1. AC Question's Avatar
    I have a Samsung Galaxy S6 and since i upgraded to Nougat, my wifi goes out when i am in sleep mode.
    When i go out sleep mode, it takes a while but reconnects again, it doesn't matter what network i am on, it always happens.
    I have "Keep Wi-Fi on during sleep (Always)." but it is not helping.
    I do not have battery save apps, nor do i use battery optimization.
    What could be wrong with my phone ?!
    06-27-2017 09:52 AM
  2. PJRed2008's Avatar
    Welcome to the forum. I'm at a loss on this one, but I suspect a hidden setting somewhere associated with sleep. Have you tried to remove the network association and then make a new connection? I would have gone with the router but you said it happens with all networks, so that pretty much means the phone. I'll ask that your post be moved to the S6 forum, hopefully you'll get an answer there.

    If you need additional help or have more questions or details to share, please join the site so you can reply in this thread. See this link for instructions on how to join Android Central.
    06-27-2017 11:05 AM
  3. Javier P's Avatar
    Mod note. Thread moved to the S6 forum for better visibility.
    06-27-2017 11:08 AM
  4. IAmSixNine's Avatar
    Or possibly a third party app for power saving.
    06-27-2017 03:54 PM
  5. PJRed2008's Avatar
    Or possibly a third party app for power saving.
    Yeah, good point. Booting to safe mode would most likely pin that down.
    06-27-2017 04:43 PM
  6. Tyronewashingron3's Avatar
    I'm having this same issue, recently after my Galaxy S6 updated to Android 7, the wifi disconnect on lock screen started. I've checked the "keep wifi on during sleep" and it was set to always. I suspected this issue had something to do with the device manager, which kept putting applications to sleep, so I disabled it, but thay did not resolve the issue. I havent installed any new applications since the android uodate.
    06-28-2017 03:55 PM
  7. mad-mega's Avatar
    Yeah, good point. Booting to safe mode would most likely pin that down.
    Sorry for the late reply.
    I have booted in safe mode, so far so good.
    If my wifi doesn't disconnect, how do i know what program is causing this in normal mode?

    EDIT:
    It went fine for an hour or so, but just right now it came out of sleep mode, and it was connecting again with wifi, which means that it was not connected to wifi in sleep mode
    07-13-2017 02:56 AM
  8. krisqz's Avatar
    I have a polish language on my phone so don't know how it's named in english but there is a setting in developer options to more aggressively switch to mobile data if WiFi has a weak signal. Is it possible you have it enabled?
    07-16-2017 02:07 AM
  9. mad-mega's Avatar
    I have a polish language on my phone so don't know how it's named in english but there is a setting in developer options to more aggressively switch to mobile data if WiFi has a weak signal. Is it possible you have it enabled?
    I found it, but it is turned off :-(
    07-18-2017 03:32 AM
  10. Rene666's Avatar
    It seems an issue that started with Android 7 but recently I saw the same problem in Android 8.
    Reproduction is very simpel: use a ping utility on another phone or computer on the same Wifi network.
    Switch off (sleep mode not power down) the phone you are pinging and after a few minutes you will see that the destination cannot be reached anymore.
    Same result in safe mode.
    Tested on:
    Nokia 6
    Wileyfox swift
    Wileyfox Spark +
    Lenovo P1

    So all Android 7 and 8 users have this problem.
    Sadly almost all problems on this issue are ignored on most forums...
    09-25-2017 05:45 AM
  11. boomerfss's Avatar
    This has been driving me nuts for over a year. I stream music in HIFI so it chews up data.

    This works for me...Go to "Battery and power saving"...Battery usage"..."Battery optimization"..."Ignore optimization"...then select individual apps you want to run when the phone is asleep. For me the App I want running on WIFI is Sonos as I am streaming music.

    Now my WIFI is always on when I am using Sonos, even after a long period of time.
    12-31-2017 03:05 PM
  12. haytham-med haytham's Avatar
    I had this problem occuring 5 minutes after I lock my phone, switched lock screen to swipe and it's now gone. Guess it was caused by smart lock , using Nokia 2 android 7.1.1
    02-13-2019 05:36 PM

Similar Threads

  1. Replies: 10
    Last Post: 08-03-2017, 01:39 PM
  2. Second Screen shortcut choices? Really Limited to 5?
    By Thomas Bjornsen in forum LG V20
    Replies: 9
    Last Post: 06-29-2017, 07:30 AM
  3. Replies: 1
    Last Post: 06-27-2017, 11:12 AM
  4. Turn on caller id
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 06-27-2017, 10:09 AM
  5. Is it still safe to submerge my phone after I dropped it?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 06-27-2017, 09:22 AM
LINK TO POST COPIED TO CLIPBOARD