1. Slade8525's Avatar
    Hi, joined to see if anyone else is having the same problems with their S7 Active that we are. If you could kindly try to replicate this issue and post your results that would be great...

    Open 'Activity Zone'
    Click on 'Compass'
    Click on 'Mode'
    Click on and change 'View Mode' from 'Normal' to 'Map'
    (Azimuth mode makes no difference)

    Does it say 'Google Play services are updating'?


    It appears to be a universal S7 Active issue, based on 9 out of 9 Active users (4 personally visually confirmed) thus encountered. It also appears to be a simple software issue (it would be nearly impossible to be a hardware issue unless we all just HAPPEN to share the same one in a(n) (unknown transistor count but obviously well up there) transistor malfunction, which is statistically improbable {impossible as hardware proves otherwise} as the changes range in the one in a trillion range for it to happen to more than 3 devices, based solely on previous Qualcomm figures), based on 2 units improperly responding, and extrapolating that statistically based on responses seen below, clearly we have a software issue; minor in ways, yet considering it is a major feature of a premium, carrier specific device, it should thusly receive premium carrier specific attention to fix.

    Please note the math is irrelevant as all required support software (eg google play services, google play store, google maps, samsung active zone, samsung active zone compass, etc all work flawlessly, individually. It may be a minor thing, but the fact its broken out of the box is a major thing; it SHOULD work; it CAN work. Obviously at some stage, to pass QC, unless samsung and at&t were clearly negligent, it DID work; and it is probably an easy fix, on their end, as ive gone to my wits end and the ends of my capacity to try to fix it, to no avail.

    I tried everything over the past 3 days (pretty advanced Android user) even down to complete wipe and factory reset; no dice. Basically, a rather critical feature requiring both Google Maps and Compass feature, to properly orient a map to a compass is NOT working in any capacity; see below.


    Please let me know ASAP! 9 out of 9 S7 Actives share the same issue.

    Thanks!
    07-04-2016 07:39 PM
  2. planoman's Avatar
    Do you have your location set on the highest setting?

    Update: mine does the same thing in map mode. Google play services updating.

    Posted via my S7 Active with Samsung Pay!
    07-04-2016 08:36 PM
  3. jlczl's Avatar
    Same: Google Play services updating
    07-04-2016 09:30 PM
  4. Mal Lignant Tumor's Avatar
    Mine does the same thing.
    07-04-2016 09:35 PM
  5. andrew_ackley's Avatar
    Mine too weird.

    Posted via the Android Central App
    07-04-2016 09:56 PM
  6. Slade8525's Avatar
    Planoman, jlczl, andrew_ackley, thank you for confirming this is not simply a very rare multi-unit hardware failure, but software related. I shall PM you tomorrow requesting screenshots of device information (please blur out IMEI and other personal information, i will reiterate that in my PM's).

    I adore this device and i want it fixed, to be frank.

    I have spent literally 3 days trying to resolve this alone with 2 unique S7 Actives; i had been a Dev and contributor off and on for WinMo and Android for years. In any event... The hardware checks out (obviously).

    This is a software issue. Means it can be fixed by Samsung and pushed by AT&T easily. As to the expediency within a reasonable timeframe; we shall see. Personally, i may return our units and demand a refund or compensation; my GF is an attorney, while i work in both securities and advertising. Legalities and implied/expressed warranties features and expectations are our specialties.

    I check out EVERYTHING in a new device; every setting, every app, every feature. I am ashamed it took me over 2 weeks to find this; and i was ignorantly planning on using it as a primary source for orienting myself, keeping a physical map and precision calibrated compass with us, as well as a nice Casio Rangeman (A/B/C with Thermometer watch) with us as well as a very precise GPS unit just in case. With that said...

    ...Well then Ladies and Gentlemen, we have ourselves a serious issue; whether the fault lies at the feet of Samsung or Google does not matter; for a major selling point on a $794.99 (plus tax) device, for a rather critical element therein featured as reliable and accurate, it SHOULD work.

    Its a major concern of mine as i intended to use this feature, here in the Eastern US as well as Colorado/Wyoming and elsewhere, abroad as well.

    Samsung offered to RMA my device, which i politely declined citing no hardware failures, and a preference to 'swap' it out at an AT&T store worst case scenario.

    Thank you all, and please, to every one else, please check it out, feel free to PM me or post here, and i shall get back to you as quickly as i am able.
    07-04-2016 10:17 PM
  7. Soreloser's Avatar
    Mine does this as well, so add one more...
    07-04-2016 11:07 PM
  8. jchybinski's Avatar
    Same here... Unfortunately 😕

    Posted via the Android Central App
    07-05-2016 06:27 AM
  9. htcrazy's Avatar
    Same here. By the way, I installed Compass Pro by gabenative. I calibrated both it and the Active compass according to instructions. Pointed both devices in same direction. Compass Pro shows a reading of 321 degrees NW which looks correct and Active compass shows 239 degrees SW so something is obviously not right.
    07-05-2016 08:25 AM
  10. Rds030903's Avatar
    Same here on my wife's. She has the gold edition. I won't know about mine until i get it back from samsung
    07-05-2016 03:47 PM
  11. Slade8525's Avatar
    BUMP.

    Latest carrier update (Wifi Calling, AMBS Phase 3, IPME, Advanced Messaging) has removed 'Map' mode on 'Compass' feature of 'Activity Zone'.

    Irritating, but thread no longer needed. Shame; it was a GREAT idea, actually, and one that i used all the time with physical compass and physical map; this would have been SO much more convenient.
    FLTimmyB likes this.
    08-09-2016 09:28 PM
  12. htcrazy's Avatar
    On mine after update, if you open activity zone, click on compass and then click on mode, nothing happens. If you click on mode a second time, it says "unfortunately activity zone has stopped". Anyone else?
    08-10-2016 06:25 PM
  13. TylerLV76's Avatar
    On mine after update, if you open activity zone, click on compass and then click on mode, nothing happens. If you click on mode a second time, it says "unfortunately activity zone has stopped". Anyone else?
    Mine seems to work fine. Gives me normal, camera and night mode.
    markbc likes this.
    08-10-2016 07:43 PM
  14. htcrazy's Avatar
    I guess my phone got borked by the update then.
    08-10-2016 08:13 PM
  15. markbc's Avatar
    My activity zone works well, but no mapping function or display..
    08-11-2016 01:14 AM
  16. htcrazy's Avatar
    I guess I could try a factory reset, but I really hate to do that. There are quite a few good compasses available in the Playstore.
    FLTimmyB likes this.
    08-11-2016 06:25 AM
  17. htcrazy's Avatar
    Problem solved. Had to bite the bullet and do a factory reset. It now works as it should.
    08-11-2016 08:34 AM
  18. FLTimmyB's Avatar
    I'm glad it was an easy fix...granted a pain but a easy fix. the old motto this too will pass, like a kidney stone but it will pass
    08-11-2016 08:43 AM
  19. brian kerbe's Avatar
    The activity app needs to be located on a main screen, drag the app out of the Samsung folder and place it on the bottom bar or somewhere other then the Samsung folder.
    12-16-2016 06:19 PM

Similar Threads

  1. Replies: 24
    Last Post: 12-16-2017, 06:49 PM
  2. Replies: 2
    Last Post: 07-06-2016, 08:57 AM
  3. How to stop keyboard on Android s4 to stop popping up
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 07-05-2016, 05:06 PM
  4. Replies: 0
    Last Post: 07-04-2016, 06:42 PM
  5. Replies: 1
    Last Post: 07-04-2016, 06:06 PM
LINK TO POST COPIED TO CLIPBOARD