10-25-2016 05:33 PM
59 123
tools
  1. Graham Berg's Avatar
    My 3 wk old s7 edge died completely seven days ago while I was out of the country. None of the forced button restart options worked. I shipped the phone off to a Samsung Support Center last Monday. Hopefully I'll get it back at the end of the week.
    08-07-2016 08:30 PM
  2. soyunespia's Avatar
    The same hapened to me 2 days ago, but unfortunately it didn´t woke up with any buttons combination.
    Went to the dealer, and i´m suposed to get a new replacement within a week.

    Purchased it in Buenos Aires, Argentina, cost me about USD 1000

    Opening the phone is not a solution, we might get a new one. Out of question....
    08-25-2016 12:22 AM
  3. Roynato's Avatar
    Damn... this is a terrifying thread indeed...

    We can maybe try and look for some common factors.
    I see a lot of posts talking about the problem happening when messing around with Gear VR.
    What else? any other update or something that you guys remembered doing?

    You guys got me freaked out now
    08-25-2016 07:28 AM
  4. mru007's Avatar
    Since this issue showed up on a newly purchased phone, I would go to a service center (the chip may be faulty).
    Though the phone is now up & running, I would recommend you to check the same.
    Also perform a 'Wipe Cache Partition' via Recovery Menu.
    08-25-2016 07:59 AM
  5. CoolBeit's Avatar
    I'm pretty sure what *most* of you are experiencing is a pretty common android problem. Usually the power button+volume up fixes it. It usually happens when the battery gets drained too low. So I wouldn't worry about returning any phones if charging for a couple hours fixed it or if power+volume up revived it.
    08-25-2016 12:11 PM
  6. TriSoler's Avatar
    Thank you for this. Mine died too even at 70% batt. This worked!
    09-08-2016 06:03 AM
  7. Ogeron's Avatar
    Same thing happened to me today, and the posted fix worked straight away, thank you! The only out of the ordinary thing that happened before it died is that I had a notification of a firmware update - I hadn't downloaded it though.
    09-09-2016 01:42 PM
  8. JoshRout's Avatar
    The same thing happened to me but when I held those buttons it wiped my phone back to factory settings.
    10-24-2016 02:00 AM
  9. Can9 SA's Avatar
    I followed your suggestion after pushing buttons to no avail when my phone died. Took it out of it's protective cover and then held down all the buttons suggested above. Voila it came back on ... the little green arrow within the battery icon showed it was again alive and had started to charge. Thank goodness as I LOVE this cell phone and camera. I know I caused it to die by taking photos outside in the dark.So it didn't just die... it's human operator had a hand in it. But not responding when it was plugged in was scary. Until I googled the subject and tried this person's suggestion. Thank you.
    10-25-2016 05:33 PM
59 123

Similar Threads

  1. MMS photos missing after transfer to S7
    By jaxsta in forum Samsung Galaxy S7
    Replies: 3
    Last Post: 03-11-2016, 10:49 PM
  2. Frustrated with my S7 Edge
    By obana1990 in forum Samsung Galaxy S7 edge
    Replies: 5
    Last Post: 03-11-2016, 03:04 AM
  3. Replies: 0
    Last Post: 03-10-2016, 11:01 PM
  4. Replies: 3
    Last Post: 03-10-2016, 09:26 PM
  5. moving photos with galaxy s7 edge.
    By Constance Barrett in forum Samsung Galaxy S7 edge
    Replies: 0
    Last Post: 03-10-2016, 09:18 PM
LINK TO POST COPIED TO CLIPBOARD