10-23-2017 09:29 AM
40 12
tools
  1. kneedeep64's Avatar
    I'm having issues with my wireless charging on my s7 Edge with my 16 GMC Sierra. It works perfect on my samsung wireless charger. I have tried naked and with a case and still won't pick it up. Anyone else having issues? Is there a setting that needs to be turned on in the phone? Thank you for help.
    03-14-2016 04:59 PM
  2. Lobwedgephil's Avatar
    Does it work on other phones?
    03-14-2016 05:11 PM
  3. TMavC5's Avatar
    I'm having issues with my wireless charging on my s7 Edge with my 16 GMC Sierra. It works perfect on my samsung wireless charger. I have tried naked and with a case and still won't pick it up. Anyone else having issues? Is there a setting that needs to be turned on in the phone? Thank you for help.
    Is it QI compatibility? Make sure its not PMA.
    03-14-2016 05:12 PM
  4. dpham00's Avatar
    S7 should support both
    03-14-2016 05:22 PM
  5. TMavC5's Avatar
    S7 should support both
    Nope, does not support PMA. I have PMA wireless from Panasonic, it wouldn't even charge.
    03-14-2016 05:39 PM
  6. NuMotiv's Avatar
    Its definetly PMA. I'm not sure what samsung supports other than I know its QI 2.0

    EDIT: I saw a few reviews say it was both QI and PMA.
    03-14-2016 05:53 PM
  7. Kevin OQuinn's Avatar
    It definitely supports both standards:

    Which wireless charging pad should you buy for the Galaxy S7? http://www.androidcentral.com/which-...-buy-galaxy-s7
    03-14-2016 06:13 PM
  8. Lobwedgephil's Avatar
    OP, try setting your phone on the pad before you turn your car on, and then see if it starts charging when you turn your car on. A lot of recent GM SUV models have finicky chargers and that should tell you if it works at least.
    03-14-2016 06:20 PM
  9. aggie's Avatar
    Neither my s7 edge or note 5 work on the wireless charger in my wife's tahoe. I've yet to see one that works properly on any GM model.

    Posted via the Android Central App
    03-14-2016 06:31 PM
  10. Lobwedgephil's Avatar
    My s7 edge works fine on my GM SUV.
    03-14-2016 06:46 PM
  11. b_rianw's Avatar
    I have similar issues with my S7 in my 2016 Sierra. I have had it connect maybe 5x. I had a friend try his S7 edge and it connected. Once his connected we took his off and mine was connecting. I left the vehicle came back later and it would not connect again. I have been able to get it to connect once with shutting the phone off and placing on the mat once, then could not replicate. If you figure it out would love an answer.
    03-24-2016 03:24 PM
  12. Gator352's Avatar
    I'm having issues with my wireless charging on my s7 Edge with my 16 GMC Sierra. It works perfect on my samsung wireless charger. I have tried naked and with a case and still won't pick it up. Anyone else having issues? Is there a setting that needs to be turned on in the phone? Thank you for help.
    So your the one who stole my truck!

    J/k!

    Posted via the Android Central App
    03-24-2016 05:11 PM
  13. lilmike304's Avatar
    My 2016 Sierra has the same issue with my S7 edge. It works for KY sons s6 active.

    Posted via the Android Central App
    03-24-2016 05:54 PM
  14. jeepin2001's Avatar
    I have had similar issues. I can get it to work without a case, but it is really temperamental on placement. It doesn't work more often than it works.
    03-30-2016 02:31 PM
  15. lakemurrayskier's Avatar
    Same issue with my Verizon Galaxy S7. It will show green charging error on screen for about 4 seconds and then disappear. Never shows on phone that its charging. I have gotten in to work twice out of about 75 times. It's been in the shop 3 times for it and they say the GM tool they use to test shows that it is good and working. I also had them apply the new Android Auto update to Intellilink and it does not work either. The S7 won't recognize Android Auto even after the GMC firmware update. Very frustratrating!!
    04-05-2016 07:12 PM
  16. gto4spd's Avatar
    I just took my 2016 Tahoe LTZ into the dealer today to get my console charger looked at since I have been unable to use my GS7 Edge with it. It also intermittently worked twice. They said it was working since they tried a GS6 and a Motorola and they started charging immediately. I went to Sprint right after that and baffled them (they didn't have a GS7 to try it with. I think I'm going to contact Samsung as I want to use the wireless charger as it was meant to be.
    The Chevrolet dealer also installed Android Auto which I couldn't get working right away. I got home and found out you had to do several things to get it active. 1) you need to connect a data cable to a USB port. 2) You have to go into your phone and enable Mirrorlink. 3) you have to go into your settings area in your vehicle and enable Android Auto. After a while you get a notice on your phone that in order for any of this to work you have to download and install several google apps. It gets ok from there but still doesn't allow me to text from speech like they told me I could at the dealership. It really is not that impressive. Hope this helps.
    04-19-2016 07:55 PM
  17. Ratchet1's Avatar
    Hello everyone,

    I am also having a problem with the S7 Wireless charging on my 2016 Sierra. I started doing some research on the mat in the truck and it says that its a PMA 1.0 so I thinking its a 1 amp charge (please correct me if Im wrong)

    Well, I have a Charging pad from Samsung that requires the 2 amp charging cable to work and that works fine. So I figured that I would do a test of my own with my pad and my old S5 charger (which is a 1 amp charger) and the charger isn't strong enough to charge the phone, it will start charging for a few seconds and then pause.

    Could it be that the PMA in the vehicles just aren't strong enough?
    04-27-2016 10:02 PM
  18. oneformula's Avatar
    Good luck- I can't get any of the electronic features of my Cadillac to work as advertised consistently.

    Posted via the Android Central App
    04-27-2016 10:47 PM
  19. mcdonsco's Avatar
    I had an s7 and have a 2016 Sierra denali and it works fine on the wireless charger, albeit slow. If I had a case on it at all though it wouldn't work. Unfortunately it seems to be low power. But with a naked s7 should work fine. But you do have to have the bottom of the phone lined up against the bottom of edge of the pad, if it's up front it won't charge (coils don't seem to be lined up there, only at rear).
    05-15-2016 10:46 AM
  20. jeff osborne's Avatar
    I THINK I FOUND A SOLUTION! ! Place your s7 edge about 1/4 inch past the rubber bump stop. It will raise the rear of the phone slightly but it should begin charging. A few times I've had to remove it and replace it a couple of time but it's been pretty consistent.
    Just to be clear, place the bottom of the phone about 1/4 past the rear bumper on the charging pad. I can't tell you why it works but I sure hope this helps others. BTW, my wife's note 5 wouldn't charge either but this pavement works for it as well.

    Good luck!
    05-27-2016 08:10 PM
  21. jdh4's Avatar
    The charger has worked on my 2016 yukon denali and the s7 edge but I do have to remove the case most of the time. Sometimes it works with the case on it but with no case everytime

    Posted via the Android Central App
    05-27-2016 09:15 PM
  22. mcdonsco's Avatar
    Same issue, s7 edge in a Sierra Denali 2016. I had a standard s7 originally and it worked without a problem, so not sure why this one won't work.

    EDIT: I got it working by removing the piece of rubber over the wireless charger which just pulls out it's not in any way attached with glue or screws or anything it just pulls right out without that my S7 Edge charges no problem instantly as soon as I lay it down. So I think when I get home I'm going to cut out the ridges on that insert so the phone is closer to the charger which should help.
    06-08-2016 08:07 PM
  23. Joseph Colandreo's Avatar
    Great fix! I just turned the rubber piece 180 degrees and reinstalled it! Works perfect! You will have to cut the little nub on the bottom of the rubber mat so it will lay flat!

    Been working perfect for two days! Didn't cost a dime and only took about 5 minutes. If you use a very small screw driver pull the sides in at the middle (both sides). Pull it out. To reinstall put the ends in first then the sides.

    Nothing to it! Ajust the phone so the bottom edge of the phone just covers the orange warning labe.

    I have a 2016 Silverado 2500HD and a Samsung S7 Active.
    07-22-2016 12:29 PM
  24. PaulNY's Avatar
    Great fix! I just turned the rubber piece 180 degrees and reinstalled it! Works perfect! You will have to cut the little nub on the bottom of the rubber mat so it will lay flat!
    Registered to say thank you, this worked for me!

    Just picked up a '16 Sierra 2500HD a few days ago and it was bugging me that my S7 Edge wasn't charging. I just had to pry off the rubber and cut off that little nub at the bottom and rotate it and its been working all day.
    07-23-2016 08:13 PM
  25. LaLaLaFevers's Avatar
    How did you get the rubber mat out without damaging the mat or the surrounding plastic?
    Thanks for any info
    08-06-2016 12:29 PM
40 12

Similar Threads

  1. At&t recent 3/10 update kills wireless fast charge?
    By Kev_N in forum Samsung Galaxy Note 5
    Replies: 5
    Last Post: 05-10-2017, 09:47 AM
  2. Replies: 4
    Last Post: 03-16-2016, 04:58 AM
  3. Wireless charging / Screen comes on.
    By Dhawk1202 in forum Samsung Galaxy S7 edge
    Replies: 10
    Last Post: 03-15-2016, 08:46 AM
  4. Why xiaomi phone battery decreassing while charging
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 03-14-2016, 05:15 PM
  5. Replies: 0
    Last Post: 03-14-2016, 07:31 AM
LINK TO POST COPIED TO CLIPBOARD