08-24-2017 03:48 AM
40 12
  1. Gregg-1869's Avatar
    I had the same problem. Could not download via wifi with my Galaxy S7 and Netgear c6300 router.
    I FINALLY found out that if I turned on GUEST mode with a password that I could then download after connecting to the GUEST network ssid. I spend days trying to get this to work and netgear support is useless
    04-03-2016 03:25 PM
  2. RiaHannam's Avatar
    I had the same problem, Galaxy 7 with Tmobile, can't access Google play or stream Pandora. I turned on the ipv6 on Dlink router, tunnelling 6to4 address. That fixed the problem. Good luck.
    YES this worked for me too! I have T-Mobile, Comcast as ISP, and a Belkin router. Hopefully this will work for a lot of other people too.


    *updated to add that just today I noticed my phone having problems. It's not working again over WiFi at home even with the above solution still enabled. Looking back to my google photos I narrowed it down that the 'fix' only worked for 3 days. Lovely.*

    **Update #2. Used Guest Access on router --------- and it works! I cannot figure out WHY it works, but I'm happy for the time being.

    **Update #3. Turns out this was an Android issue, not a Samsung one. An update last month cured the issue. WiFi works normally as it should now! H a p p y !
    04-09-2016 11:10 PM
  3. Sam Daves's Avatar
    i found a fix finally from the att forums. I unchecked the enhanced 4g lte in settings under mobile data. I have no clue what it means but finally i can watch youtube and listen to pandora on this new phone!
    thanks so much!!! 3 weeks and 2 new phones and all i needed was this one tip
    04-21-2016 11:23 PM
  4. sampro01's Avatar
    The fix "turning of Enhanced LTE features" sounds great, but now you can't make HD calls. Sounds stupid/minor, but I really enjoyed that feature. It's ridiculous that you'd have to loose that feature just to make the App Store work.
    05-06-2016 08:17 AM
  5. Krista St's Avatar
    I did everything you did. Nothing. Someone mentioned reset the router for the heck of it. I did. Now it works and can downloand on WiFi
    05-12-2016 09:09 PM
  6. Ladydi1928's Avatar
    I've had the same problem. Just bought the S7 and as soon as android updated from 6.0 to 6.0.1 is when the problem began. I read somewhere to take the check mark out of Enhanced LTE Services and it should work. I've done that and it works. This is really just a work around and not a solution but it works for me. If I put check mark back in, I can't download from the playstore. When I take it back out again, I can download.
    05-23-2016 03:56 PM
  7. TaylorGT's Avatar
    For what it's worth none of the suggestions here worked. BUT. the opposite did. I have an Archer C3200 and ENABLING IPv6 as well as turning on the guest network feature did the trick for me. I rebooted my phone to be sure. This was not a problem with my Nexus 5X. Glad this is resolved now.
    05-24-2016 08:32 PM
  8. Voldi Way's Avatar
    Disabling IPv6 on my SonicWALL did not fix the problem. Didn't have this issue with the HTC One M8 that I just replaced with the S7. Any other ideas?
    I disabled IPv6 on my SonicWALL by checking the box that said "Disable all IPv6 Traffic on the Interface" and that totally solved the problem. Are you sure you disabled it for the interface that your S7 is connecting through (In my case, X0)?
    06-09-2016 12:15 PM
  9. Zaid1988's Avatar
    Ok so I fixed the problem with my Galaxy S7 from Rogers in Canada by going into my D-Link router settings (typed http://dlinkrouter in my browser), advanced settings, IPV6, and switching from "link-local only" to "6to4".....the page refreshed for a few minutes and suddenly my GS7 works perfectly fine. I hope this helps someone.

    I should mention that my phone worked fine on other wifi networks but had the problem only at home. This prompted me to think that the issue was with my internet not my phone. I didn't have this issue with my nexus 5.
    06-11-2016 03:29 PM
  10. daweeze02's Avatar
    I can confirm only 5ghz and guest network work with my S7. Regular 2.4ghz brings the Google Play Store to a hault
    07-29-2016 08:24 AM
  11. Russsmale111's Avatar
    Try typing the ipv6 address you find in settings on your phone into your search engine. I did with mine and it came back saying it was a google redirect.
    08-17-2016 12:34 AM
  12. JAT2's Avatar
    I have a Galaxy S7 and when I download an app it doesn't appear anywhere. Is there a dedal
    08-20-2016 05:08 PM
  13. JAT2's Avatar
    Sorry, is there a default file where they appear?
    08-20-2016 05:09 PM
  14. Lauren Boughton's Avatar
    Disable ipv6 on router
    Yes. This worked for me. Took me forever to figure out how though, because I am not at all tech savvy

    Finally figured it out:

    Go to Settings->connections->wifi

    Then click on your wifi then it will say Go to Web page and have http://192:something something: --'> click it.

    On that page it brings up ,click home network then under that u will see ivp6 --click it.

    Then u have to enter Access code which is on side of router (not your wifi password). Then after u enter that it will come up and the 1st ipv6 option disable it..save and hopefully your phone works now!

    I contacted Samsung and all they kept saying was it was a Google Play issue but I knew it wasn't because Google play worked fine on my other devices. So I contacted AT&T then went through technical support for both phone and internet...they ended up replacing my router...still didn't work. Finally found this forum and figured it out!! Didn't need a new router but oh well it'seems better one than I had...
    12-28-2016 04:24 PM
  15. bratt28's Avatar
    I have owned my edge 7 for over a year and never had any problems until recently when it did a couple updates. Now I cant download anything at all off the play store. Even apps that have been previously installed on my phone. My case stopped displaying the LED notifications. And my OK Google wont listen to a dam thing I say. Its like talking to a teenager.
    I know my router is not the issue. Mistly necause I dont have a router so how else can the problem get resolved.
    08-24-2017 03:48 AM
40 12

Similar Threads

  1. Replies: 2
    Last Post: 03-16-2016, 04:17 PM
  2. Can you get a Music player widget on the lock screen S6?
    By AC Question in forum Samsung Galaxy S6
    Replies: 2
    Last Post: 03-15-2016, 04:21 PM
  3. Samsung S7 Edge connecting to other mobile phones, is it possible?
    By AC Question in forum Samsung Galaxy S7 edge
    Replies: 1
    Last Post: 03-15-2016, 02:51 PM
  4. Why do my apps keep disappearing from my home screen?
    By AC Question in forum Android Apps
    Replies: 1
    Last Post: 03-15-2016, 11:02 AM
  5. Device not found with adb, can anybody help?
    By nababy12 in forum Android 5.0 Lollipop
    Replies: 1
    Last Post: 03-15-2016, 10:03 AM