07-21-2016 06:17 PM
34 12
tools
  1. piannetta's Avatar
    I had the S6 Edge and ran into the same problem. Very frustrating. I love using the notification led to tell me what info is waiting on my phone. The work around was not working for me with Lightflow.

    I read a ton of forums and ended up buying Light Manager. It works perfect for me. I use about 6 or 7 colors, my green text led blinks fast. Emails purple, snapchat yellow, calender blue, hangout white and others. Also alternating mode works well too. So if I have multiple notifications the colors alternate. I can't complain and fully recommend it.

    Not sure what you want to out of your led manager but I hope this helps. Light Manager works great for me on my S7 Edge.

    https://play.google.com/store/apps/d...ightmanagerpro

    Posted via the Android Central App
    Light manager seems to be working fine on my S7 Edge too
    04-29-2016 03:57 AM
  2. Ryza321's Avatar
    Light manager seems to be working fine on my S7 Edge too
    What can I do to eliminate the light flow persistent notification? Besides, I would like to know why if I use what's app to configure my led's color I don't get the notifications anymore. I don't understand how to configure this app.
    04-29-2016 05:07 AM
  3. meyerweb#CB's Avatar
    Are you sure you downloaded the Legacy version? When I look in the app manager, one of mine is clearly labeled as Lightflow Legacy.

    Notification Light Solutions-screenshot_20160429-170111.jpg

    When you installed the second version, did it ask if you wanted it to disable the prior install? If not, I'm not sure you installed Legacy.

    Here's the one that should be installed first: https://play.google.com/store/apps/d...roid.lightflow

    And Legacy, which should be installed second: https://play.google.com/store/apps/d...owlegacy&hl=en
    04-29-2016 04:07 PM
  4. jell91's Avatar
    not sure if anyone else has experienced this problem, but for some of my apps through light flow, i'm getting a red led flash before it turns to the colour i've selected? namely the two i've noticed are inbox and snapchat, any idea on how to fix this? i've followed all the points laid out previously on this post.
    04-29-2016 04:10 PM
  5. Ryza321's Avatar
    Are you sure you downloaded the Legacy version? When I look in the app manager, one of mine is clearly labeled as Lightflow Legacy.

    Click image for larger version. 

Name:	Screenshot_20160429-170111.jpg 
Views:	25 
Size:	108.1 KB 
ID:	226025

    When you installed the second version, did it ask if you wanted it to disable the prior install? If not, I'm not sure you installed Legacy.

    Here's the one that should be installed first: https://play.google.com/store/apps/d...roid.lightflow

    And Legacy, which should be installed second: https://play.google.com/store/apps/d...owlegacy&hl=en
    Yes I am sure. On my S7 Edge I don't see what you see, I see two "Light Flow" app. When I run Light Flow Legacy, it ask me if I want to disable the other version, I said yes, but nothing change. Other than that I have other issues as I wrote before. Thank you for your help, if you can help me to solve those problems I'll buy you a beer
    not sure if anyone else has experienced this problem, but for some of my apps through light flow, i'm getting a red led flash before it turns to the colour i've selected? namely the two i've noticed are inbox and snapchat, any idea on how to fix this? i've followed all the points laid out previously on this post.
    This is a know S7 issue, the famous first red blink.
    sinfoman likes this.
    04-29-2016 04:21 PM
  6. recDNA's Avatar
    Lightflow Legacy seems to be working fine for me now, with AOD on or off, after following all the steps recommended on their web site. If you just install it, and expect it to work, you'll be disappointed. Here's what I did, IIRC:

    1. Download and install the regular paid version. Don't bother to set up any notifications.
    2. Download and install Legacy. It will alert you that you need to disable, but not delete, the full version, and offer to disable it for you. Accept that option. This is NOT the same as disabling an app in the application manager. Don't disable it in the application manager.
    3. At some point, it will prompt to to enable the Samsung workaround. Choose that setting.
    4. In the phone settings, go to Lock screen and security / Other security settings / Device administrators. Make sure Light Flow Legacy is turned on.
    4. Do NOT turn on administrators
    5. In device Settings, go to Accessibility, scroll all the way down, and make sure Light Flow Legacy in On. (Not sure if this is really necessary, but it's working with this enabled, and it won't hurt anything).
    6. Back to Lightflow Legacy: In General settings, check (or make sure these are checked): Enable Light Flow, Show LED in Priority Mode, Accessibility check.
    7. Go to Lightflow Legacy and set up your notifications. For some apps you'll need to check the Switch screen on and Wake screen when in pocket options to get notifications to work. To minimize the impact of this, set Screen on length to 0.3 seconds. I don't even notice the screen flash To avoid the issue with screen locking and needing to use a PIN to unlock the screen, choose "Phone screen default length" as the value for Screen on length. The drawback to this is that your screen will light up for 5 to 10 seconds when you get a notification for these apps, but it's the only way to avoid the pin locking problem.
    7b. Apps I know require these settings include Gmail, E-mail (Samsung's app),
    8. For the built-in SMS app, if you have problems, uncheck the boxes for Monitor SMS Conversations, and check the option for Monitor notification bar.
    9. Finally, go back to device Settings, choose Notifications, click Advanced, scroll down to Light Flow (not Legacy), and and turn off notifications. Make sure notifications are ON for Light Flow Legacy.
    10. In device Settings / Display, make sure LED indicator is set ON.

    With these settings, everything seems to be working for me, with the only drawback being the screen turns on for notifications from Gmail and Email. If you set up notifications for an app and just get the regular Blue LED instead of what you've programmed, follow step 7 for that app.
    The screen on option is a problem for me since l like screen on default to be 10 minutes and that is a battery drain.

    Thanks for the very detailed instructions. I really appreciate the time and effort it took.
    05-13-2016 03:14 PM
  7. meyerweb#CB's Avatar
    The screen on option is a problem for me since l like screen on default to be 10 minutes and that is a battery drain.

    Thanks for the very detailed instructions. I really appreciate the time and effort it took.
    I don't think this default value is the same as you've set in the display options. I have my display time out set to 1 minute, but when I get a gmail notification the screen goes off in less than 10 seconds. I'm not sure where this default value comes from, but I don't think that will be a problem for you.
    05-13-2016 03:41 PM
  8. chrisd#AC's Avatar
    Hi all, I appreciate the research on this (particularly meyerweb's instructions). I had trouble getting Gmail LED notifications to work after following these steps and wanted to give a heads-up in case others have the same problem, or if anyone can think of something I might have missed.

    Setup: I followed meyerweb's instructions from post #9.

    Symptom: Gmail LED notifications would work fine in Light Flow Legacy's test function, but when new mail arrived the LED wouldn't blink at all. (I know the notification was firing because I still heard the alert sound I configured.) To emphasize, it wasn't even getting the default blue LED.

    My fix: I had to disable Light Flow's Samsung workaround. After doing that (and changing nothing else), Gmail LED notifications are now working fine and showing the custom color I set (not Samsung's default blue). I know there's some occasional confusion around the status of this setting, so to emphasize, my Light Flow Legacy is showing the "Enable workaround" button, meaning the workaround is currently disabled for me.

    So far I'm not seeing any consequences from disabling the Samsung workaround, though it's possible some issues could crop up during continued use. At any rate, consider toggling that option if anyone else has the same issue.
    05-15-2016 06:50 PM
  9. futurepro62's Avatar
    Hello, thanks for this fix! It is working really well for me thus far. On step 7, where you indicated that the screen on will have to be on for certain apps, I have noticed that the screen turns on for ALL of my apps, not just Gmail. All the other apps don't have the screen on setting selected so I don't know why they are popping the screen for their notifications. Is there a way to fix this? I'm afraid it is going to demolish my battery.
    07-21-2016 06:17 PM
34 12

Similar Threads

  1. Replies: 44
    Last Post: 08-09-2018, 02:01 AM
  2. Replies: 6
    Last Post: 03-16-2016, 05:32 AM
  3. Does the Telegram notification appear in the second screen?
    By AC Question in forum Ask a Question
    Replies: 2
    Last Post: 03-15-2016, 03:58 PM
  4. Replies: 2
    Last Post: 03-15-2016, 02:55 PM
  5. Replies: 0
    Last Post: 03-15-2016, 02:08 PM
LINK TO POST COPIED TO CLIPBOARD