07-21-2016 06:17 PM
34 12
tools
  1. RG129's Avatar
    I've been an avid Light Flow user and have just been disappointed with the erratic performance it's been giving me on my S7e. Light Flow has been a little weird ever since Marshmallow, but even on my Nexus 6P, it seemed to function decently...but on this phone it's just not functional at all. I've tried every combination of the developer's suggestions to make it work and what I've read from other users on forums and the lights either don't cycle through the notifications properly, or they don't light at all, or they just light blue or the worst was when it was automatically killing the notifications from the status bar. And even when it sort of works, something as simple as placing the phone on my wireless pad will break the LED flashing and fight to display just the charging light.

    I've sort of played around with Light Manager but didn't seem to see any improvements without paying for the full version.

    I've resorted to uninstalling any LED manager app and just going with the default lights which don't give me any control over color and speed, but also light for notifications that I don't care about (like traffic incidents reported by Google). I'm kind of okay with that, except for the LED.....blinks....so....slowly! I have to stare at my phone for about 2 or 3 seconds just to see if the LED will blink and figure that reaching over and hitting the home button would inform me faster.

    Does anybody have any tips or tricks that have gotten any form of LED customization working?
    03-15-2016 06:38 PM
  2. SpookDroid's Avatar
    That's all on the app dev's side to fix (and granted, every time Samsung comes up with a new phone, they mess something up with the notification system... I'm looking at you, TalkBack 'bug'). Lightflow, however, has usually been quick to respond and update, but it might take a few weeks, especially if they don't have an S7 to play with (remember, not everyone got it before the official launch).

    You can help by sending in bug reports, system logs, and just notifying the dev of the issue (they can't fix what they don't know about, and the more people post about it, the faster it'll get their attention).
    03-15-2016 07:48 PM
  3. verks's Avatar
    I had the S6 Edge and ran into the same problem. Very frustrating. I love using the notification led to tell me what info is waiting on my phone. The work around was not working for me with Lightflow.

    I read a ton of forums and ended up buying Light Manager. It works perfect for me. I use about 6 or 7 colors, my green text led blinks fast. Emails purple, snapchat yellow, calender blue, hangout white and others. Also alternating mode works well too. So if I have multiple notifications the colors alternate. I can't complain and fully recommend it.

    Not sure what you want to out of your led manager but I hope this helps. Light Manager works great for me on my S7 Edge.

    https://play.google.com/store/apps/d...ightmanagerpro

    Posted via the Android Central App
    jimbo1mcm likes this.
    03-16-2016 12:46 AM
  4. bosscib's Avatar
    03-16-2016 01:24 AM
  5. RG129's Avatar
    Yea. Light Flow Legacy was giving me the same erratic behavior. Sometimes it worked perfectly and other times it didn't. I'll try to play around with Light Manager again and see if I get any success.

    Why couldn't Samsung throw in notification bar icons into the Always on Display? That would have been a good alternative.
    03-16-2016 01:34 AM
  6. bmann7777777's Avatar
    Has anyone got 'Light Manager' to work successfully on the Samsung Galaxy S7 yet? I can't seem to get my setting just right so that it will work (after loving it on my S4!)

    Thanks for the help!
    03-16-2016 06:21 PM
  7. blambtn's Avatar
    I have light manager and can't seem to get the email LED to work. It still flashes in blue even though set to white. Anyone have any suggestions? I can't find in the email settings where to turn this off.

    Posted via the Android Central App
    03-17-2016 01:12 PM
  8. blambtn's Avatar
    I had the S6 Edge and ran into the same problem. Very frustrating. I love using the notification led to tell me what info is waiting on my phone. The work around was not working for me with Lightflow.

    I read a ton of forums and ended up buying Light Manager. It works perfect for me. I use about 6 or 7 colors, my green text led blinks fast. Emails purple, snapchat yellow, calender blue, hangout white and others. Also alternating mode works well too. So if I have multiple notifications the colors alternate. I can't complain and fully recommend it.

    Not sure what you want to out of your led manager but I hope this helps. Light Manager works great for me on my S7 Edge.

    https://play.google.com/store/apps/d...ightmanagerpro

    Posted via the Android Central App
    How did you get your email light to work?

    Posted via the Android Central App
    03-17-2016 01:14 PM
  9. meyerweb#CB's Avatar
    Lightflow Legacy seems to be working fine for me now, with AOD on or off, after following all the steps recommended on their web site. If you just install it, and expect it to work, you'll be disappointed. Here's what I did, IIRC:

    1. Download and install the regular paid version. Don't bother to set up any notifications.
    2. Download and install Legacy. It will alert you that you need to disable, but not delete, the full version, and offer to disable it for you. Accept that option. This is NOT the same as disabling an app in the application manager. Don't disable it in the application manager.
    3. At some point, it will prompt to to enable the Samsung workaround. Choose that setting.
    4. In the phone settings, go to Lock screen and security / Other security settings / Device administrators. Make sure Light Flow Legacy is turned on.
    4. Do NOT turn on administrators
    5. In device Settings, go to Accessibility, scroll all the way down, and make sure Light Flow Legacy in On. (Not sure if this is really necessary, but it's working with this enabled, and it won't hurt anything).
    6. Back to Lightflow Legacy: In General settings, check (or make sure these are checked): Enable Light Flow, Show LED in Priority Mode, Accessibility check.
    7. Go to Lightflow Legacy and set up your notifications. For some apps you'll need to check the Switch screen on and Wake screen when in pocket options to get notifications to work. To minimize the impact of this, set Screen on length to 0.3 seconds. I don't even notice the screen flash To avoid the issue with screen locking and needing to use a PIN to unlock the screen, choose "Phone screen default length" as the value for Screen on length. The drawback to this is that your screen will light up for 5 to 10 seconds when you get a notification for these apps, but it's the only way to avoid the pin locking problem.
    7b. Apps I know require these settings include Gmail, E-mail (Samsung's app),
    8. For the built-in SMS app, if you have problems, uncheck the boxes for Monitor SMS Conversations, and check the option for Monitor notification bar.
    9. Finally, go back to device Settings, choose Notifications, click Advanced, scroll down to Light Flow (not Legacy), and and turn off notifications. Make sure notifications are ON for Light Flow Legacy.
    10. In device Settings / Display, make sure LED indicator is set ON.

    With these settings, everything seems to be working for me, with the only drawback being the screen turns on for notifications from Gmail and Email. If you set up notifications for an app and just get the regular Blue LED instead of what you've programmed, follow step 7 for that app.
    03-18-2016 06:40 PM
  10. meyerweb#CB's Avatar
    How did you get your email light to work?

    Posted via the Android Central App
    See #7 in my post above this one. If there's a similar option in the app you're using, that might help.
    blambtn likes this.
    03-18-2016 06:41 PM
  11. Devil13n's Avatar
    Lightflow Legacy seems to be working fine for me now, with AOD on, after following all the steps recommended on their web site. If you just install it, and expect it to work, you'll be disappointed. Here's what I did, IIRC:

    1. Download an install the regular paid version. Don't bother to set up any notifications.
    2. Download an install Legacy. It will alert you that you need to disable, but not delete, the full version, and offer to disable it for you. This is NOT the same as disabling an app in the application manager. Don't disable it there.
    3. At some point, it will prompt to to enable the Samsung workaround. Choose that setting.
    4. In the phone settings, go to Lock screen and security / Other security settings / Device administrators. Make sure Light Flow Legacy is turned on.
    5. In device Settings, go to Accessibility, scroll all the way down, and make sure Light Flow Legacy in On. (Not sure if this is really necessary, but it's working with this enabled, and it won't hurt anything).
    6. Back to Lightflow Legacy: In General settings, check (or make sure these are checked): Enable Light Flow, Snow LED in Priority Mode, Accessibility check.
    7. Go to Lightflow Legacy and set up your notifications. For some apps you'll need to check the Switch screen on and Wake screen when in pocket options to get notifications to work. To minimize the impact of this, set Screen on length to 0.3 seconds. I don't even notice the screen flash
    7b. Apps I know require these settings include Gmail, E-mail (Samsung's app),
    8. For the built-in SMS app, if you have problems, uncheck the boxes for Monitor SMS Conversations, and check the option for Monitor notification bar.
    9. Finally, go back to device Settings, choose Notifications, click Advanced, scroll down to Light Flow (not Legacy), and and turn off notifications.

    So far, everything seems to be working for me. If you set up notifications for an app and just get the regular Blue LED instead of what you've programmed, follow step 7 for that app.
    Really appreciate the step by step directions.

    Gmail still inconsistent though.
    rflores5432 likes this.
    03-18-2016 08:00 PM
  12. meyerweb#CB's Avatar
    You did the setup in step 7?

    So far Gmail seems fine for me, but I haven't gotten a lot of messages today. Will see how it goes over the next few.
    03-18-2016 08:02 PM
  13. blambtn's Avatar
    See #7 in my post above this one. If there's a similar option in the app you're using, that might help.
    I will try that. Thanks!!

    Posted via the Android Central App
    03-18-2016 08:25 PM
  14. blambtn's Avatar
    What is the switch screen option that you are referring to?

    Posted via the Android Central App
    03-18-2016 08:31 PM
  15. meyerweb#CB's Avatar
    What is the switch screen option that you are referring to?

    Posted via the Android Central App
    In Lightflow, go to Notfication settings in the menu. Scroll to the notification you want to edit and click the 3 button menu for that app, the click settings. Make sure you're on the Notification tab (at the top). Scroll down to the second group of options, Screen based notifications. The first option there is "Switch screen on." Check that option. Then tap the option two below that on "Screen on Length." Choose 0.3 seconds if you don't actually want to see the screen come on. Then check the option "Wake screen when in pocket" (it'll only light for 0.3 seconds).
    03-18-2016 08:57 PM
  16. blambtn's Avatar
    In Lightflow, go to Notfication settings in the menu. Scroll to the notification you want to edit and click the 3 button menu for that app, the click settings. Make sure you're on the Notification tab (at the top). Scroll down to the second group of options, Screen based notifications. The first option there is "Switch screen on." Check that option. Then tap the option two below that on "Screen on Length." Choose 0.3 seconds if you don't actually want to see the screen come on. Then check the option "Wake screen when in pocket" (it'll only light for 0.3 seconds).
    Thank you!!

    Posted via the Android Central App
    03-18-2016 09:02 PM
  17. meyerweb#CB's Avatar
    Looks like there's a problem with this setup. In order to get LF to reliably alert on Gmail and eMail, you have to turn it on as a device administrator. Doing that then requires me to enter a pin, instead of just using my fingerprint, whenever I get an LF notification for those apps. Not worth it. I'm using Dynamic notifications, but it's not as handy because it's not really visible from a distance, and it doesn't stay lit like the notification LED does. It also doesn't handle things like low battery or charging, but I can live with that.
    03-22-2016 01:24 PM
  18. meyerweb#CB's Avatar
    I've been communicating with the developer of lightflow, and I believe I now have notifications working for the apps I use, without the pin locking problem mentioned above. I've updated the steps in post #9 to reflect my current setup.

    http://forums.androidcentral.com/sam...ml#post5070680

    If this doesn't work for you, reach out to the developer via their web page. I've found him to be quite responsive and helpful.

    Reactle
    03-30-2016 08:41 AM
  19. recDNA's Avatar
    Lightflow Legacy seems to be working fine for me now, with AOD on or off, after following all the steps recommended on their web site. If you just install it, and expect it to work, you'll be disappointed. Here's what I did, IIRC:

    1. Download and install the regular paid version. Don't bother to set up any notifications.
    2. Download and install Legacy. It will alert you that you need to disable, but not delete, the full version, and offer to disable it for you. Accept that option. This is NOT the same as disabling an app in the application manager. Don't disable it in the application manager.
    3. At some point, it will prompt to to enable the Samsung workaround. Choose that setting.
    4. In the phone settings, go to Lock screen and security / Other security settings / Device administrators. Make sure Light Flow Legacy is turned on.
    4. Do NOT turn on administrators
    5. In device Settings, go to Accessibility, scroll all the way down, and make sure Light Flow Legacy in On. (Not sure if this is really necessary, but it's working with this enabled, and it won't hurt anything).
    6. Back to Lightflow Legacy: In General settings, check (or make sure these are checked): Enable Light Flow, Show LED in Priority Mode, Accessibility check.
    7. Go to Lightflow Legacy and set up your notifications. For some apps you'll need to check the Switch screen on and Wake screen when in pocket options to get notifications to work. To minimize the impact of this, set Screen on length to 0.3 seconds. I don't even notice the screen flash To avoid the issue with screen locking and needing to use a PIN to unlock the screen, choose "Phone screen default length" as the value for Screen on length. The drawback to this is that your screen will light up for 5 to 10 seconds when you get a notification for these apps, but it's the only way to avoid the pin locking problem.
    7b. Apps I know require these settings include Gmail, E-mail (Samsung's app),
    8. For the built-in SMS app, if you have problems, uncheck the boxes for Monitor SMS Conversations, and check the option for Monitor notification bar.
    9. Finally, go back to device Settings, choose Notifications, click Advanced, scroll down to Light Flow (not Legacy), and and turn off notifications. Make sure notifications are ON for Light Flow Legacy.
    10. In device Settings / Display, make sure LED indicator is set ON.

    With these settings, everything seems to be working for me, with the only drawback being the screen turns on for notifications from Gmail and Email. If you set up notifications for an app and just get the regular Blue LED instead of what you've programmed, follow step 7 for that app.
    Does this mean whenever you turn screen on it shuts off almost immediately?
    03-30-2016 08:55 AM
  20. meyerweb#CB's Avatar
    Does this mean whenever you turn screen on it shuts off almost immediately?
    No, if you turn it on yourself it still respects whatever screen timeout you've applied in settings. In my case, 1 minute. This only affects the timeout when Nova turns on the screen to load a notification from Gmail or Email. Then it stays on for about 5 seconds.
    recDNA likes this.
    03-30-2016 12:47 PM
  21. Blacklance's Avatar
    Tried your steps. I still get Blue for Gmail. All others work fine. Weird.
    03-31-2016 12:22 PM
  22. meyerweb#CB's Avatar
    Tried your steps. I still get Blue for Gmail. All others work fine. Weird.
    I think I've figured this out. Do you have AOD or Night clock turned on? Both of those settings prevent Lightflow from turning on the screen, so it can't load the settings you chose, and instead defaults to the flashing blue LED. If you are using AOD, try turning it off and see if that solves the problem with Gmail.
    04-01-2016 10:51 AM
  23. Blacklance's Avatar
    Turning off AOD does in fact fix the Gmail blue light problem, although I really like the AOD so I guess I'll have to live with blue light until another fix comes along.

    Thank you!
    04-01-2016 01:06 PM
  24. recDNA's Avatar
    I've used lightflow since my og droid and the developer is a great guy but if there is no better solution than this I'm sticking with my Note 3. Just too complicated and AOD is a very desirable feature. I hope a fix comes along.
    04-01-2016 01:52 PM
  25. Ryza321's Avatar
    I tried to follow the steps, but it doesn't work. I get two notifications for every app, I have two light flow app with the same name so I don't know what is the legacy version and I have some others annoying problem. I threw away this money.
    04-29-2016 03:30 AM
34 12

Similar Threads

  1. Replies: 44
    Last Post: 08-09-2018, 02:01 AM
  2. Replies: 6
    Last Post: 03-16-2016, 05:32 AM
  3. Does the Telegram notification appear in the second screen?
    By AC Question in forum Ask a Question
    Replies: 2
    Last Post: 03-15-2016, 03:58 PM
  4. Replies: 2
    Last Post: 03-15-2016, 02:55 PM
  5. Replies: 0
    Last Post: 03-15-2016, 02:08 PM
LINK TO POST COPIED TO CLIPBOARD