1. AC Question's Avatar
    My s7 is loosing all the time the signal. Every time that i reboot the device is fine for few days. I change the sim card i tried with 3 sim cards and is the same. Is not a provider issiue
    03-29-2016 10:20 AM
  2. B. Diddy's Avatar
    Welcome to Android Central! How do you know it's not a network issue? Do other phones on the same network have no problems right next to you?

    Try using a can of compressed air to blow out the SIM slot or tray. Since the phone is new, I'd bring it back to the store for an exchange, or contact Samsung for warranty repair/replacement.
    03-29-2016 11:26 AM
  3. Artem Kuznetsov1's Avatar
    I have the same issue! My s7 is 4 days old and is always losing cellular, data, and even wifi connection... I tried making a call and it won't dial. I can't send texts nor turn on data.
    I tried resetting the network configuration and it worked. Only half hour later I lost signal again.. PLEASE HELP.
    06-16-2016 05:40 PM
  4. trinichindian's Avatar
    At 4 days old with that kind of issue, I'd return it it under warranty and have it replaced.

    Posted via my Galaxy S7 Edge!
    06-17-2016 04:41 AM
  5. naturalguy's Avatar
    I have the same issue, it only happens once or twice per week and I can fix it by toggling on/off airplane mode but that shouldn't happen
    06-17-2016 07:04 AM

Similar Threads

  1. Samsung Galaxy S7 - Youtube App: how can I fix this?
    By AC Question in forum Samsung Galaxy S7
    Replies: 9
    Last Post: 06-20-2016, 11:57 PM
  2. Galaxy Note 5 media server drain, how can I fix this?
    By AC Question in forum Samsung Galaxy Note 5
    Replies: 3
    Last Post: 03-30-2016, 08:58 AM
  3. Replies: 2
    Last Post: 03-29-2016, 11:31 AM
  4. Can a Galaxy S4 be a phone as well as a tablet?
    By AC Question in forum Samsung Galaxy S4
    Replies: 3
    Last Post: 03-29-2016, 09:13 AM
  5. Change Font size on stock browser for Galaxy S5
    By Dave McQueen in forum General Help and How To
    Replies: 1
    Last Post: 03-29-2016, 08:51 AM
LINK TO POST COPIED TO CLIPBOARD