1. AC Question's Avatar
    I have s7 edge and regular s7. I have 200mbps with time warner and have the netgear c6300. It won't connect properly to app store, youtube, oculus store etc. The iphones in my house work perfectly, as do my computers and laptops. The s7 phones work fine on other wifi connections, just not at home. Help!
    04-04-2016 11:54 PM
  2. B. Diddy's Avatar
    Welcome to Android Central! The first thing to try is reboot the router, by unplugging its power, waiting 10 seconds, then plugging it back in again. If that doesn't help, review this guide: http://forums.androidcentral.com/amb...-problems.html
    04-05-2016 01:44 AM
  3. klt3505's Avatar
    I have the same issue. Replaced the phone and the new phone did the same thing. No other phones or devices have the problem. My daughter has TWC but a different router and everything works. My mom and I both have TWC and netgear c6300 and we cant connect to oculus or google play. I can surf the web just fine. After trial and error it is something with the router.
    04-06-2016 04:08 PM
  4. surround00's Avatar
    Yup, have the same exact problems with the same router, time warner internet and galaxy s7 and s7 edge. All the iphones and every other device works just fine. My s7 works on other wifi locations too.
    04-07-2016 09:31 PM
  5. Kpsquared's Avatar
    I've actually been having the same issue with my Note 5 and Tab S2. Certain apps will not pull notifications nor update over the wifi. Also my wifi calling causes the calls to hang up. Everything was perfect until I began using TWC & Netgear.
    04-07-2016 10:49 PM
  6. B. Diddy's Avatar
    I will assume you have all tried rebooting your router and it didn't help. Can you check to see if there are any firmware updates for the router?
    04-08-2016 01:32 AM
  7. Fauschak Finicky's Avatar
    Same exact situation in my case.
    S7 edge, Time Warner, Netgear c6300.
    I can see YouTube videos on Chrome browser or Firefox, but I cannot see videos on YouTub app.
    At the office's WiFi, YouTube app works without problems.

    Apps that do not work:
    • YouTube
    • Netflix
    • Google Store
    • Google Newstand

    Apps that work:
    • Gmail
    • Inbox
    • Email
    • Browsers
    • Bunch of financial applications (Chase, Bofa, Venmo, Mint)

    I rebooted the router, I've changed the type of WiFi security(I haven't tried no security, yet).
    I rebooted the phone many times.
    I deleted the WiFi connection on the phone and re-added it.
    I removed updates and new applications and reloaded them.
    I deleted cache contents, forced stop and restarted.
    All other phones and laptops work fast and flawlessly.

    I'm thinking on hooking up some Lan Analyzer to check the TCP/UDP traffic, but I hope someone finds out the answer sooner...

    I'm also thinking on trying a VPN to see if hiding the content of the packet has some effect.

    I hope that Time Warner is not throttling traffic.

    Could the applications for Samsung 7 with Android Marshmallow we the cause of the problem?

    So many questions...
    04-08-2016 03:45 PM
  8. wxman2003's Avatar
    Change the router settings to IPv4 instead of IPv6 and see if that works. If that doesn't work, change the router's DNS settings to either google or openDNS. Try or for google. or for openDNS.
    B. Diddy and Laura Knotek like this.
    04-08-2016 03:58 PM
  9. Fauschak Finicky's Avatar
    Well, here I come with news, and it's not pretty.

    I've spent a great deal of the Saturday experimenting, and on the phone with Samsung and with TimeWarner (all very polite and going above and beyond to help).

    I'll start by the end:
    Now all the apps on the S7 Edge work without any problem: YouTube, Netflix, Google Store, BeyondPod, etc.
    This happened after I've replaced the Netgear C6300 (which I own!) with TimeWarner's Ubee DDW36C (which I needed to lease at 10$/mo for router and 5$/mo for WiFi -- can you believe it?!)

    By the way, I'm also commenting and reading in Netgear's forum and in Reddit's Galaxy S7 site.

    Here's a list of all the things I've tried before replacing the modem/router:
    • Wiped the cache partition -- did not help
    • Replace the DNS from the Dynamic one to OpenDNS -- did not help
    • Changed the security configuration of the WiFi to accept TKIP+AES (instead of just AES) -- did not help
    • Went to a neighbor with different modem/router (Arris) and same internet provider (TWC). Connected into his WiFi and tried -- Still did not work (this made me suspicious of TWC!, but it could be that Arris is also having the same time of problem, no?)
    • Went to another neighbor with different modem/router (don't know what he has) and different provider (ATT [dsl]) -- Worked flawlessly!!
    • Installed a visual traceroute in my new S7 Edge and on my old S4 -- tried tracing Google in both: the S4 reached Goggle on this trajectory: San Diego -> Hawaii -> Los Angeles -> New York -> Los Angeless -> San Francisco -> Google
      The query on the S7 Edge showed no progress from the first hop: my house. Mmm...

    The TWC technician suggested to mail me their modem with router and wifi. It would have taken 3 or 4 days. I decided to go to TWC's offices and get one.
    It was simple to install and configure to reproduce the same WiFi SSID and passwords.
    As soon as it came up, the phone's apps worked without issues.
    Even more telling, traceroute to Google went straight San Diego -> San Francisco -> Google.

    Now I'm planning to ask Netgear what could be wrong with their equipment, (or the Netgear / TWC combination).

    What do you guys say?
    04-10-2016 07:19 PM
  10. Kpsquared's Avatar
    I ended up returning the C6300 to BestBuy for a Nighthawk (AC1900) model. The extra $50 not only allows my Note5, Tab S2, and wife's S6 to work properly, the internet is MUCH faster (an average increase of about 90mbps). I literally downloaded a 13 track album from Amazon Prime music in about 6 or 7 seconds on my phone. I don't see myself needing anything else for the next few years as it pays for itself.
    04-10-2016 11:45 PM
  11. klt3505's Avatar
    I found a work around.
    Log into the netgear router settings
    Click advanced tab
    Click advanced setup on left and select wireless settings
    On wireless access card click setup list
    Check box that says Turn Access Control On
    Make sure the radio button is lit for allow list
    Click add
    When the new window comes up clcik the radio button by the device (you will have to locate it in your phone by the mac address)
    Click add and then when the screen refreshes click apply.
    A message will pop up that the WPS will be disabled click yes.

    I was then able to access everything! Now my samsung s7 and Neatgear C6300 router work.
    04-12-2016 02:18 PM
  12. jmw_man's Avatar
    I have the exact identical problem with just a single difference, my phone is the Samsung Galaxy S6 which both my wife and I have had for a year since release and just one month ago we performed the update to 6.0.1 Marshmallow and immediately following the update the some apps work and other's don't and it's the same apps as mentioned before. For the last year since we got the phones and before the update, they worked perfectly fine.

    I have TWC and the Netgear C6300, nothing has changed here. From my point of view, the problem seems like a compatibility problem with the new android update with the Netgear router maybe?

    I've tried everything from forgetting network to network reset, settings reset, cycle power on/off to both phone and router, factory reset, and even a re-flash of the operating system.

    If I go to someone else's wifi, it works fine, but on my own, neither my S6 nor my wife's S6 works fully. My wife also has an iphone and it works flawlessly. I hate speaking to the techs at Verizon, Netgear, Samsung, TWC, and Best buy because they all look at me like I'm lying and don't know what I'm doing, the problem is obviously way over their heads.

    By the way, I tried the workaround in the last post and it did not work for me.
    04-25-2016 09:44 PM
  13. TrippinTrips's Avatar
    I'm also having the same problem with my Galaxy s7. It worked fine until I got the Netgear a few weeks ago. I've tried calling Time Warner Cable, Google Support, Samsung, Netgear and even my phone carrier with no luck. I have no cell phone service at my house (it's a deadzone, I found out too late) and now I'm stuck with a phone that barely works. Any help would be much appreciated.

    I tried the workaround as well and had no success. Has anyone else figured it out? I dropped a huge amount of money on the c6300 and I can't return it. It would be a shame to have to give up and buy another modem.
    04-26-2016 05:22 PM
  14. jmw_man's Avatar
    Right now, the workaround I'm using is the guest network on my Netgear C6300. It's not encrypted and I don't have it password protected so as an additional security measure I disabled the SSID broadcast so technically speaking it's supposed to be invisible. I'm not sure if it's possible for people to detect networks where the SSID is not broadcast. In the meantime, I've already spent so much time looking for a better workaround that I feel like I should send a bill to Verizon/Samsung/Netgear/Android. It would be cheaper for me to just buy a different router where my WIFI works and is secure, but that's not solving the problem, it's circumventing it. The phone was flawless before 6.0.1, I'm not sure why Android isn't giving the S6 phones a way to revert back...
    04-27-2016 02:43 PM
  15. JWH02's Avatar
    This is a good discussion.

    The issue is not limited to Samsung Galaxy S7 devices, it is in fact any Android Marshmallow equipped device, i am duplicating the same issue on TWC Maxx service with the Netgear C6300 modem.

    The problem appears to be that in Marshmallow, certain core google components including the play store and other features are now configured to use IPv6 addresses instead of the old IPv4 addresses which were used in prior versions of Android OS. The firmware on the C6300 does not play well with the TWC IPv6 services for some reason.

    I proved this out by setting up a DNS service which does not respond to IPv6 queries on my internal home LAN, and having the internal DHCP server assign this DNS to all of my internal devices including my Android 6.x phones. After doing this, TWC internet + Netgear C6300 works fine.

    Other service providers have the version 2.01.14 firmware released already and this problem is now fixed.

    see this thread for more information

    C6300 FW 1.02.19 vs 2.01.14 - TWC Community Forums

    Current firmware version for NETGEAR cable modem routers | Answer | NETGEAR Support
    05-04-2016 05:34 PM
  16. gvancise's Avatar
    I bought the Samsung Galaxy S7 on 3/26/16, and we installed a brand new router on 3/30/16, the Netgear C6300. In my home, the only thing I could access on my S7 was Facebook and Google search. Unable to access Google Maps, Play Store, Youtube, Pandora, etc. Wifi worked perfectly anywhere else I went; C6300 worked perfectly with all other devices in our home including our Smart TV & my husband's Galaxy S7. Hours spent on the phone with Verizon, Samsung, Netgear, and finally, Time Warner. CONCLUSION: The S7 & the C6300 are NOT compatible, and neither Samsung nor Netgear wants to do anything about it. Fortunately, Amazon has agreed to issue a refund for the c6300 when we return it. (they do not typically take returns after 30 days; this is a special circumstance). DON'T WASTE YOUR TIME...REPLACE YOUR ROUTER.
    05-11-2016 07:26 PM
  17. mike770's Avatar
    I too had this exact problem with TWC and the netgear c6300. Ultimately the solution was to return the router for another brand. For what it's worth, I bought an Asus AC1750 and everything works properly. I am also getting a stronger Wifi signal throughout my house.
    05-11-2016 07:55 PM

Similar Threads

  1. Replies: 1
    Last Post: 04-05-2016, 02:21 AM
  2. Replies: 1
    Last Post: 04-05-2016, 01:49 AM
  3. How To Get Android N
    By emmawilliam in forum Android 7.0 Nougat
    Replies: 1
    Last Post: 04-05-2016, 12:08 AM
  4. WiFi not connecting to Android, how can I get it working?
    By AC Question in forum General Help and How To
    Replies: 2
    Last Post: 04-04-2016, 11:39 PM
  5. Why can't I listen to music apps and play games?
    By AC Question in forum Samsung Galaxy Note 5
    Replies: 1
    Last Post: 04-04-2016, 11:36 PM