1. dxbclaire's Avatar
    Good afternoon.

    Hope someone can help as I have never expereinced a problem like this on my previous S3, I just got a new S7E and I set it up to use UK English, when I click on the microphone button in the message box (either text or WhatsApp), it beeps and says "OFFLINE MODE UNAVAILABLE".

    I then clicked on the gear icon and looked at the language settings, the US English is up to date and set as the default, I also d/l'ed the French language pack without any issues, but when I tried the UK English, nothing happens, the pack is there looking like its ready to d/l and I can cancel it, but nothing is actually happening. This is with SwiftKey. I have also tried it with the Samsung keyboard and its the same. The UK language pack just isnt being downloaded

    I am based in Dubai and I have tried this on my home WiFi, via a friends VPN connection and via my mobile data so it's not something specific to the Middle East (and I had no issues with the S3). The phone is completely upto date with all the software etc done.

    Could anyone point out what I am doing wrong or if it is a general error and I am not admitting defeat to my Apple friends who said I should swap from 'droid to IOS - they can bugger right off...!

    Many thanks
    04-10-2016 06:17 AM
  2. dxbclaire's Avatar
    Anyone please? Thanks
    04-11-2016 01:02 AM
  3. MrBill9591's Avatar
    Hi Claire,

    Hello - I did the following to solve the very same problem that you are facing, but in my case it is a Samsung S6, and not a S7.

    This link is for instruction from the Bell Canada website in Canada, but the setting should be the same for your phone as well.
    To resolve the Offline mode unavailable I did the following steps. They said on line that this can be out-of-whack, or corrupt settings, and resetting it solves many issues.
    See this link below for steps to follow:

    How to reset the APN settings to default on my Samsung Galaxy S6

    How to reset your APN setting on your phone, then proceed to choose your proper cell carrier again from the APN settings menu.
    I then reset my phone, and funny you mentioned "language" settings because I am almost sure it has to do with language, or language of preference.

    In my case I had it setup for CAN English, and I think this also gave me the same error as you are getting. When I set my phone language to US English, now I do not get the "Offline mode unavailable & unable " any longer, and it works for voice input in all apps.

    I wish you good luck and all the best!


    Ottawa Canada
    04-18-2016 08:07 PM

Similar Threads

  1. How connect my Android tv box to server after factory reset
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 04-10-2016, 03:07 PM
  2. Back up S6 Edge to pc
    By Racy Tracy in forum Samsung Galaxy S6 edge
    Replies: 1
    Last Post: 04-10-2016, 02:46 PM
  3. Replies: 1
    Last Post: 04-10-2016, 02:40 PM
  4. How to exit Asus Memo Pad Me172v Fastboot/Bootloader Mode???
    By AC Question in forum ASUS MeMO Pad 7
    Replies: 1
    Last Post: 04-10-2016, 02:37 PM
  5. How to turn off sounds except phone calls sat night
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 04-10-2016, 03:49 AM