1. Rumblee1's Avatar
    Well, I couldn't wait for the S7 edge. But to be truthful, im appreciating my S6 edge right now. My S7 edge keeps loosing data signal. I cant get calls, make calls and no Internet, nothing until I go to settings - Mobil networks - network mode and toggle between global and lte/cdma. Then it'll work for a while. Then off again and I have to repeat the process. I've checked all settings and they're correct. Only thing I haven't done is a factory reset. Any ideas? My S6 edge never had any issues. My only real gripe was battery life. But since marshmallow, even that is respectable now.

    Posted via Android Central App
    04-14-2016 05:29 AM
  2. MartinMPL's Avatar
    Return it, either for replacement or not.
    04-14-2016 05:43 AM
  3. bullittmustang's Avatar
    Sounds like maybe a carrier issue. Have you called your carrier?
    04-14-2016 06:05 AM
  4. ironass's Avatar
    Which model of Galaxy S7 Edge do you have?
    04-14-2016 06:08 AM
  5. areyes163's Avatar
    Sounds like it may be defective. I would return or exchange it especially if you s6 doesn't have these issues.
    04-14-2016 07:46 AM
  6. Rumblee1's Avatar
    UPDATE - I just talked to Verizon and they had me turn on wifi/hd calling and so far it's been excellent. They're also sending me a new sim in case I still have an issue. If all fails, they'll swap out the phone.

    Posted via the Android Central App
    04-14-2016 02:25 PM
  7. jeetu4444's Avatar
    Yes lot of ppl said sim card is a problem at times...

    Posted via My Awesome Lumia 950 ds red and gold or LG G4 or surface pro 4
    04-14-2016 02:35 PM

Similar Threads

  1. Replies: 8
    Last Post: 05-29-2016, 06:13 PM
  2. Replies: 2
    Last Post: 04-15-2016, 01:59 PM
  3. Replies: 1
    Last Post: 04-14-2016, 02:17 AM
  4. Replies: 1
    Last Post: 04-14-2016, 01:09 AM
  5. Replies: 1
    Last Post: 04-13-2016, 11:59 PM
LINK TO POST COPIED TO CLIPBOARD