1. Rumblee1's Avatar
    Im on my 2nd brand new galaxy S7 edge, and still having connection issues with wifi and data-phone connection. My biggest complaint is the data connection. It'll be working fine, then for some reason, just cut out without warning, without notice. To get it back, I've got to go to settings and toggle the connection from global to lte /cdma and back to globle again to restart. Signal strength has no bearing on this. It just happens. Verizon had me try everything possible including a full factory reset, then a new sim card and another factory reset. Have done this on both phones. Both were brand new units. Ive got an LG V10 and a galaxy S6 edge and have no issues with either one of them. I also did a bit of research on line and found that im not the only one having this issue. If anyone can shed some light on the problem, it would very much be appreciated. Im ready to just ditch the S7 edge and stay with the S6 edge. That phone had been perfect. By the way, i did try the S6 edge sim in the S7 edge and the same problem persists. So it's got to be the S7 edge. Thanks.

    Posted via Android Central App
    05-04-2016 07:59 AM
  2. Almeuit's Avatar
    Hm that is weird. Something with Verizon in your area and that S7 Edge aren't mixing. I have friends on Verizon with the phone and they haven't once complained about data just randomly dropping... And some of them are extremely heavy users.
    05-04-2016 08:02 AM
  3. Rumblee1's Avatar
    But it's when I'm out & about that this mostly happens. In very strong signal areas.

    Posted via the Android Central App
    05-04-2016 08:21 AM
  4. ThrottleJohnny's Avatar
    Not having this issue at all with the T-mobile variant.

    Posted via the Android Central App
    05-04-2016 09:50 AM
  5. Rumblee1's Avatar
    Well, I just went out. In a store and went to call home. Guess what? No data. Had to do the toggle thing. And when it came back on, I had full bars.

    Posted via Android Central App
    05-04-2016 10:56 AM
  6. BDub0817's Avatar
    Having the issue on AT&T. I think it is a Qualcomm issue because I have a Lumia 950, 950 XL, Galaxy S7 and S7 edge on AT&T and all the phones have the same issue.
    05-04-2016 03:20 PM
  7. Rob Rowland's Avatar
    I've had this issue a few times as well. I usually just reboot the phone to get my data connection back. AT&T phone
    05-04-2016 10:33 PM
  8. Rumblee1's Avatar
    This should not be happening though. These phones were not cheap. Time to start complaining right to samsung. Seems to me this could be just a matter of an update of some kind.

    Posted via Android Central App
    05-05-2016 06:35 AM
  9. Rumblee1's Avatar
    Ok, since im now retired and want to really try everything under the sun to get this phone to work, I tried the one thing that I didn't try on my current S7 edge or previous. That is i turned on the "activate wifi calling mode" . Even though this should not have made a difference, my S7 edge has been working flawlessly (knock on wood) ever since. No data drops at all. This is since last night around 8pm. I'll give it more time and continue to update. So try it. Active wifi calling.

    Posted via Android Central App
    05-05-2016 01:47 PM
  10. Rumblee1's Avatar
    UPDATE - Since I turned on wifi calling, ive not had a single data drop. Isnt it amazing that verizon tech support didnt know this when I spent over an hour on the phone with them with my first S 7 edge? I probably wouldnt have needed to ditch the first one and pick up a second. They had me try everything, soft reset, hard reset, resets I never heard of, full factory data reset, new sim card, then another full factory reset. And that was still on my first S7 edge. So when I got my second S7 edge, and had the same issue, I knew there had to be something wrong that could be fixed. I Dont believe in coincidences. By the way, did I mention that both phones were brand new, right out of the box. I paid full price for both. I didn't want someone else's used phone.

    Posted via Android Central App
    05-07-2016 07:47 AM

Similar Threads

  1. How do I restrict background data on Lenovo A816
    By AC Question in forum Ask a Question
    Replies: 5
    Last Post: 02-09-2017, 10:49 AM
  2. Where did the heart emojis go on my Samsung Note 4
    By AC Question in forum Samsung Galaxy Note 4
    Replies: 2
    Last Post: 05-04-2016, 03:18 PM
  3. Replies: 2
    Last Post: 05-04-2016, 02:33 PM
  4. Replies: 6
    Last Post: 05-04-2016, 02:05 PM
  5. i can't send messages on my htc one8.
    By AC Question in forum HTC One M8
    Replies: 1
    Last Post: 05-04-2016, 09:07 AM