1. AC Question's Avatar
    Hi everyone,

    I am having some trouble with my s7 edge. I can't connect or even detect a 5 ghz wifi network. My nexus 6p connects just fine. I've tried everything I could find on google in the sense of help. Things like resetting the modem to resetting the phone. Changing channels on the modem also didn't work. Is there maybe something I'm overlooking on the s7 edge to make it find 5ghz bands?

    Any help would be greatly appreciated.

    Thanks all :-)
    05-04-2016 02:39 PM
  2. B. Diddy's Avatar
    Welcome to Android Central! Go to Settings>Wi-fi, tap Menu>Advanced, and look for the Wi-fi Frequency Band option. Make sure it's set to Automatic or 2.4 GHz/5 GHz.
    05-04-2016 04:39 PM
  3. dm3ready's Avatar
    My AT&T edge does not have that option under wifi /advanced... What am missing?
    05-05-2016 06:23 AM
  4. B. Diddy's Avatar
    That's strange--it should be there, since other articles have mentioned it in that Advanced menu. But I also just looked at the AT&T S7 manual, and they don't list that option in the Advanced Wi-fi menu either. It'd be hard to understand why AT&T would remove that option from the settings, but I wouldn't necessarily be surprised that a big carrier meddled with the settings like that. Let me ask around.
    05-05-2016 11:26 AM
  5. PJRed2008's Avatar
    While B.Diddy is looking around, what channel are you using for 5G? I had no luck until I got up into the 153 area. Truthfully though, unless you have a very good router, signal strength will be a real concern.
    05-05-2016 11:55 AM
  6. dpham00's Avatar
    Are you using different ssid for 2.4 and 5ghz?

    My s7 edge connects to 5ghz no problems. I set automatic channel.
    05-05-2016 12:24 PM
  7. B. Diddy's Avatar
    Are you using different ssid for 2.4 and 5ghz?

    My s7 edge connects to 5ghz no problems. I set automatic channel.
    Hey dpham00, where is the setting? The main problem for the OP is they can't find the setting to change from 2.4 only, 5 only, or Automatic. Does AT&T hide that from the user?
    05-05-2016 06:23 PM
  8. PJRed2008's Avatar
    Actually, I don't have that setting on my Verizon either.
    Tatt2014 likes this.
    05-05-2016 08:15 PM
  9. dpham00's Avatar
    Hey dpham00, where is the setting? The main problem for the OP is they can't find the setting to change from 2.4 only, 5 only, or Automatic. Does AT&T hide that from the user?
    You can't choose in the settings. But you can set up different ssid on the router so you know which one is 5ghz
    B. Diddy likes this.
    05-05-2016 09:45 PM
  10. Jan Jonkman's Avatar
    Hi and thanks for the reply. When go into settings it doesn't allow me to change the bands at all. That option isn't available. I assume I have the international version. Strangely enough my mate 8 also doesn't detect a 5ghz band. Only the nexus 6p allows for band changes.

    Anyone else have this problem?

    Many thanks.
    05-06-2016 09:35 AM
  11. dpham00's Avatar
    Hi and thanks for the reply. When go into settings it doesn't allow me to change the bands at all. That option isn't available. I assume I have the international version. Strangely enough my mate 8 also doesn't detect a 5ghz band. Only the nexus 6p allows for band changes.

    Anyone else have this problem?

    Many thanks.
    I have never seen this option on samsung galaxy devices.
    05-06-2016 05:37 PM
  12. Raedaq's Avatar
    I know it's old, but I've just experienced the same issue and after some fiddling, I manually changed the 5 Ghz channel on 36 and my galaxy s7 and s7 E were able to detect the network.

    Hope this helps!
    10-02-2016 01:56 PM
  13. Tasama's Avatar
    I know it's old, but I've just experienced the same issue and after some fiddling, I manually changed the 5 Ghz channel on 36 and my galaxy s7 and s7 E were able to detect the network.

    Hope this helps!
    this may help. I experienced this problem once but not for my S7e. it was on my tablet with wifi 2.4/5GHz capable.
    I changed 5ghz channel in my access point to match the device's country allowance channel. and it's work.
    see
    https://en.wikipedia.org/wiki/List_o...Fac.29.5B17.5D
    10-09-2016 11:02 AM
  14. johnmoz's Avatar
    For those owners whose device can't see wifi 5ghz frequency, your device is not broken which I thought mine was.
    The remedy is simple, set your wifi country to EU, JP, or others same as your routers bands, as samsung default was set to US ( my router E4200 is APAC region ).

    Use RootExplorer and SQLite editor ( these apps from the same dev ) and go to "/data/data/com.android.providers.settings/databases/settings.db" in "secure" table, look for "wifi_country_code=XX" change XX to JP as in my case. Reboot your wifi. Et voila ! There it is my 5GHZ SSID !!
    10-18-2016 04:23 AM

Similar Threads

  1. Replies: 3
    Last Post: 05-05-2016, 04:39 PM
  2. Can't change account while adding contact
    By gafoorgk in forum Ask a Question
    Replies: 5
    Last Post: 05-05-2016, 11:11 AM
  3. Replies: 1
    Last Post: 05-05-2016, 10:53 AM
  4. Replies: 2
    Last Post: 05-04-2016, 03:55 PM
  5. Why won't Facebook update on WiFi?
    By AC Question in forum Facebook
    Replies: 0
    Last Post: 05-04-2016, 12:53 PM
LINK TO POST COPIED TO CLIPBOARD