1. pdxfisher's Avatar
    I ran into an odd issue with adoptable memory. Everything worked fine until I tried to reinstall an app that had previously resided on the SD card. I received a -504 error every time I tried to reinstall. I did all the cache cleaning, etc, etc but I could not get the app to reinstall.

    I ran experiments to repeat this issue. If I moved an app from the SD part of the memory to the internal part and uninstalled it I could reinstall just fine. If I uninstalled an app that was sitting on the SD card I could not reinstall.

    In the end, I just moved everything off the SD card back to internal and reformatted the SD card back to normal (removable) memory.

    Has anyone else run into this? I am curious if anyone has seen this problem and then solved it.

    This was on an S7 edge.

    Thanks.
    06-03-2016 06:32 PM
  2. chanchan05's Avatar
    Probably depends on how you enabled adoptable storage since that's disabled by default on thr S7. Moving an app to SD card via the app manager is not adoptable storage.
    06-03-2016 07:07 PM
  3. pdxfisher's Avatar
    I followed Paul OBrien's article MoDaCo on setting up adoptable storage. It worked fine - except when reinstalling an app that ended up on the SD card, was deleted. I was not moving apps anywhere the OS was properly apps on the SD card (indicating proper recognition of the adoptable storage).
    06-06-2016 12:40 PM

Similar Threads

  1. Samsung Pay app
    By Jude526 in forum Samsung Galaxy Note 4
    Replies: 5
    Last Post: 06-09-2016, 10:59 AM
  2. Anyone having SMS issues?
    By theelite1x87 in forum T-Mobile
    Replies: 3
    Last Post: 06-07-2016, 07:15 PM
  3. How can I charge my S5 with a broken charge port?
    By AC Question in forum Ask a Question
    Replies: 2
    Last Post: 06-03-2016, 07:11 PM
  4. Problem with adoptable storage and reinstalling apps
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 06-03-2016, 06:01 PM
  5. Replies: 0
    Last Post: 06-03-2016, 05:45 PM
LINK TO POST COPIED TO CLIPBOARD