1. Infinite_Ouya's Avatar
    I just upgraded from my old iPhone 5s to the S7 Edge and so far it has been a HUGR mistake. It no only is slower on LTE but almost unusable on my home wifi that worked perfectly fine on my old phone and works great with my gaming PC. YouTube videos don't even load, websites take minutes to load, and any online applications don't connect. Is there any fix to this? If not I'll just return the phone and just get a iPhone 6.
    06-05-2016 10:29 PM
  2. tinybfk's Avatar
    Try restarting the phone. If that doesn't work try a factory reset. If that doesn't work call Samsung.

    Posted via Carrier Pigeon.
    06-05-2016 10:49 PM
  3. D13H4RD2L1V3's Avatar
    I suggest doing another factory reset and also restarting your home network.

    If they fail, send it back for a replacement as you might have a defective unit.
    Almeuit likes this.
    06-05-2016 10:53 PM
  4. Almeuit's Avatar
    I suggest doing another factory reset and also restarting your home network.

    If they fail, send it back for a replacement as you might have a defective unit.
    This. Your LTE / WiFi should work just fine.
    06-06-2016 12:15 AM
  5. James See's Avatar
    That's weird, because S7 usually don't work that way. Try restarting your device check your Wi-Fi router if it works well.
    06-06-2016 01:25 AM
  6. coolkenny13's Avatar
    i'm sorry your phone is working this way. restart and try. if not then factory reset. worst case scenario get a replacement. please update us
    06-06-2016 01:31 AM
  7. Infinite_Ouya's Avatar
    It worked, the reset fixed the issues for now
    06-06-2016 07:34 AM
  8. D13H4RD2L1V3's Avatar
    It worked, the reset fixed the issues for now
    Nice. Use it for a bit and see if that really sorts out the issue.

    If it comes back, I'd send it back for a replacement. Odds are, you should be fine.
    06-06-2016 09:30 AM

Similar Threads

  1. Can I get face tis on my tab4 10.1
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 06-06-2016, 05:37 AM
  2. My phone died and won't turn on nor LED right turn on
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 06-06-2016, 04:32 AM
  3. What information is linked with my mobile number?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 06-06-2016, 02:47 AM
  4. Replies: 1
    Last Post: 06-05-2016, 10:11 PM
  5. How do I change my backup password?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 06-05-2016, 10:06 PM
LINK TO POST COPIED TO CLIPBOARD