1. AlphaVictor87's Avatar
    I'm not sure if i've changed a setting on my phone, but Google maps has been taking upwards of 5 to 10 seconds to completely load before i can do anything.

    The app may open, but it'll just be that tan color with the search bar at the top and thats about it. It becomes completely unresponsive until the app loads completely. Once it loads its fine and i don't notice any issues.

    Anyone else had this or know why it might be taking so long?
    06-14-2016 10:39 AM
  2. pjwk81's Avatar
    I'm not sure if i've changed a setting on my phone, but Google maps has been taking upwards of 5 to 10 seconds to completely load before i can do anything.

    The app may open, but it'll just be that tan color with the search bar at the top and thats about it. It becomes completely unresponsive until the app loads completely. Once it loads its fine and i don't notice any issues.

    Anyone else had this or know why it might be taking so long?
    Mine has been doing the same but I was blaming going on the Beta of it. Are you on the same?
    06-14-2016 11:23 AM
  3. anon(19981)'s Avatar
    I was having a slow load on beta also. I uninstalled beta and maps is working fast as usual again.

    Posted via the Android Central App
    06-14-2016 07:08 PM
  4. AlphaVictor87's Avatar
    Mine has been doing the same but I was blaming going on the Beta of it. Are you on the same?
    Not that I know of. I'm on version 9.27.1.
    06-14-2016 10:25 PM
  5. pjwk81's Avatar
    Not that I know of. I'm on version 9.27.1.
    Mine is on 9.27.2 but has just updated a couple of minutes ago, so you could well be on it. I use it a lot so I'm going to go back to the stable release and see if it helps too.
    06-15-2016 12:58 AM
  6. aha's Avatar
    Not that I know of. I'm on version 9.27.1.
    Clear app cache?

    Posted via Android Central App
    06-15-2016 05:27 PM
  7. AlphaVictor87's Avatar
    Clear app cache?

    Posted via Android Central App
    Yup i've tried that as well as uninstalling all updates then re-updating the app. Still happens.
    06-16-2016 07:12 AM
  8. bikenski's Avatar
    I'm not on the beta release, but noticed recently that Maps was freezing upon launch while the GPS locked in my current location. Once the current location was indicated, the program started working normally.

    Haven't used Maps in the past few days, but hopefully the recently pushed update fixed this issue.
    06-16-2016 02:07 PM
  9. Almeuit's Avatar
    Hmm that is odd. Try on a wifi connection or mobile data (basically the one you don't normally) and see. I use maps often and it loads normal for me on LTE or wifi.
    06-16-2016 02:33 PM
  10. Burp2368's Avatar
    wipe your device cache partition. fixed the problem for me.
    10-01-2016 05:27 PM

Similar Threads

  1. Infinite reboot of Galaxy Gear 2 Neo after trying to pair it with new phone
    By AndroidGuy1969 in forum Samsung Gear 2 & Gear 2 Neo
    Replies: 4
    Last Post: 11-23-2016, 11:57 AM
  2. How do I fix? - unable to play video file has incorrect data
    By AC Question in forum Ask a Question
    Replies: 2
    Last Post: 06-20-2016, 08:47 AM
  3. Replies: 1
    Last Post: 06-14-2016, 10:35 AM
  4. Can't remove swipe to turn on screen
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 06-14-2016, 10:00 AM
  5. how to factory reset
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 06-14-2016, 09:38 AM
LINK TO POST COPIED TO CLIPBOARD