1. jacobr365's Avatar
    So I just got my phone like two weeks ago. At my home I can connect to my wifi fine (it is secure but i don't remember what type). but when I am at work, I can connect to the visitor network which has no security, but sends you to a login page when you connect and makes you enter a password that they change daily. So being stuck using the visitor network would be a huge pain to have to go call it and get the password every day. We also have a staff network that is secured with 802.1xEAP and has MSCHAPV2 phase 2 verification. However whenever I try to connect to it, the little spinner spins for 3-5 min and then it says that my credentials are invalid. I have verified that both my username and password are 100% correct. I even went and spoke to one of the system admins and they pulled up the logs and can see that I did give the correct info and the system accepted me. They looked at my phone and tried to set the connection with EAP method = PEAP, Phase 2 authentication = MSCHAPV2, my username and password and it still failed. So that combined with the logs lead them to think something is wrong with the phone.

    I have tried restarting the phone, trying with bluetooth on and off, turning mobile data off and and putting it in airplane mode while trying to connect (idk why this would help but some guide i found on google said it would), I have turned off the auto connect to hotspots and disabled smart switch. I have forgotten the network and re-added it, reset all network settings. None of this stuff worked.

    The only thing I have not tried is a factory reset, but i would like to avoid doing this if at all possible.

    I read somewhere that it is an issue with Android 6.1 but I also found articles saying samsung patched the issue so I am not sure what to believe. And in both cases i could not find any updates beyond the initial posts.

    Anyone know what could be wrong and how to fix? Or, am I just left waiting for a software patch?

    It is also worth noting that other coworkers have the same phone with the same android version and they are able to connect. Any ideas?
    06-27-2016 09:24 AM
  2. dpham00's Avatar
    I don't think Android 6.1 is out yet for the S7 Edge?
    06-27-2016 04:33 PM
  3. michelle tuller's Avatar
    Factory reset will most likely fix the issue...
    06-27-2016 06:27 PM
  4. paridge's Avatar
    Do you have AT&T's latest updates? The May update fixed some Wi-Fi & Bluetooth issues.
    06-28-2016 05:03 AM
  5. jacobr365's Avatar
    Yea, I am fully up to date.

    Ok will will try the reset. I finally got my phone all set up the way i want it (minus the wifi issue), such a shame i have to do it all over again.
    06-28-2016 08:09 AM
  6. jacobr365's Avatar
    So wifi now works. I have no idea why. I was going to wait till the weekend to do the factory reset but I came in this morning and it is working. Nothing on my phone was updated and i confirmed with IT at my company that they did not change anything. So I have no idea why it is now working but it is so hurray.
    06-30-2016 07:58 AM

Similar Threads

  1. Replies: 3
    Last Post: 06-29-2016, 07:29 AM
  2. LG G4 Call/Text/Data major issue
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 06-29-2016, 05:18 AM
  3. Replies: 1
    Last Post: 06-27-2016, 12:34 PM
  4. Replies: 1
    Last Post: 06-27-2016, 09:21 AM
  5. AT&T S7 Bloatware vs S7A
    By tkuhe in forum Samsung Galaxy S7 Active
    Replies: 0
    Last Post: 06-27-2016, 09:12 AM
LINK TO POST COPIED TO CLIPBOARD