1. dyna mike's Avatar
    Hi all. I'm having trouble turning on trusted voice. I have set up the OK google prompt, so that when my phone is on and at the lock screen or if I'm just using an app, I can say OK google and the phone starts the google app, but it won't unlock the phone for me.

    If I try to turn this feature on by going to: settings --> lock screen and security --> secure lock settings --> smart lock --> then enter my PIN, --> trusted voice, I find the option for "trusted voice" (ie, let OK Google unlock your device) is grayed out and I can't figure out a way to make it select-able. Any thoughts?

    I included two pictures of what I am seeing. They both show that Trusted Voice is not select-able right now, but I included a second picture after turning off "From Any Screen" to show that the "Trusted Voice" is grayed out differently than if it were just turned off, like "From Any Screen" is.

    Can't figure out how to turn on trusted voice-screenshot_20160817-094421.jpg

    Can't figure out how to turn on trusted voice-screenshot_20160817-094427.jpg
    08-17-2016 12:49 PM
  2. Tom Westrick's Avatar
    Enable "from any screen" first and see if that unlocks it
    08-17-2016 06:33 PM
  3. dyna mike's Avatar
    Enable "from any screen" first and see if that unlocks it
    Tom, I've tried that too. The only reason I included that picture you're looking at was to show that trusted voice was grayed out in a different way than if I had just been turned off. The other picture I posted shows trusted voice grayed out even with any screen turned on.

    Posted via the Android Central App
    08-17-2016 09:18 PM
  4. Tom Westrick's Avatar
    Tom, I've tried that too. The only reason I included that picture you're looking at was to show that trusted voice was grayed out in a different way than if I had just been turned off. The other picture I posted shows trusted voice grayed out even with any screen turned on.

    Posted via the Android Central App
    Gotcha, the first pic didn't load for me for some reason so I didn't see that.

    Have you tried going through the settings in the Google app? It's Settings, voice, "OK Google" detection. It's the same screen, I'm just wondering if it would work for you there.
    08-17-2016 10:14 PM
  5. khayman9's Avatar
    Try deleting the old voice model and retraining it from the smart lock settings....Can't figure out how to turn on trusted voice-screenshot_20160818-121257.png
    08-18-2016 06:14 AM
  6. dyna mike's Avatar
    Try deleting the old voice model and retraining it from the smart lock settings....Click image for larger version. 

Name:	Screenshot_20160818-121257.png 
Views:	21 
Size:	107.8 KB 
ID:	235715
    Khayman, I just tried that with no luck...

    Gotcha, the first pic didn't load for me for some reason so I didn't see that.

    Have you tried going through the settings in the Google app? It's Settings, voice, "OK Google" detection. It's the same screen, I'm just wondering if it would work for you there.
    Tom, good idea, and we're making progress but haven't solved the problem yet. Here is what I see when I try to access "OK Google" through the path you suggested:

    Can't figure out how to turn on trusted voice-screenshot_20160818-135814.jpg
    08-18-2016 05:05 PM
  7. martin w1's Avatar
    Khayman, I just tried that with no luck...



    Tom, good idea, and we're making progress but haven't solved the problem yet. Here is what I see when I try to access "OK Google" through the path you suggested:

    Click image for larger version. 

Name:	Screenshot_20160818-135814.jpg 
Views:	18 
Size:	94.7 KB 
ID:	235879
    I have exactly the same problem.
    08-20-2016 02:16 PM
  8. khayman9's Avatar
    Well this is baffling and, I admit, I'm at a loss here. However, I think I remember having this issue before a software update or a reset but I'm not really sure....
    08-21-2016 05:38 AM
  9. Darkmatter0603's Avatar
    I'm not sure if this can be a factor but do you have S-Voice on too? Maybe it is not allowing you to unlock the device with both voices.
    08-21-2016 06:11 AM
  10. martin w1's Avatar
    I have an Nexus 5X and i cant find a way to get the slider from trusted voice enabled. I have absolut no problem on my Nexus 5.
    08-21-2016 12:13 PM
  11. martin w1's Avatar
    It´s exactly the same behaviour as described from dyna mike.
    08-21-2016 12:14 PM
  12. bryanthavercamp's Avatar
    I have been having the exact same issue for months. It used to work, then all of a sudden stopped working and i couldn't turn it back on. I thought i was the only one with this issue.
    11-02-2016 10:48 PM
  13. zweenzta's Avatar
    I am now having this issue after doing a factory reset of my Galaxy S7. It was working fine before this. The only thing I can think of is that Google needs to "train" your voice first? I read this on a website.

    After many uses the option might become available again? Otherwise I have no idea. Been trying to resolve it for a few days and tried all of the above.
    11-30-2016 05:00 AM
  14. Douglas333's Avatar
    Dude?
    The ever get this figured out?
    Having the same issue inn my $6 edge. If retrained, dis-re-enabled, everything I can think of, but no dice!
    I don't think s-voice is on, but Samsung is sneaky about turning bloat back on, unfortunately.
    Phrase let me know if you find a solution?
    I know I had it on once upon a time, but now it's of and will not re-enable...

    Thanks!
    03-22-2017 08:37 PM
  15. slashinpdx's Avatar
    I had the same problem, but found that it was because of the security involved in having an exchange type account setup. I switched to the Outlook app, which apparently doesn't require lock screen security. Hope this helps.


    Hi all. I'm having trouble turning on trusted voice. I have set up the OK google prompt, so that when my phone is on and at the lock screen or if I'm just using an app, I can say OK google and the phone starts the google app, but it won't unlock the phone for me.

    If I try to turn this feature on by going to: settings --> lock screen and security --> secure lock settings --> smart lock --> then enter my PIN, --> trusted voice, I find the option for "trusted voice" (ie, let OK Google unlock your device) is grayed out and I can't figure out a way to make it select-able. Any thoughts?

    I included two pictures of what I am seeing. They both show that Trusted Voice is not select-able right now, but I included a second picture after turning off "From Any Screen" to show that the "Trusted Voice" is grayed out differently than if it were just turned off, like "From Any Screen" is.

    Click image for larger version. 

Name:	Screenshot_20160817-094421.jpg 
Views:	16 
Size:	109.4 KB 
ID:	235557

    Click image for larger version. 

Name:	Screenshot_20160817-094427.jpg 
Views:	15 
Size:	105.3 KB 
ID:	235556
    04-20-2017 10:09 AM

Similar Threads

  1. How long to wait for Unlocked US version of the Note 7?
    By pjniez in forum Samsung Galaxy Note 7
    Replies: 34
    Last Post: 08-24-2016, 11:48 AM
  2. Replies: 1
    Last Post: 08-17-2016, 04:26 PM
  3. Replies: 1
    Last Post: 08-17-2016, 12:48 PM
  4. Replies: 0
    Last Post: 08-17-2016, 12:10 PM
  5. Replies: 0
    Last Post: 08-17-2016, 12:08 PM
LINK TO POST COPIED TO CLIPBOARD