1. G-Man8776's Avatar
    I bought my Galaxy S7 Edge about a month ago and I've been loving it, however today I went to use a camera app from the play store (that I've been using fine for almost as long as I've had the phone) and it failed to open.
    No error message.

    I thought that was weird so I opened Snapchat.
    Camera wouldn't load.
    I then opened the default camera app and I got a simple "Camera failed" error.

    I did some reading and couldn't find much, but read some suggestions to clear system settings or remove the SD card and reboot. Another suggestion was to wipe the system and dalvik caches from recovery. I would do this if I were capable, but I currently have TWRP recovery, which normally wouldn't be a problem, but TWRP currently can't get permission to write anything unless I wipe my phone, which I'm far from ready to do.

    I've deleted the camera app from the play store. No dice.
    I've cleared the camera cache and data from within settings. No dice.
    I've cleared all system settings. No dice.
    I've removed my SD card and rebooted. No dice.

    So I essentially have two questions here:
    Most pressing, how could I go about getting my camera to work?
    If only through a cache wipe in recovery, how do I return to stock recovery so that I'm actually capable of doing anything in it?

    EDIT- I just discovered that I'm unable to turn on the flash, as it's being "used by Camera". I feel like that could be important.
    09-13-2016 09:36 PM
  2. chanchan05's Avatar
    Try this:

    Turn phone off, then press volume up and home while powering up. Do not let go of the buttons until you see the spinning Android blue screen. You may be presented with a dead Android screen for a minute but don't mind it. Then you will see the recovery menu. Use the volume buttons to navigate and select 'cache wipe'. Be careful in this as it's right next to 'factory wipe'. Then once highlighted, press the power button to select, and confirm the action. Once done, select power off the phone, then turn it on again.
    09-13-2016 10:55 PM
  3. jbjtkbw007's Avatar
    I had this exact issue. Along with it, I noticed my Samsung Pay also no longer worked. I tried all of the suggestions I could fins and just ended up doing a factory reset. Should have done that from the beginning. Cleared up all issues and camera worked again like a charm.

    The Samsung Pay was the first item to stop working but I thought nothing if it. Then, my camera failed during a summer camp performance for my daughter. I spent the better part of a week trying solutions. Yes, you have to set everything back up, but if I would have done it from the beginning, I would have saved a lot of time.

    Just $.02.
    09-14-2016 07:00 AM
  4. G-Man8776's Avatar
    Try this:

    Turn phone off, then press volume up and home while powering up. Do not let go of the buttons until you see the spinning Android blue screen. You may be presented with a dead Android screen for a minute but don't mind it. Then you will see the recovery menu. Use the volume buttons to navigate and select 'cache wipe'. Be careful in this as it's right next to 'factory wipe'. Then once highlighted, press the power button to select, and confirm the action. Once done, select power off the phone, then turn it on again.
    My current recovery is a custom recovery (TWRP) and it's nonfunctional. If you could help me return it to stock, I would be able to try your suggestion.
    09-14-2016 08:34 PM
  5. aksokhal's Avatar
    hey! i wiped cache partition... and it did work for about a day.... then after a restart it is again happening.
    09-22-2016 01:15 AM
  6. F_Benitez's Avatar
    I did everything including a factory wipe. No luck. What else can I try? Wife's phone. I'm afraid if I don't find a fix, she'll end up taking my S8+
    09-21-2017 11:23 PM

Similar Threads

  1. What is your camera version?
    By TBoltJ in forum HTC 10
    Replies: 12
    Last Post: 09-19-2016, 04:11 PM
  2. Samsung Pay Error
    By Mdsmooth in forum Samsung Pay
    Replies: 6
    Last Post: 09-14-2016, 11:19 AM
  3. GS7E Camera Failing/Help With Stock Recovery
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 09-13-2016, 07:38 PM
  4. My camera is not connect and its not responding or loading
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 09-13-2016, 07:13 PM
LINK TO POST COPIED TO CLIPBOARD