1. freeop's Avatar
    Just got my Gear VR Headset and followed all the steps to get it working. Plugged the phone in and got the GEAR VR Software download screen. Now all it does is it shows "Update Required" and shows Oculus System Activites and "Update Now". I have done the Update Now like 20, 21, 22, etc. Times now and still shows it downloading then back to the Update now.

    I have also uninstalled Oculus completely and plugged the phone back in and it started downloading Oculus again. All 100.4MB. and it now continues to want to Update over and OVER again.

    What am I doing wrong? I can't get any further than that.
    09-21-2016 04:12 PM
  2. SpookDroid's Avatar
    Not sure if it'll help, but are you on WiFi? For some reason mine didn't want to update unless I was on WiFi, but mine didn't even let me download, let alone install.
    09-21-2016 04:16 PM
  3. freeop's Avatar
    Yes sir. I am on WiFi and thought if I disconnected from WiFi and tried to download via the 4G LTE Network that would help. But only thing that changed was the speed that it took to download the update.

    Reconnected WiFi and same thing. "Update Now" just stuck in a continuous loop and can not do anything with the Phone or Gear VR together. Is there any where to download the Gear VR Package or the Oculus update? This is getting me nowhere as it is stuck.
    09-21-2016 04:28 PM
  4. freeop's Avatar
    Well finally figured it out. I did a search on the Oculus Site under the Support/Gear VR section and was reading a post that was exactly like my problem. On about the third or forth reply someone mentioned that if you had an app blocking anything from FACEBOOK, it would not load as Oculus uses the Facebook servers for their downloads.

    Well I had disabled all the Facebook cra... Um services on my phone so nothing was getting through. Once I reinabled all the Facebook stuff, it worked and it finally finished the download and installation of the Oculus software.

    So everything is working now, just because of Facebook. Makes no sense to me, but it works.
    SpookDroid and Cooler299 like this.
    09-21-2016 05:14 PM
  5. SpookDroid's Avatar
    Aha! Thanks for that! Good to know in case other users run into the same issue!
    09-22-2016 01:18 PM
  6. PJRed2008's Avatar
    Aha! Thanks for that! Good to know in case other users run into the same issue!
    Sounds like a sticky?
    09-22-2016 02:35 PM

Similar Threads

  1. Google and their MacBook alternative
    By Radeghost in forum General News & Discussion
    Replies: 4
    Last Post: 09-29-2016, 09:42 PM
  2. Replies: 1
    Last Post: 09-28-2016, 09:12 AM
  3. Interested in Gear S2 or S3
    By steph746 in forum Samsung Gear S2
    Replies: 2
    Last Post: 09-22-2016, 10:25 AM
  4. Replies: 1
    Last Post: 09-21-2016, 12:26 PM
  5. Replies: 1
    Last Post: 09-21-2016, 11:50 AM
LINK TO POST COPIED TO CLIPBOARD