1. lancia12's Avatar
    I just switched to the s7 edge after years of using an iPhone. I will say 2 things before I start: 1) I am a very tech savvy person. 2) I am no Apple fan boy. With that said, I have been eagerly anticipating my switch to the galaxy for months now. I just got the new phones about 2 weeks ago and I have been plagued with problems using the device and I am unable to find workarounds/solutions.
    1) Phone operation - I often have my phone in my pocket and a wired headset attached. One that controls music/phone operations via a button. On my iPhone, when I clicked and held the button Siri would spin up and I would say "Call so and so" and it would just do it, even if the screen was off and the phone locked. On my galaxy, this is not the case. I have been plagued by problems getting any voice recognition to work while the phone is locked. I tried getting google now installed and working but it never seemed to work while the phone screen was off. I now have s voice working but it requires that I use the built-in mic and say a wake-up command. I don't mind the wake up command but I NEED this to work over a wired headset. In my ideal world, clicking and holding the button would launch s voice and I would say "call so and so" and it would work. Is this possible on an android? If so, what headset/config settings to I need to make?
    2) I often listen to music while on my bike...which is daily. The volume was super soft so while the phone was in my pocket and attached via the wired headset, I tried to turn the volume up. It never went up but I could turn it down. So I stopped my bike, pulled out the phone to see what the problem was and I was presented with a message that says something to the effect of "Hey stupid person. Listening to really loud music can cause a boo-boo on your ear. You can't turn up the volume until you click this stupid ok button." I'm sure the intention is to keep people safe but it was actually putting me in danger by messing with my phone while on my bike. I am also sure this is a liability issue but then why isn't a stupid nanny nag window on everything we listen to? The iPhone doesn't have it and that is about as nanny as it gets. Is there any way to turn this off or disable this stupid popup window?
    3) I have a standing conference call every morning. It is an 800 number with an extension. So I have it in my contacts as "800-xxx-xxxx,,123456" so that it dials the extension. I put 2 commas in there because 1 is not enough of a pause before it starts dialing the extension. This 800 number never shows up in my call log. I really need to see this logged because I use it to see how long my phone call was for billing purposes. Is there a reason this doesn't show up in my log? I have it set to show everything.

    I know these things are small but I really need the phone to work like a phone. Not like a computer that can make calls. I am so frustrated I am considering switching to the new iPhone which I really don't want to do. Someone please help me get past #1 as the other stuff I can live with.
    tn_friend likes this.
    09-28-2016 09:55 PM
  2. scott_0's Avatar
    firstly, google now is leaps and bounds better than Siri, Im actually using an iphone 6 at the moment while my S7E is getting the camera repaired at Samsung, and let me tell you, this iphone sucks! but Im partial I guess, you need to go in to the google now settings and set it up for access from any screen, I have mine setup where I dont have to push anything, I simply say "ok google"

    there is no way to turn off the volume warning sadly, but it just needs acknowledged one time after a power up/restart, not every time
    09-29-2016 09:27 AM
  3. IAmSixNine's Avatar
    At one time there used to be a slight difference between headsets that were made for android and ones made for iOS. its more of a compatabilty thing between features of the phones.
    So you may want to start with getting a pair of headphones designed for Android use. See if that corrects the issues you are having with voice controls.

    Yes the volume to loud message is annoying. I listen to music in my truck via BT connection and i just happen to power cycle my phone daily. So every morning i have to tap OK to allow full volume.

    Since your on a conference call every day, and you know the prompts, i would suggest editing the contact so its just a normal 800 number, then manually entering in the prompts. See if that then is recognized in the call logs. If so then the commas or additional numbers is whats causing the phone log to not log the call.
    09-29-2016 11:07 AM
  4. lancia12's Avatar
    I tried google now but I could never seem to get it to override s voice. It also never seemed to work unless the screen was on, locked but on.
    09-29-2016 12:14 PM
  5. lancia12's Avatar
    I was thinking the same thing about the headset. It's only about a year old and I'm pretty sure it was a generic android/iPhone headset. maybe I will buy a different set to test. With an android headset, should pressing and holding the button launch voice recognition? what is the normal behavior when you do that? Currently, I'm not seeing it do anything.
    09-29-2016 12:16 PM
  6. lancia12's Avatar
    I am still unable to get the "phone" portion of this phone to work properly so unfortunately I will be exchanging them back for the new iPhone. Thanks for the replies.
    10-03-2016 03:36 PM
  7. Mirest's Avatar
    3) I have a standing conference call every morning. It is an 800 number with an extension. So I have it in my contacts as "800-xxx-xxxx,,123456" so that it dials the extension. I put 2 commas in there because 1 is not enough of a pause before it starts dialing the extension. This 800 number never shows up in my call log. I really need to see this logged because I use it to see how long my phone call was for billing purposes. Is there a reason this doesn't show up in my log? I have it set to show everything.
    For this one, I usually save the number as 800-xxx-xxxx;123456 and when I actually dial, it does add the pause. Not sure if you tried with a semi colon instead of comma, but that does the trick for me.
    10-03-2016 06:46 PM
  8. IAmSixNine's Avatar
    I am still unable to get the "phone" portion of this phone to work properly so unfortunately I will be exchanging them back for the new iPhone. Thanks for the replies.
    I do believe the "phone" portion of the device works, what your trying to do is add extensions which may be reliant on the PBX system the number your dialing into uses. So the fact you can dial into it means the "phone" portion of the device works just fine, its dialing the number you need to get into the call, whats not working is the extensions after the call has been placed.

    Enjoy your iPhone.
    10-04-2016 08:40 AM
  9. lancia12's Avatar
    I do believe the "phone" portion of the device works, what your trying to do is add extensions which may be reliant on the PBX system the number your dialing into uses. So the fact you can dial into it means the "phone" portion of the device works just fine, its dialing the number you need to get into the call, whats not working is the extensions after the call has been placed.

    Enjoy your iPhone.
    There are 3 areas of the phone that do not work properly.

    1) When the phone is locked, I am still unable to call via headset without unlocking my phone. I've tried google now. I've tried s voice. I've tried BT headset and wired. I've tried trusted voice. I've tried trusted device. Still no go. I absolutely must have a phone that I can make a phone call from my headset and after 2 weeks of troubleshooting I am no able to do this. I haven't tried just leaving my phone totally unlocked but that isn't really a solution.
    2) WiFi calling is a must. I live in an area where no carriers work well so wifi calling is a must. This phone turns my wifi calling off all the time. Then it often has trouble re-connecting. Sometimes I need to reboot the phone and do a voodoo dance to make it connect properly. I can't be on the phone with clients that cant hear me and that is what happens on a call without wifi.
    3) The phone extension issue in the log is not the end of the world, it's just annoying. This isn't a deal breaker but the top 2 are.

    I'm a tech guy and no fanboy of apple at all. I had been looking forward to this switch for months "finally able to ditch apple". But I have honestly never been this frustrated with a phone. These little basic things should just work....perfectly, in every situation and they don't. With all the short comings of the iPhone, I have never had these issues. The phone portion just works. It's too bad because this phone (hardware wise) is still better than the new iPhone.
    10-04-2016 11:25 AM
  10. Toad76's Avatar
    So after reading your post I got to messing around with my s7 and found that by going into the dialer, and then into the settings, I found a section called "answering and ending calls". I clicked on it and turned on automatic answering. Then by pressing on my button on my headphones Google woke up and asked me what I wanted. I said call my wife and it did just that. It even works with the screen off. Went back in and turned off automatic answering and it still works. So now I can make phone calls with my headset and my phone in my pocket.
    10-04-2016 10:09 PM
  11. lancia12's Avatar
    So after reading your post I got to messing around with my s7 and found that by going into the dialer, and then into the settings, I found a section called "answering and ending calls". I clicked on it and turned on automatic answering. Then by pressing on my button on my headphones Google woke up and asked me what I wanted. I said call my wife and it did just that. It even works with the screen off. Went back in and turned off automatic answering and it still works. So now I can make phone calls with my headset and my phone in my pocket.
    Wow...that actually worked. It's funny because I HAD to enable auto answering (which I definitely wouldn't want to have on) first, lock the phone, set google as my default app, try it and it worked. Then disabled auto answering. It now works as it should! You may have just saved me the hassle of swapping to an iphone.

    Now if I could only figure out how to keep the wifi calling from turning itself off...any ideas?!?
    10-06-2016 01:15 AM
  12. Toad76's Avatar
    I'm sure you've done this but make sure that in the phone dialer settings go to Wi-Fi calling and make sure that Wi-Fi preferred is selected. The only issue that I've had is when I'm on my 2.4ghz it drops a lot. When I'm on the 5ghz it seems to work good for me. Hope that helps.
    10-06-2016 11:55 AM
  13. Gray Area's Avatar
    I'm sure you've done this but make sure that in the phone dialer settings go to Wi-Fi calling and make sure that Wi-Fi preferred is selected. The only issue that I've had is when I'm on my 2.4ghz it drops a lot. When I'm on the 5ghz it seems to work good for me. Hope that helps.
    I've had the same experience! Wifi calling rarely drops when I'm on a 5ghz band. Also, I've found it's more stable when you only have 1 wifi ch enabled at a time in the wifi calling app. If you have multiple ch enabled it seems to occasionally, not be able to figure out which wifi ch your connected too and therefore won't connect or drop.
    10-07-2016 07:28 AM
  14. Dukins's Avatar
    Wow...that actually worked. It's funny because I HAD to enable auto answering (which I definitely wouldn't want to have on) first, lock the phone, set google as my default app, try it and it worked. Then disabled auto answering. It now works as it should! You may have just saved me the hassle of swapping to an iphone.

    Now if I could only figure out how to keep the wifi calling from turning itself off...any ideas?!?
    What do you mean set google as my default app? I have been trying to have this function for years with android. With my iphone it was so seamless.

    So after reading your post I got to messing around with my s7 and found that by going into the dialer, and then into the settings, I found a section called "answering and ending calls". I clicked on it and turned on automatic answering. Then by pressing on my button on my headphones Google woke up and asked me what I wanted. I said call my wife and it did just that. It even works with the screen off. Went back in and turned off automatic answering and it still works. So now I can make phone calls with my headset and my phone in my pocket.
    Dude you are a godsend thank you for this. Unfortunately I am having a hard time for this to work with my Note 7. I wish I still had my edge to test on.


    Nevermind finally got it to work. I had to disable S-Voice.
    10-07-2016 07:50 AM
  15. ksanger35's Avatar
    What do you mean set google as my default app? I have been trying to have this function for years with android. With my iphone it was so seamless.



    Dude you are a godsend thank you for this. Unfortunately I am having a hard time for this to work with my Note 7. I wish I still had my edge to test on.


    Nevermind finally got it to work. I had to disable S-Voice.
    I just turned auto answer when on Bluetooth off as the phone was answering while still in my pocket. Hope that doesn't kill the phone while working in my Vehicle using the vehicle bluetooth connection.
    11-20-2017 06:48 PM

Similar Threads

  1. Replies: 1
    Last Post: 09-29-2016, 07:08 AM
  2. how can i restore my deleted IMO chats?who can help me?plc
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 09-29-2016, 05:06 AM
  3. HDMI Galaxy S6
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 09-29-2016, 02:39 AM
  4. Battery Charging Animation Broken? How to Fix?
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 09-28-2016, 09:39 PM
  5. Battery Drain While Charging - Phone OFF Why?
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 09-28-2016, 09:36 PM
LINK TO POST COPIED TO CLIPBOARD