05-15-2017 09:30 AM
54 123
tools
  1. markm75's Avatar
    I have a bit of an update on my draining issue..

    I recently did the android 7 upgrade.. and a full reset.. followed by a restore of all apps from a backup (also tried from scratch).. there may have been marginally better life on the one Not restored from backup, still unclear.. at any rate i'm back full blown install..

    I think i found a few sources of drain or at least wakelocks.. one may have been weatherbug.. another the tmobile app (i'm on metro pcs).. i've disabled these and it seems better.

    I switched wifi to sleep when off, unless charging.. i also made sure wifi calling was set to only if cellular quality was poor.

    Gsam though, is acting odd.. i ran the adb command to enable more stats.. it worked fine but randomly switches back to "combined cpu" view for things.. its also reporting now that my phone signal use is at 0 minutes over 4 hours time (cant be).. and wifi at full blown the whole time (both in good cell areas and not)..

    Yesterday eve, at home in 4-5 bar cell areas.. i got it down to about 1.6% per hour when off.. wifi actually went to sleep for some of the hours in the tests.. this has never happened before.

    Now here we are today though (bluetooth off btw).. and at work i was sitting at around 2.4% per hour when off (before at work this would be more like 3.9-7% when off), but now with the weird phone use vs wifi and combined cpu thing on gsam..

    I just restarted the phone.. gsam is reporting the correct things and showing more stats (not combined cpu) now.

    I suspect at least at work, the major culprit is the cell signal being weak (1-2 bars generally).. i can get 0 to 0.5% per hour (i think) when i switch to airplane mode at work..

    Still testing but at least some progress, though i need to confirm weatherbug really caused the drain (wakelock viewer seemed to indicate it and tmobile woke things up the most), though even that wakelock viewer is confusing and doesnt seem to have a way to reset the hour count.
    05-12-2017 10:34 AM
  2. markm75's Avatar
    I did a 30 min test in airplane mode with wifi ON (radio off).. basically 5 min held awake (10 per hour roughly) and 0% per hour drain while off.. i'm guessing its the phone radio causing the issue.. but i wonder if its poor metropcs or if its a "bad" radio, if thats possible.

    In another airplane test i turned wifi off.. over 49 mins it was held awake 2 mins.. android system (50%) kept it awake 1min 30sec.. again caused by imsservice and Kernel was at 2min 5sec keep awake, overall 0%/hour with wifi off + airplane

    And for another.. normal mode but wifi off.. over 45min 54 sec screen time, held awake 6min, and 1.3%/hr while off (no wifi use obviously and 45 mins of phone radio active), doze time light shows 34min with 76% screen off, while deep shows nothing
    05-12-2017 01:18 PM
  3. markm75's Avatar
    I did a 30 min test in airplane mode with wifi ON (radio off).. basically 5 min held awake (10 per hour roughly) and 0% per hour drain while off.. i'm guessing its the phone radio causing the issue.. but i wonder if its poor metropcs or if its a "bad" radio, if thats possible.

    In another airplane test i turned wifi off.. over 49 mins it was held awake 2 mins.. android system (50%) kept it awake 1min 30sec.. again caused by imsservice and Kernel was at 2min 5sec keep awake, overall 0%/hour with wifi off + airplane

    And for another.. normal mode but wifi off.. over 45min 54 sec screen time, held awake 6min, and 1.3%/hr while off (no wifi use obviously and 45 mins of phone radio active), doze time light shows 34min with 76% screen off, while deep shows nothing
    More testing, this time overnight.. i get anywhere from 0.8 / hour loss to 1.5 / hour.. i noticed over 2 hr 45 min that it only went into deep sleep for 16 minutes.. how long wifi comes on also seems to be a factor.. the last 2hr 45 min segment it came on for 59 minutes i think.. whereas the lesser drain rates it only came on for much less, say 15 minutes over 3 hours.
    05-15-2017 09:18 AM
  4. markm75's Avatar
    Work based, low signal area testing when off latest example:
    41minutes 4.4% / hour, radio 41 minutes, wifi 0 minutes, held awake 8 minutes.. app usage..
    Attached Thumbnails S7 edge battery issues, drain, gsam stats? MetroPCS/Tmobile varient-screenshot_20170515-102657.png  
    05-15-2017 09:30 AM
54 123

Similar Threads

  1. Why is my phone battery dying so fast?
    By AC Question in forum Ask a Question
    Replies: 5
    Last Post: 08-26-2018, 08:39 PM
  2. HDR content on Netflix, now available!
    By slackerjack in forum Samsung Galaxy Note 7
    Replies: 11
    Last Post: 10-02-2016, 11:58 AM
  3. SD Card issues
    By rs990 in forum Samsung Galaxy S7 edge
    Replies: 3
    Last Post: 09-30-2016, 03:02 PM
  4. clear negitive images on my phonr
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 09-30-2016, 02:52 PM
LINK TO POST COPIED TO CLIPBOARD