1. traneupcqk's Avatar
    I have rooted my S7 Edge Snapdragon version.

    After rooted, my front camera takes very dark and red picture, just like negative color.
    I also unrooted, flashed latest stock firmware but camera issue still persists. I know that some people who don't have their device rooted seems to have the same problem like me.

    Does anyone here have the same issue ? I've searched everywhere but still had no answer.
    http://imgur.com/9fjoZpI
    10-13-2016 12:01 AM
  2. SpookDroid's Avatar
    Does it do it if you use a 3rd party camera app (like Facebook's or any other cameras)? What about if you go into Safe Mode? Are you sure you don't have any filters enabled?
    10-13-2016 12:20 AM
  3. traneupcqk's Avatar
    Does it do it if you use a 3rd party camera app (like Facebook's or any other cameras)? What about if you go into Safe Mode? Are you sure you don't have any filters enabled?
    Totally fine when i use 3rd party camera app. I haven't tested in safemode yet.
    I'm sure 100% that there are no filters enabled.
    10-13-2016 12:47 AM
  4. SpookDroid's Avatar
    OK, so it's not a hardware issue. Have you tried clearing data/cache from the stock Camera app in the Application Manager? Are you seeing the 'negative' effect while taking the picture or only after it's been taken? If the latter, check if your pictures are being saved to internal memory VS SD Card.
    10-13-2016 02:58 AM
  5. traneupcqk's Avatar
    OK, so it's not a hardware issue. Have you tried clearing data/cache from the stock Camera app in the Application Manager? Are you seeing the 'negative' effect while taking the picture or only after it's been taken? If the latter, check if your pictures are being saved to internal memory VS SD Card.
    I've tried clearing data and cache from camera app.
    The negative effect can be seen only after taking photos (While taking picture is okay). No matter where i save photo, the result is same (SD card and internal)
    10-13-2016 07:45 AM
  6. Kudzai Dhodho's Avatar
    I've tried clearing data and cache from camera app.
    The negative effect can be seen only after taking photos (While taking picture is okay). No matter where i save photo, the result is same (SD card and internal)
    I have the same problem on my note 7. I've rooted I'm not so sure its the cause, but I started to experience the problem after rooting. I've looked everywhere no-one seems to know a solution rather than just using a 3rd party camera app.
    10-13-2016 01:06 PM
  7. SpookDroid's Avatar
    If it happens after rooting I'm wondering if this has something to do with the Knox fuse. I don't see HOW that would make the pictures save 'funny', but it's the only thing that jumps out when thinking of rooting these phones. If re-loading the camera app doesn't help, then I guess you're forced to use a 3rd party camera to use the front-facing one?
    traneupcqk likes this.
    10-13-2016 09:05 PM
  8. traneupcqk's Avatar
    I have the same problem on my note 7. I've rooted I'm not so sure its the cause, but I started to experience the problem after rooting. I've looked everywhere no-one seems to know a solution rather than just using a 3rd party camera app.
    I think i should do a "NAND erase all" to see that it will fix it or not.
    I also asked a guy on reddit about the front camera issue. He said that he had some random update and it was fix.
    10-13-2016 10:12 PM
  9. traneupcqk's Avatar
    If it happens after rooting I'm wondering if this has something to do with the Knox fuse. I don't see HOW that would make the pictures save 'funny', but it's the only thing that jumps out when thinking of rooting these phones. If re-loading the camera app doesn't help, then I guess you're forced to use a 3rd party camera to use the front-facing one?
    I think so. Thanks for your support, anyway
    10-13-2016 10:13 PM
  10. traneupcqk's Avatar
    So i did NAND erase all and the problem is still there. That's bad.
    10-14-2016 08:25 AM
  11. SpookDroid's Avatar
    Well, at least you can still use a 3rd party camera. I guess tripping the root fuse does screw it up.
    10-15-2016 12:25 AM

Similar Threads

  1. S7 battery problem?
    By Chalanthorn Chanmathikornkul in forum Samsung Galaxy S7
    Replies: 21
    Last Post: 10-20-2016, 09:31 PM
  2. Photo Software
    By SimeonLatremoille in forum Axon 7 & Axon 7 mini
    Replies: 4
    Last Post: 10-20-2016, 11:20 AM
  3. New phone s7 edge
    By AC Question in forum Ask a Question
    Replies: 2
    Last Post: 10-13-2016, 01:50 AM
  4. Replies: 1
    Last Post: 10-13-2016, 01:44 AM
  5. Replies: 0
    Last Post: 10-12-2016, 10:19 PM
LINK TO POST COPIED TO CLIPBOARD