1. dvarapala's Avatar
    I have a Motorola car charger that I've had for a while (originally bought it for my Note 3). The other day I tried to use it with my S7 edge but it refused to charge, claiming that it had detected "moisture" in the USB port.

    The plug looks like this:



    It does have some small ridges on one side which may be what is false-triggering the moisture detection.

    Anyone else have this problem? Any way to solve it short of buying a new car charger?
    10-23-2016 02:57 PM
  2. nahoku's Avatar
    Can't see the photo.

    Is the charger spec'd for the S7 requirements. Maybe the charger is underrated and the phone is mistakenly determining the low power for a wet usb connector... no idea.
    10-23-2016 04:19 PM
  3. oks10's Avatar
    I'm having the same thing with the travel charger I've got. Both my S7E and my wife's S7 give the error. I'm pretty sure I've used the charger before though, not sure when it stopped working.
    10-25-2016 09:28 PM

Similar Threads

  1. How close to stock is the V20 launcher?
    By MoonShade in forum LG V20
    Replies: 18
    Last Post: 10-25-2016, 02:28 PM
  2. Replies: 0
    Last Post: 10-23-2016, 02:50 PM
  3. my phone is not running right?
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 10-23-2016, 02:44 PM
  4. Why is my battery life draining so fast?
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 10-23-2016, 02:41 PM
  5. Replies: 0
    Last Post: 10-23-2016, 02:39 PM
LINK TO POST COPIED TO CLIPBOARD