12-18-2017 09:33 PM
51 123
tools
  1. Nic Zibelli's Avatar
    Hello! The battery percentage of my Galaxy S7 Edge has been running low at a rapid pace lately, and I think the cause is definitely the weird constant turning off and on of my WiFi. Here is a link to the screen recording I took: https://photos.google.com/share/AF1Q...pTOFh0dURSb3h3 . I am not touching the WiFi shortcut or the On/Off button at all, illustrated by the touch-showing setting. I have tried restarting my phone and messing with the WiFi settings, but nothing is working. Please help!
    11-17-2016 08:27 AM
  2. anon(632115)'s Avatar
    Try disabling Smart Network switch in wifi settings
    11-17-2016 09:09 AM
  3. 420lyfe's Avatar
    Yeah I agree with op.
    11-17-2016 09:24 AM
  4. Nic Zibelli's Avatar
    It is disabled
    11-17-2016 10:18 AM
  5. Nic Zibelli's Avatar
    PROBLEM SOLVED: not sure how I fixed it but it's working properly again
    srkmagnus likes this.
    11-17-2016 11:32 AM
  6. DJS_T's Avatar
    My S7 Edge started doing the exact same thing 2 days ago!

    If I manually turn WiFi off once, it gets stuck in this infinite loop and won't stay turned on or off. The only way I've found to combat it so far is a cache partition clear, but this only fixes it until the next time WiFi is turned off.

    As a couple of devices have started doing it at the same time, could we assume it's a borked software update? Anyone able to shed any more light on it?
    11-17-2016 05:20 PM
  7. Nic Zibelli's Avatar
    PROBLEM SOLVED: not sure how I fixed it but it's working properly again
    problem NOT solved: the bug has come back; I noticed this happening at the beginning of the week; NEED HELP, please!
    11-18-2016 05:16 AM
  8. Chris5626's Avatar
    Having the same issue with my S7 Edge plus. At first I thought I was just forgetting to turn wifi on when at home and off when out but I've seen the button in the settings shortcut menu turn on and off by itself.
    11-19-2016 09:24 AM
  9. GoLfWRC's Avatar
    Me too, having this issue since last update on my S7. I believe this is a firmware issue. (In additional, not only S7 but also J7 Prime is having the same kind of problem)

    We may need to wait for another update then.
    11-19-2016 09:19 PM
  10. Cam Roland's Avatar
    Well there does need to be an update but I found a temporary fix for my G7 Edge. Go to Settings>Privacy and safety>Location>Improve Accuracy> and Disable Wi-Fi Scanning. It worked for me, if it doesn't for you then I have no idea.
    rgriffin25 likes this.
    11-19-2016 09:51 PM
  11. GoLfWRC's Avatar
    Well there does need to be an update but I found a temporary fix for my G7 Edge. Go to Settings>Privacy and safety>Location>Improve Accuracy> and Disable Wi-Fi Scanning. It worked for me, if it doesn't for you then I have no idea.
    I'll try. Thanks for advice.
    42Teslagirl likes this.
    11-19-2016 09:58 PM
  12. Giannis_Korakidis's Avatar
    Well there does need to be an update but I found a temporary fix for my G7 Edge. Go to Settings>Privacy and safety>Location>Improve Accuracy> and Disable Wi-Fi Scanning. It worked for me, if it doesn't for you then I have no idea.
    I can confirm that the above fix worked for me. I am testing this for 30 mins and all is ok. No turning on and off until now. I too believe that a bad software update may have caused the problem. Hope it helps you too.
    42Teslagirl likes this.
    11-20-2016 04:02 PM
  13. GoLfWRC's Avatar
    Also fixed for me after monitoring this for a day.
    11-20-2016 11:01 PM
  14. DJS_T's Avatar
    Well there does need to be an update but I found a temporary fix for my G7 Edge. Go to Settings>Privacy and safety>Location>Improve Accuracy> and Disable Wi-Fi Scanning. It worked for me, if it doesn't for you then I have no idea.
    Can confirm that this fixed it for me too.
    42Teslagirl likes this.
    11-21-2016 04:42 AM
  15. Nic Zibelli's Avatar
    Well there does need to be an update but I found a temporary fix for my G7 Edge. Go to Settings>Privacy and safety>Location>Improve Accuracy> and Disable Wi-Fi Scanning. It worked for me, if it doesn't for you then I have no idea.
    Thank you so much for your suggestion! It's working properly again.
    11-21-2016 06:16 AM
  16. Shadowhawk's Avatar
    Well there does need to be an update but I found a temporary fix for my G7 Edge. Go to Settings>Privacy and safety>Location>Improve Accuracy> and Disable Wi-Fi Scanning. It worked for me, if it doesn't for you then I have no idea.
    I noticed this on 11/15 along with a faster than expected battery usage and the phone getting really hot on the wifi at work. I didn't seem able to stay connected, which matches with the on-off visual of the toggle switching.

    i have a Verizon Samsung Galaxy S7 Edge that I got in April, right about when they came out.

    I did a video and phone chat with a Samsung agent via their support app, and disabling the Wi-Fi scanning is where our discussion eventually led.

    i did that, and it is no longer a problem.

    Still and all...I feel like that's not how that feature is supposed to work, so it seems that's just a workaround for a bug.

    Thanks!
    => Shadowhawk
    11-21-2016 09:31 PM
  17. justdubya's Avatar
    I came here looking for answers to the same question regarding my Note 4. This solution worked for me as well.

    Thanks!!
    11-22-2016 09:33 AM
  18. tennislvr8's Avatar
    This happens to me too. It says my WiFi connection is weak. That has never been an issue for me before this phone. I tired this and it didn't fix it.
    11-22-2016 11:01 AM
  19. zeek_11's Avatar
    I'm so grateful for this forum. Had this issue on my S5 and my brand new S7. Was driving me crazy. This fix worked for me as well. So happy!!!
    11-26-2016 01:00 PM
  20. Murph5150's Avatar
    I hate to say it, but if you've received the update and there has been no solution found, a factory reset is probably your only option.

    Ironically, this is the first update on my S7 Edge I didn't have to do a factory reset. However, I do have a problem I have not yet solved. My phone gets extremely hot now. Before the update, my phone, under stress, would become "warm." Now, it is generating tremendous heat and I really don't want to perform a fourth factory reset.

    Is anyone else experiencing excessive heat?
    11-26-2016 03:58 PM
  21. Alanhd's Avatar
    I've just realised I'm having the same issue, turning off wifi scanning did fix it, but like others have said this is a workaround. Hopefully this will be fixed in the next update.
    11-27-2016 05:37 AM
  22. tennislvr8's Avatar
    What really fixed it for me was removing the password on the 5G WiFi.
    11-27-2016 07:11 AM
  23. G_M_2's Avatar
    Great! The first solution worked, and then I forgot the 5G wifi connection, set the original setting back on, and wifi is still connected. For me it is the 5G wifi I think. Thank you so much
    11-27-2016 04:01 PM
  24. zrene's Avatar
    I have the same issue. I found a way to fix it temporarily by clicking on "Wi-Fi Direct" and going back (under Settings->wifi).
    11-27-2016 04:28 PM
  25. dvarapala's Avatar
    Same issue here; I tried disabling WiFi-based location, so far so good...
    11-29-2016 07:26 AM
51 123

Similar Threads

  1. Sony Xperia Z5 Premium Dual E6883 Looking To Replace S7 Edge-Yes or No?
    By 123spongebob123 in forum Sony Xperia Z5 Premium
    Replies: 1
    Last Post: 12-01-2016, 07:11 AM
  2. This phone is starting to grow on me
    By AGC 1906 in forum Samsung Galaxy S7 edge
    Replies: 29
    Last Post: 11-21-2016, 08:36 AM
  3. Chrome on S6 not opening to set home page
    By williamhcraft in forum Samsung Galaxy S6
    Replies: 1
    Last Post: 11-17-2016, 10:44 AM
  4. Why doesn't my BT200 headphones show up on my Nexus 7 tablet?
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 11-17-2016, 08:18 AM
  5. proximity sensor not working on galaxy S5.
    By abhi997 in forum Ask a Question
    Replies: 0
    Last Post: 11-17-2016, 07:12 AM
LINK TO POST COPIED TO CLIPBOARD