1. GSMacLean's Avatar
    I have had my S7 Edge for about a month and a half now, after getting it in exchange for my amazing Note 7, which I still mourn.

    I have a wireless charger on my desk at work, and plug it in at home to charge. Both are using the OEM Samsung quick charger and OEM white cable.

    I noticed yesterday that my phone was at 78% when I plugged it in, and an hour later, it was only at 82%. Huh? I looked, and it said that it would complete charging in 4 hours and 35 minutes. Something's wrong. I also noticed that instead of "fast charging" it just said "cable charging."

    I rebooted the phone and tried again. No difference. I checked the battery setup, it was set to fast charge both cable and wireless.

    I put it on the wireless charger, and it started fast charging like normal.

    I tried plugging my wife's S7 Edge into the cable, it fast charged with no problem.

    I tried plugging my phone into a different charger, it would not fast charge. My wife's phone would.

    I tried turning my phone off and charging it with the cable while it was shut off. It still charged extremely slowly. So that rules out an application causing the problem.

    I had a look at the charging port. It looked pristine. I sprayed it out with quality CRC electrical contact cleaner just to be sure. No change.

    Anyone have any ideas or suggestions as to what might be causing this, and more importantly, how to fix it?
    12-22-2016 12:53 PM
  2. junianby's Avatar
    Go to settings then battery and make sure fast cable charging is on.
    12-22-2016 01:07 PM
  3. GSMacLean's Avatar
    Go to settings then battery and make sure fast cable charging is on.
    As I mentioned in my original posting, I already checked this. In fact, I tried turning them both off, testing, then turning them back on and testing again. No difference.

    I have a USB power meter that, when I plug my phone in, shows it is drawing only 0.43 amps when charging. So not only is it not fast charging, but the cable charging is running extremely slow as well, which no doubt is why it says it would take 4 1/2 hours to fully charge from 82%.
    12-22-2016 02:45 PM
  4. Kiet189's Avatar
    I have had my S7 Edge for about a month and a half now, after getting it in exchange for my amazing Note 7, which I still mourn.

    I have a wireless charger on my desk at work, and plug it in at home to charge. Both are using the OEM Samsung quick charger and OEM white cable.

    I noticed yesterday that my phone was at 78% when I plugged it in, and an hour later, it was only at 82%. Huh? I looked, and it said that it would complete charging in 4 hours and 35 minutes. Something's wrong. I also noticed that instead of "fast charging" it just said "cable charging."

    I rebooted the phone and tried again. No difference. I checked the battery setup, it was set to fast charge both cable and wireless.

    I put it on the wireless charger, and it started fast charging like normal.

    I tried plugging my wife's S7 Edge into the cable, it fast charged with no problem.

    I tried plugging my phone into a different charger, it would not fast charge. My wife's phone would.

    I tried turning my phone off and charging it with the cable while it was shut off. It still charged extremely slowly. So that rules out an application causing the problem.

    I had a look at the charging port. It looked pristine. I sprayed it out with quality CRC electrical contact cleaner just to be sure. No change.

    Anyone have any ideas or suggestions as to what might be causing this, and more importantly, how to fix it?
    Same thing happened to me couple months back.
    Contact Samsung and provide proof of purchase and they will send you a new one.

    My replacement got sent within a week and works flawlessly and the wire is slightly longer than the old one!
    12-22-2016 03:32 PM
  5. GSMacLean's Avatar
    Well after messing around with T-Mobile a few times, they've finally decided that the phone is defective and are replacing it. Unlike previous experiences, they will no longer ship the replacement to my house - apparently you must now go to a local store to pick up the phone. What a huge PITA - every single experience I have had with the people at that store has been a nightmare.

    I also discovered that the USB port on my phone no longer functions as a USB port - I can't "see" the phone when plugged into any computer. So obviously something serious went wrong with the USB port, where it barely charges and won't transfer data anymore.
    01-02-2017 04:17 PM

Similar Threads

  1. I put my SIM card in my phone but no network found.
    By Calhoun1973 in forum General Help and How To
    Replies: 1
    Last Post: 12-23-2016, 03:53 AM
  2. Replies: 1
    Last Post: 12-23-2016, 02:13 AM
  3. forgot backup password, print wont work, 6s edge
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 12-22-2016, 02:39 PM
  4. Replies: 1
    Last Post: 12-22-2016, 10:26 AM
  5. Google search widget isn't working
    By kill4food in forum Ask a Question
    Replies: 0
    Last Post: 12-22-2016, 10:08 AM
LINK TO POST COPIED TO CLIPBOARD