09-05-2017 02:06 AM
44 12
tools
  1. mundo472's Avatar
    this is the only option for notifications, its ridiculous
    Like that theme, though. Which one is it?
    03-02-2017 05:02 PM
  2. JameAde's Avatar
    Did not know that, hopefully the developer will actually update to work on nougat if possible at all.

    One of the reasons I hate updates, or I should say updates are a double edge sword, get some nice improvements, but at the price of losing other features and possible performance issues.

    Well, guess headsoff isn't an option on nougat.
    Yeah, to add I have a S7 Edge and pop-up notifications on 6.0.1 used to show the contact picture and message details, but now on 7.0 it only shows the word "Message" twice?!?!?!?! No matter if it's the stock messages app or gmail and I've been through all the settings. Someone forgot to fully test 7.0. I really hope they fix it.
    03-05-2017 07:45 PM
  3. Chipsnchips's Avatar
    Why not just turn on do not disturb whilst you're in your car with people if you don't want them to see anything? Don't personally see why you're wanting to hide the content, but it seems there's no option in the settings to hide heads up content.
    It's not just about being in one place and wanting to hide stuff. I don't want sensitive information, for example about projects I'm working on, to be viewable by anyone who can see my screen. The pop ups are also big and very much disrupt whatever I'm working on.

    Having to constantly amend my settings to suit changes in location is a ridiculous solution to what was never a problem on 6.0.
    Louisa ag likes this.
    03-17-2017 09:32 PM
  4. Chipsnchips's Avatar
    The 7.0 uodate only just came to Japan so it's only just effected me. Has anyone had any luck fixing?

    The above fix using the pc and debug tools, I'm assuming that's a pc only fix right?
    03-17-2017 10:04 PM
  5. Chipsnchips's Avatar
    Hi Widget, did you ever get a fix for this? Just received the update myself today and it's driving me crazy!
    Louisa ag likes this.
    03-18-2017 01:56 AM
  6. javiertoti's Avatar
    Finally found the solution on S7 Edge running Android Nougat, tried and testing, its working.

    1.Follow the instructions here to install and use ADB

    How to Install and Use ADB, the Android Debug Bridge Utility

    2.Once it is installed and you have verified that it works (verification step is also given in the above page), just type the below command in the command (cmd.exe) window on the PC (phone should be connected by USB)

    adb shell settings put global heads_up_notifications_enabled 0


    Basically its connecting your phone to the PC and sending a command through the PC emulator window to your phone system and disabling the heads up notifications.

    If working for you all, lets spread the word to other forums too.

    tnx
    rgds
    Mayur
    I've just registered to say you THANKS!!!
    03-19-2017 02:36 PM
  7. songjuhee's Avatar
    [spoiler]
    Finally found the solution on S7 Edge running Android Nougat, tried and testing, its working.

    1.Follow the instructions here to install and use ADB

    How to Install and Use ADB, the Android Debug Bridge Utility

    2.Once it is installed and you have verified that it works (verification step is also given in the above page), just type the below command in the command (cmd.exe) window on the PC (phone should be connected by USB)

    adb shell settings put global heads_up_notifications_enabled 0


    Basically its connecting your phone to the PC and sending a command through the PC emulator window to your phone system and disabling the heads up notifications.

    If working for you all, lets spread the word to other forums too.

    tnx
    rgds
    Mayur
    [/spoiler]

    THANKS.!! it works
    03-26-2017 10:21 PM
  8. Mahroo Sharegh's Avatar
    hi ,
    im new to the forum but not to samsung phones, my s7 edge has been faultless until today when i updated it to 7.0

    now i cannot receive a message without it displaying it in the top heads up which is no good to me as my phone is usually always on in the car etc and everyone in there can now see my messages.
    there is no option to stop this except for turning off everything so you get no sound,vibration or preview where before you could just select to hide preview messages.
    if there is no way to hide these then 7.0 is useless to me as i need my privacy and i also like to be notified of a message etc.
    it is crazy if they leave it like this, how can i go back to 6.0 after updating ?

    thank you
    04-02-2017 05:19 AM
  9. Jaleks's Avatar
    Finally found the solution on S7 Edge running Android Nougat, tried and testing, its working.

    1.Follow the instructions here to install and use ADB

    How to Install and Use ADB, the Android Debug Bridge Utility

    2.Once it is installed and you have verified that it works (verification step is also given in the above page), just type the below command in the command (cmd.exe) window on the PC (phone should be connected by USB)

    adb shell settings put global heads_up_notifications_enabled 0


    Basically its connecting your phone to the PC and sending a command through the PC emulator window to your phone system and disabling the heads up notifications.

    If working for you all, lets spread the word to other forums too.

    tnx
    rgds
    Mayur
    This works on my S7 Edge (SM-G935F) as well, thank you.
    04-04-2017 04:35 PM
  10. widget2k13's Avatar
    This works on my S7 Edge (SM-G935F) as well, thank you.
    was working fine on my s7 edge.

    but i just got he new s8 and guess what ?

    it doesnt work on that and back to square one
    04-22-2017 11:56 AM
  11. mundo472's Avatar
    this is the only option for notifications, its ridiculous
    Agreed. Ridiculous.
    04-26-2017 07:55 AM
  12. widget2k13's Avatar
    ah at least someone agrees with me
    04-27-2017 02:25 AM
  13. roacharu's Avatar
    Finally found the solution on S7 Edge running Android Nougat, tried and testing, its working.

    1.Follow the instructions here to install and use ADB

    How to Install and Use ADB, the Android Debug Bridge Utility

    2.Once it is installed and you have verified that it works (verification step is also given in the above page), just type the below command in the command (cmd.exe) window on the PC (phone should be connected by USB)

    adb shell settings put global heads_up_notifications_enabled 0


    Basically its connecting your phone to the PC and sending a command through the PC emulator window to your phone system and disabling the heads up notifications.

    If working for you all, lets spread the word to other forums too.

    tnx
    rgds
    Mayur
    Thank You!!! It works!
    05-11-2017 10:52 AM
  14. the_new_mr's Avatar
    Finally found the solution on S7 Edge running Android Nougat, tried and testing, its working.

    1.Follow the instructions here to install and use ADB

    How to Install and Use ADB, the Android Debug Bridge Utility

    2.Once it is installed and you have verified that it works (verification step is also given in the above page), just type the below command in the command (cmd.exe) window on the PC (phone should be connected by USB)

    adb shell settings put global heads_up_notifications_enabled 0


    Basically its connecting your phone to the PC and sending a command through the PC emulator window to your phone system and disabling the heads up notifications.

    If working for you all, lets spread the word to other forums too.

    tnx
    rgds
    Mayur
    Awesome. Thanks!
    06-05-2017 09:18 PM
  15. the_new_mr's Avatar
    was working fine on my s7 edge.

    but i just got he new s8 and guess what ?

    it doesnt work on that and back to square one
    I saw someone else say it works for them on an S8. I don't have an S8 so can't verify. But I wonder have you remembered to turn on USB debugging while trying this? This is necessary for ADB to be able to talk to the device. Turn USB debugging off when you're finished.
    06-05-2017 09:20 PM
  16. Dariush Aliyan's Avatar
    hi every one
    i'm iranian
    my phone samsung a5 2016
    android 6.01 to 7 updated

    in whatsapp just go to whatsaspp setting and notification and put perview popup to always show popup....
    yes really answered
    06-06-2017 06:16 AM
  17. pappcam's Avatar
    hi every one
    i'm iranian
    my phone samsung a5 2016
    android 6.01 to 7 updated

    in whatsapp just go to whatsaspp setting and notification and put perview popup to always show popup....
    yes really answered
    So you don't have the same phone, you are talking about a different app, and your "fix" does nothing to solve the OP's issue.

    Well done.
    06-06-2017 01:43 PM
  18. Foxtrotoscar73's Avatar
    Simple fix my friend, go to the play store and get Light flow. Make sure you flick the toggle to show silently in the apps section for WhatsApp.
    09-03-2017 03:39 AM
  19. the_minidude's Avatar
    Finally found the solution on S7 Edge running Android Nougat, tried and testing, its working.

    1.Follow the instructions here to install and use ADB

    How to Install and Use ADB, the Android Debug Bridge Utility

    2.Once it is installed and you have verified that it works (verification step is also given in the above page), just type the below command in the command (cmd.exe) window on the PC (phone should be connected by USB)

    adb shell settings put global heads_up_notifications_enabled 0


    Basically its connecting your phone to the PC and sending a command through the PC emulator window to your phone system and disabling the heads up notifications.

    If working for you all, lets spread the word to other forums too.

    tnx
    rgds
    Mayur

    YES! YES! YES! finally a fix!!
    The ADB downloads section is a little different to all the steps described and I ended up downloading the full studio.

    Just tested on my S6 and it works.

    Hate that the new version on droid is so glitchy with notifications. You can set them off, but they stay on. Who wants a big intrusive banner notification on your screen anyway?!
    Ran these steps and after a few minutes, all my problems gone.

    Thanks for this awesome fix, much appreciated.
    09-05-2017 02:06 AM
44 12

Similar Threads

  1. Nougat Battery life
    By Wizzy in forum Samsung Galaxy S7 edge
    Replies: 10
    Last Post: 03-14-2017, 03:55 PM
  2. Replies: 11
    Last Post: 02-07-2017, 02:27 PM
  3. Replies: 4
    Last Post: 02-05-2017, 08:48 PM
  4. Replies: 1
    Last Post: 02-04-2017, 09:55 PM
  5. Replies: 0
    Last Post: 02-04-2017, 02:17 PM
LINK TO POST COPIED TO CLIPBOARD