09-05-2017 02:06 AM
44 12
tools
  1. widget2k13's Avatar
    hi ,
    im new to the forum but not to samsung phones, my s7 edge has been faultless until today when i updated it to 7.0

    now i cannot receive a message without it displaying it in the top heads up which is no good to me as my phone is usually always on in the car etc and everyone in there can now see my messages.
    there is no option to stop this except for turning off everything so you get no sound,vibration or preview where before you could just select to hide preview messages.
    if there is no way to hide these then 7.0 is useless to me as i need my privacy and i also like to be notified of a message etc.
    it is crazy if they leave it like this, how can i go back to 6.0 after updating ?

    thank you
    Mahroo Sharegh and the_new_mr like this.
    02-04-2017 05:43 PM
  2. B. Diddy's Avatar
    Welcome to Android Central! Try going to Settings>Notifications, select your messaging app, and manually set the "Importance" to "No full screen interruption or peeking." (This is on my Nexus 6P -- the menu setup might be a little different on your phone.)

    When you have a chance, head over to the Intros forum and tell us something about yourself! http://forums.androidcentral.com/introductions/
    02-04-2017 07:29 PM
  3. trucksmoveamerica#AC's Avatar
    This app worked for me. I used it to stop the battery full notification to pop up waking me up at night.

    https://play.google.com/store/apps/d...orks.noheadsup
    02-04-2017 10:28 PM
  4. widget2k13's Avatar
    that heads up app worked great until nougat, it doesnt work with it on the s7

    and there is no options anymore in the s7 with nougat to turn off heads up peeking you got to turn it all off or nothing, they have ruined it doing that
    02-05-2017 02:15 AM
  5. widget2k13's Avatar
    this is the only option for notifications, its ridiculous
    Attached Thumbnails s7 edge and nougat heads up notifications-2017-02-05-08.16.58.jpg  
    KPMcClave and Mahroo Sharegh like this.
    02-05-2017 02:19 AM
  6. trucksmoveamerica#AC's Avatar
    that heads up app worked great until nougat, it doesnt work with it on the s7

    and there is no options anymore in the s7 with nougat to turn off heads up peeking you got to turn it all off or nothing, they have ruined it doing that
    Did not know that, hopefully the developer will actually update to work on nougat if possible at all.

    One of the reasons I hate updates, or I should say updates are a double edge sword, get some nice improvements, but at the price of losing other features and possible performance issues.

    Well, guess headsoff isn't an option on nougat.
    thecomicbookandme likes this.
    02-05-2017 07:05 AM
  7. trucksmoveamerica#AC's Avatar
    this is the only option for notifications, its ridiculous
    Does nougat allow you to control system notifications such as the battery full pop up, guessing no.
    02-05-2017 07:07 AM
  8. trucksmoveamerica#AC's Avatar
    that heads up app worked great until nougat, it doesnt work with it on the s7

    and there is no options anymore in the s7 with nougat to turn off heads up peeking you got to turn it all off or nothing, they have ruined it doing that
    I was looking at the headsoff description, and there is a nougat note as you see below. Have you tried that, does it work after doing that?

    02-05-2017 07:10 AM
  9. widget2k13's Avatar
    I was looking at the headsoff description, and there is a nougat note as you see below. Have you tried that, does it work after doing that?

    https://uploads.tapatalk-cdn.com/201...15d0be861c.jpg
    The nougat note does not apply to the s7 edge that I can see, that option is not available
    02-05-2017 07:22 AM
  10. anon(9408097)'s Avatar
    If you just want to tweak your text messages notifications you can do that by downloading a third party messaging app like Textra. Whatsapp and messenger let you hide preview through the app. What other messages do you want to hide?
    02-05-2017 09:22 PM
  11. widget2k13's Avatar
    whatsapp hidden preview has never worked on the s7 edge that's why i had to use heads up software in the first place, its actually whatsapp that i need to hide it for mainly. it has the feature built into it yes but it actually doesn't work
    02-06-2017 01:41 AM
  12. widget2k13's Avatar
    seems like the solution is unlocking the hidden System UI Tuner - which seems to be available for every phone but the S7.

    unless anyone knows any different ?
    02-06-2017 01:47 AM
  13. mayjas's Avatar
    Finally found the solution on S7 Edge running Android Nougat, tried and testing, its working.

    1.Follow the instructions here to install and use ADB

    How to Install and Use ADB, the Android Debug Bridge Utility

    2.Once it is installed and you have verified that it works (verification step is also given in the above page), just type the below command in the command (cmd.exe) window on the PC (phone should be connected by USB)

    adb shell settings put global heads_up_notifications_enabled 0


    Basically its connecting your phone to the PC and sending a command through the PC emulator window to your phone system and disabling the heads up notifications.

    If working for you all, lets spread the word to other forums too.

    tnx
    rgds
    Mayur
    javiertoti, Jaleks and the_new_mr like this.
    02-06-2017 03:01 AM
  14. anon(9408097)'s Avatar
    You can go into lock screen settings and select do not show content.
    02-06-2017 05:12 AM
  15. widget2k13's Avatar
    Yes on lock screen you can but not on home screen which is what I need, my phones normally on my holder in the car so I can listen to my music but every message now pops up showing everyone in my car my messages, very annoying
    02-06-2017 08:30 AM
  16. anon(9408097)'s Avatar
    You can check out whatsapp plus. It's a whatsapp client on steroids. Maybe you'll find this feature in that app. It works and looks just like the whatsapp app. But it has so many extra features too.
    02-06-2017 09:04 AM
  17. widget2k13's Avatar
    the feature is in whatsapp it just doesn't work on nougat
    02-06-2017 10:55 AM
  18. bi Teme me's Avatar
    I have the same exact issue that was not there before until the update, I guess we have to wait for Whatsapp to release a new update, I searched everywhere, and definitely I won't install a 3rd party app for that matter, it should be native and working like it was always before.
    02-07-2017 12:25 AM
  19. widget2k13's Avatar
    i just installed the latest whatsapp beta that is supposed to work on nougat but its still the same, i think its the actual phone software that's causing this and needs to be resolved by samsung
    02-07-2017 01:25 AM
  20. susan wheeler's Avatar
    i just installed the latest whatsapp beta that is supposed to work on nougat but its still the same, i think its the actual phone software that's causing this and needs to be resolved by samsung
    I agree , this heads up pop up is rubbish. I even tried live chat with samsung and they tried saying it was whatsapp problem, which is rubbish as it was working fine before the update to nougat. I have been in to developer mode and the system ui tuner isn't even there either to try to fix it. This is a definite step backwards...not happy do you think they might fix this on the next patch/update. Does anyone know how to report and get an answer?
    02-11-2017 04:56 PM
  21. lammy8's Avatar
    Why not just turn on do not disturb whilst you're in your car with people if you don't want them to see anything? Don't personally see why you're wanting to hide the content, but it seems there's no option in the settings to hide heads up content.
    02-12-2017 03:24 AM
  22. john salgado's Avatar
    finally found the solution on s7 edge running android nougat, tried and testing, its working.

    1.follow the instructions here to install and use adb

    how to install and use adb, the android debug bridge utility

    2.once it is installed and you have verified that it works (verification step is also given in the above page), just type the below command in the command (cmd.exe) window on the pc (phone should be connected by usb)

    adb shell settings put global heads_up_notifications_enabled 0


    basically its connecting your phone to the pc and sending a command through the pc emulator window to your phone system and disabling the heads up notifications.

    If working for you all, lets spread the word to other forums too.

    Tnx
    rgds
    mayur
    is this solution actually working? No heads up but the phone still vibrates when a whatsapp message is recieved?
    02-20-2017 07:43 PM
  23. didster's Avatar
    global heads_up_notifications_enabled 0 doesnt work for me. Setting set, confirmed it has stuck after a reboot with settings get global heads_up_notifications_enabled but still same pesky HU notifications.

    S7 on 3 UK.
    02-25-2017 09:49 AM
  24. htx's Avatar
    Finally found the solution on S7 Edge running Android Nougat, tried and testing, its working.
    THIS SOLUTION WORKS


    I just did it. It took me a while to actually get the SDK Manager installed, but once I ran the command and rebooted the phone, I stopped receiving all heads-up notifications. I believe changing the 0 to a 1 will enable it again if you want to do that in the future.

    I saw the update for Nougat and was kind of interested in the new features so went ahead and updated. As soon as I noticed the heads-up notifications could not be turned off, I was about to pull my hair out. I HATE heads-up notifications and don't understand why samsung/android would remove the disable heads-up option in the notification settings that was previously there! I don't want this silly, unnecessary notification to take up the top of my screen when i'm in other apps. Especially annoying if you're in a group-chat and you constantly get notified via heads-up.

    Samsung needs to fix this in a future update. I don't know how, but we need everyone to let them know this is a serious issue. The notification bar the top is such a PERFECT way of displaying notifications, like why would the remove that? I understand some people might want heads-up, but keep that as optional. Ticklr was working GREAT (could be a little better) in on the s7 edge before this update. Now for some reason it is covering important parts of the phone (like when the notification drawer is pulled down, it covers the top of the settings options).


    </End Rant>
    javiertoti and Mahroo Sharegh like this.
    03-01-2017 04:20 PM
  25. susan wheeler's Avatar
    Has anyone had a reply from samsung on this annoying bug yet? I
    03-02-2017 04:53 PM
44 12

Similar Threads

  1. Nougat Battery life
    By Wizzy in forum Samsung Galaxy S7 edge
    Replies: 10
    Last Post: 03-14-2017, 03:55 PM
  2. Replies: 11
    Last Post: 02-07-2017, 02:27 PM
  3. Replies: 4
    Last Post: 02-05-2017, 08:48 PM
  4. Replies: 1
    Last Post: 02-04-2017, 09:55 PM
  5. Replies: 0
    Last Post: 02-04-2017, 02:17 PM
LINK TO POST COPIED TO CLIPBOARD