1. Misterb's Avatar
    Very annoying. I have two separate email accounts I use inside of the Gmail app. I get notifications for one of the accounts every time. With the second account, sometimes I get notified, and sometimes I don't. I might happen to notice a 1 next to the account that has issues when I pull up the folder list on the left, and then if I go in the account it still doesn't show the email. I have to refresh the inbox and then the email comes in.

    Any ideas? This is pretty basic stuff that this phone should be able to handle.
    02-09-2017 04:57 PM
  2. SpookDroid's Avatar
    What kind of account is this? Are you sure you have the right server settings if it's not a GMail account? Also, check if your Notification settings for GMail are set to notify once per e-mail, if not, the notification will be 'lumped' and if one e-mail arrives while you have a notification, it won't re-notify you because you already have the pending notification.
    02-09-2017 05:01 PM
  3. Misterb's Avatar
    What kind of account is this? Are you sure you have the right server settings if it's not a GMail account? Also, check if your Notification settings for GMail are set to notify once per e-mail, if not, the notification will be 'lumped' and if one e-mail arrives while you have a notification, it won't re-notify you because you already have the pending notification.
    Both accounts are Gmail. I already have it set the way you said. I get this problem when when there's just one email, and it's not even downloaded yet. I have to go in and manually refresh it to get it to pull it in.
    02-09-2017 05:11 PM
  4. o4liberty's Avatar
    What launcher are you using? I have Evie launcher and my notifications are dead on no issues at all.
    02-09-2017 05:25 PM
  5. Misterb's Avatar
    What launcher are you using? I have Evie launcher and my notifications are dead on no issues at all.
    Nova, but what would that have to do with it? I'm not referring to a number count on the app icon
    02-09-2017 10:59 PM
  6. SpookDroid's Avatar
    Is your problem only with one account? Have you tried removing it and adding it back? If you go to your Account Settings, on the Google Account Sync portion for that account, do you see any errors in Sync items?
    02-10-2017 11:09 AM
  7. erasat's Avatar
    Are you on Nougat already? I'm just asking because since I moved to the Pixel with 7.01 I began having the same issue than until that time was non existent. I was switching between the Pixel XL and the S7 edge for a while and noticed that I never had the issue while on the S7, so I immediately realized that it was related to Nougat.

    Then after a couple of weeks I was added to the Nougat Beta for the S7/S7 edge and as soon as I turned it on the first time after that I began with the same issue on the s7 edge, so based on this I can assume that at least in my case it was maybe the new Doze on Nougat just keeping Gmail asleep and not allowing the usual Push Notifications, weird thing is that it wasn't all the time, but it was very frequent.

    Can't tell you now as I'm using an iPhone 7 Plus that I got for a great price and I sold my Pixel XL and haven't used the S7 edge for the past couple of weeks.
    02-10-2017 01:46 PM
  8. Misterb's Avatar
    Are you on Nougat already? I'm just asking because since I moved to the Pixel with 7.01 I began having the same issue than until that time was non existent. I was switching between the Pixel XL and the S7 edge for a while and noticed that I never had the issue while on the S7, so I immediately realized that it was related to Nougat.

    Then after a couple of weeks I was added to the Nougat Beta for the S7/S7 edge and as soon as I turned it on the first time after that I began with the same issue on the s7 edge, so based on this I can assume that at least in my case it was maybe the new Doze on Nougat just keeping Gmail asleep and not allowing the usual Push Notifications, weird thing is that it wasn't all the time, but it was very frequent.

    Can't tell you now as I'm using an iPhone 7 Plus that I got for a great price and I sold my Pixel XL and haven't used the S7 edge for the past couple of weeks.
    No, I'm on Verizon and haven't seen any updates yet
    02-10-2017 04:29 PM
  9. Misterb's Avatar
    Is your problem only with one account? Have you tried removing it and adding it back? If you go to your Account Settings, on the Google Account Sync portion for that account, do you see any errors in Sync items?
    It's just a problem with one of 3 Gmail accounts inside the Gmail app. I haven't removed the account and added back, but suppose I can as a last resort. I did go in just now and look at sync, and everything is good
    02-10-2017 04:33 PM
  10. SpookDroid's Avatar
    Try that and see if that fixes things. Sometimes sync does get wonky for some reason and that seems to help.
    02-10-2017 05:33 PM
  11. Misterb's Avatar
    Try that and see if that fixes things. Sometimes sync does get wonky for some reason and that seems to help.
    I think that fixed it, man. Thanks!
    SpookDroid likes this.
    02-15-2017 11:20 PM
  12. SpookDroid's Avatar
    Glad we could help! Not sure why, but yeah, sync sometimes gets buggy for some reason and re-forcing the account add seems to fix things.
    02-16-2017 08:21 AM
  13. Daggg8's Avatar
    ...
    05-05-2017 12:50 AM
  14. Daggg8's Avatar
    Nova, but what would that have to do with it? I'm not referring to a number count on the app icon
    Interesting! I am using Nova too and have the EXACT same problem as you (Verizon, S7 Edge). I just changed back to Google Launcher and TouchWiz launcher, sent a test email from my aol and yahoo mail accounts to my Gmail account and voila! I'm getting the notification light!

    I'll keep using the Google Launcher and/or Touchwiz for the next few days and see what happens. Give it a shot!
    05-05-2017 12:55 AM

Similar Threads

  1. Replies: 2
    Last Post: 02-11-2017, 01:22 PM
  2. Replies: 1
    Last Post: 02-10-2017, 02:30 AM
  3. No more 4K on youtube for htc 10?!?
    By jens Van Keer in forum HTC 10
    Replies: 2
    Last Post: 02-10-2017, 01:54 AM
  4. how to appear file and icons inside file?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 02-09-2017, 02:35 PM
  5. My phone asks for factory reset but it goes to that same menu
    By Luis19Russo in forum General Help and How To
    Replies: 1
    Last Post: 02-09-2017, 02:21 PM
LINK TO POST COPIED TO CLIPBOARD