1. Zendroid1's Avatar
    I have an S7 Edge/T-Mobile version on 7.0. Rather than tell you how my options are set up now, I'll just tell yo what I want. Is this possible?

    I want my phone to not light up or anything when I get an incoming call/text etc... But when wake up the screen I want it to show what phone calls I missed. Messing with the options I can only get it so it lights up my screen or does nothing and doesn't even show missed calls, but will show I have a voicemail. If someone called and didn't leave a VM I'd never know they called unless I went into the missed calls list.

    I apologize in advance because I think I have confused myself. haha I have an iPhone that I leave on DND and it never lights up my screen but shows all missed calls, vm, messages etc on lockscreen.
    02-27-2017 02:46 PM
  2. SpookDroid's Avatar
    Not sure you can do that for calls (maybe Do Not Disturb mode will work?), but for texts, you need to use an app that supports this. The Stock messaging app will always light up the screen when a text is received (and for this very reason, it is usually one of the first apps I replace on my phone). You can use 3rd party options that don't light it up like Hangouts, or apps that allow you to select which behavior you prefer, like Textra.
    02-27-2017 03:14 PM
  3. Hey I Tried's Avatar
    Setting up and enabling Do Not Disturb will prevent your screen from lighting up, but notifications will still show up on your lock screen.
    There are a bypass options and filters, if so desired.
    02-27-2017 04:44 PM
  4. Zendroid1's Avatar
    Setting up and enabling Do Not Disturb will prevent your screen from lighting up, but notifications will still show up on your lock screen.
    There are a bypass options and filters, if so desired.
    I tried various options and the missed call isn't showing up when I don't let it light up my screen.
    02-27-2017 11:57 PM
  5. Hey I Tried's Avatar
    Have you checked the phone (the app itself) to make sure the Notification permissions are correct?
    One of the permissions is actually called "hide on Lock Screen".
    Zendroid1 likes this.
    02-28-2017 12:13 AM
  6. Zendroid1's Avatar
    Have you checked the phone (the app itself) to make sure the Notification permissions are correct?
    One of the permissions is actually called "hide on Lock Screen".
    I just went into my phone app then settings and don't see a "hide on lock screen". I don't even see permissions. Am I looking in the wrong spot?
    02-28-2017 08:12 AM
  7. Hey I Tried's Avatar
    It's a good possibility that what you're looking for isn't possible with a non rooted device.
    02-28-2017 08:18 AM
  8. Zendroid1's Avatar
    It's a good possibility that what you're looking for isn't possible with a non rooted device.
    I just figured it out based on your previous post. There's no "phone" app in the list of apps in settings. But when I went to the settings app it has notification options. I had show silently unchecked. So on DND it was still lighting up my screen. I checked it and now when on DND it shows my missed calls. So confusing! But thanks.
    02-28-2017 09:48 AM
  9. Hey I Tried's Avatar
    Woops. My bad. Forgot you had to select show system apps.
    If the notifications are showing on your lock screen now, cool! Glad we got that working.
    Does the screen light up when someone calls with dnd active?
    02-28-2017 09:55 AM
  10. Zendroid1's Avatar
    Woops. My bad. Forgot you had to select show system apps.
    If the notifications are showing on your lock screen now, cool! Glad we got that working.
    Does the screen light up when someone calls with dnd active?
    Ok I spoke too soon. It does NOT light up when the call is coming in now, however now it lights up after the person hangs up and shows I have a missed call. Haha. Can't win!
    02-28-2017 10:01 AM
  11. Hey I Tried's Avatar
    Maybe try enabling Keep Screen Turned Off found in the Display and Wallpaper menu, then cover the light sensor.
    That may keep the screen off?
    02-28-2017 10:30 AM
  12. Hey I Tried's Avatar
    Before I got my s7 edge, I had an LG G3 with the smart circle case, which I loved.
    I found something similar for the S7E, and I know that with case close, dnd enabled, and the keep screen turned off enabled, it doesn't light up at all.

    Just a suggestion.

    It's called a Galaxy S7 Edge Case, G-CASE
    https://www.amazon.com/gp/aw/d/B01CJ...cUvbUpU5694162
    02-28-2017 10:39 AM
  13. Hey I Tried's Avatar
    I was playing around in my Application Manager, and found something that might work.
    Settings / Applications / Application Manager. Upper right, select More and go to Modify System Settings.
    Is this possible? (show notifs on lock screen but not light up screen)-screenshot_20170301-220625.png

    In there, select More and Show System Apps.

    Is this possible? (show notifs on lock screen but not light up screen)-screenshot_20170301-220746.png
    You can turn the phone permissions off, which will deny it from changing system settings.
    Maybe it will prevent the phone app from waking the screen?
    Or maybe it won't receive phone calls at all until re-enabled.

    Just thought I'd share.
    03-01-2017 10:12 PM

Similar Threads

  1. Galaxy Tab 4 Stuck on Samsung Splash Screen
    By AC Question in forum Samsung Galaxy Tab4 7.0
    Replies: 3
    Last Post: 03-09-2017, 02:32 PM
  2. How can I make someone stop coming up as my first option?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 02-27-2017, 11:22 PM
  3. Replies: 2
    Last Post: 02-27-2017, 05:49 PM
  4. How to reload Go Launcher widget on Android 7
    By AC Question in forum Samsung Galaxy S7 edge
    Replies: 0
    Last Post: 02-27-2017, 02:36 PM
  5. Losing network after each call with Verizon Note 4 on T-Mobile network
    By carcrafter22 in forum General Help and How To
    Replies: 0
    Last Post: 02-27-2017, 02:26 PM
LINK TO POST COPIED TO CLIPBOARD