1. Pastorhss's Avatar
    My S7 edge has Nougat. I have been trying some calendar apps and like a few - DigiCal, Today, Sol, Cal (Any.do). But they all seem to have the same problem. Any entry I make on other devices - PC, tablets, etc - will not update in the app unless I first open/refresh/update the Google Calendar app, which does so with no issues.

    Can anyone help, please?
    03-30-2017 01:19 PM
  2. underway99's Avatar
    It sounds like those apps are working as a front end for the Google calendar. If the Google calendar hasn't updated, then the other calendar app won't be able to show it.

    I would check your account settings to ensure that the calendar for that account is set to automatically update by allowing background updates. That way, the calendar database on your phone will update without having to open the Google calendar.
    Pastorhss likes this.
    03-30-2017 01:36 PM
  3. Pastorhss's Avatar
    It sounds like those apps are working as a front end for the Google calendar. If the Google calendar hasn't updated, then the other calendar app won't be able to show it.

    I would check your account settings to ensure that the calendar for that account is set to automatically update by allowing background updates. That way, the calendar database on your phone will update without having to open the Google calendar.

    Thanks so much underway99. I am not a real techy, but, from what I understand, I go to accounts, google, select the specific account, and make sure that under Sync Settings Google Calender is toggled ON. IS THIS CORRECT.?
    03-30-2017 02:10 PM
  4. underway99's Avatar
    Yes, that is correct.

    Also check that you have not turned off background data on the calendar. If background data is disabled, the calendar data won't update until you open the app. Open SETTINGS\APPLICATIONS\CALENDAR. Scroll down to and select DATA USAGE. Look at ALLOW BACKGROUND DATA USAGE. Ensure that it is set to ON.
    Pastorhss likes this.
    03-30-2017 05:27 PM
  5. Pastorhss's Avatar
    Yes, that is correct.

    Also check that you have not turned off background data on the calendar. If background data is disabled, the calendar data won't update until you open the app. Open SETTINGS\APPLICATIONS\CALENDAR. Scroll down to and select DATA USAGE. Look at ALLOW BACKGROUND DATA USAGE. Ensure that it is set to ON.
    Thanks for giving of your time underway99.

    I checked the Background Data Usage and it was On. I also verified as per your original suggestions, and everything was set to sync. So, early yesterday I decided to test a couple of the apps that I had tried previously and had sync problems. The three I tried all synced perfectly. I tested adding, deleting, and changing calendar entries on all devices (PC, laptops, Tablets, phones ... Windows 10 and Android N). All sync was perfect across platforms. So, I don't know what happened, but i'm glad it corrected itself.

    Once again, thanks. God bless you.
    03-31-2017 01:34 PM
  6. underway99's Avatar
    I'm not sure what I did, but I'm glad I could help.
    03-31-2017 02:01 PM

Similar Threads

  1. Storage problem
    By AC Question in forum Samsung Galaxy A3
    Replies: 2
    Last Post: 06-06-2017, 09:18 AM
  2. LG G6 Camera green tint banding problem
    By Alex Qa in forum LG G6
    Replies: 3
    Last Post: 03-31-2017, 12:46 AM
  3. Replies: 0
    Last Post: 03-30-2017, 08:35 AM
  4. Storage problem
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 03-30-2017, 01:23 AM
  5. Problems since update
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 03-30-2017, 01:14 AM
LINK TO POST COPIED TO CLIPBOARD