1. themagician8's Avatar
    Whenever I click on a website link in an email or especially Google Assistant, it opens Chrome, but doesn't to to the page.
    It just opens to the last page I visited.
    Please help.
    04-18-2017 10:57 AM
  2. B. Diddy's Avatar
    Is there a setting to open the links within the app (i.e., using the app's own basic browser)? For the Google app, open it, tap Menu>Settings>Accounts & Privacy, and turn on the "Open web pages in app" switch.
    04-18-2017 12:32 PM
  3. themagician8's Avatar
    I don't see anything like that in Google Assistant or the Gmail app.
    And it's been on in thr Google app, but it does the same thing. It tries to open the page in Chrome, goes there, but reverts back to the last page I browsed.
    04-18-2017 08:11 PM
  4. B. Diddy's Avatar
    Google Assistant is part of the Google app, so are you saying that when you went to the Google app's settings (as I described above), it's already set to "Open web pages in app"?

    In the Gmail app, tap Menu>Settings>General Settings, and turn on the checkbox for "Open web links in Gmail."

    This obviously won't solve the issue with Chrome, but I'm just trying to determine if it's a problem with Chrome, or with how the system is handling links in general.
    04-19-2017 09:47 AM
  5. themagician8's Avatar
    Yes. The "open web links in Gmail" setting is checked, but tries to open in Chrome, but just goes to last page browsed. And I can no longer find a setting in either Google App or Assistant thag says " open web pages in app". Google App seems to only "settings" for Google Assistant now with nothing about opening anything.
    Attached Thumbnails Links Don't Work-screenshot_20170420-113322.jpg   Links Don't Work-screenshot_20170420-113335.jpg   Links Don't Work-screenshot_20170420-113415.jpg   Links Don't Work-screenshot_20170420-113421.jpg   Links Don't Work-screenshot_20170420-113430.jpg  

    04-20-2017 10:37 AM
  6. WallaceD's Avatar
    Have you tried rebooting your phone?

    If so, have you tried force closing and disabling Chrome then re-enabling?
    04-20-2017 01:44 PM
  7. B. Diddy's Avatar
    In the Google app's menu, what do you see if you tap Accounts & Privacy (under the Search heading, not the Google Assistant heading)?

    It's also worth wiping the cache partition: https://support.t-mobile.com/docs/DOC-24999
    04-20-2017 05:20 PM
  8. themagician8's Avatar
    Ok, so I think I got it sorted out...
    I went into Gmail & Google app settings
    and UNCHECKED "open in app".
    Now it opens the links in email and Google assistant in Chrome.
    With the boxes checked... it doesn't open them in the app or in Chrome.

    Thanks for your help Diddy.
    B. Diddy and ToddL like this.
    04-23-2017 12:44 PM
  9. B. Diddy's Avatar
    Oh, my mistake -- I thought you wanted to open them within the app, and not in Chrome!
    LineKill likes this.
    04-23-2017 09:09 PM

Similar Threads

  1. Facebook push notifications not working.
    By Sathish S in forum BlackBerry Priv
    Replies: 12
    Last Post: 05-01-2017, 09:05 AM
  2. Unread badges in messages and phone not working
    By DroidRageYo in forum Samsung Galaxy S7 edge
    Replies: 4
    Last Post: 04-29-2017, 11:06 PM
  3. Replies: 1
    Last Post: 04-18-2017, 12:43 PM
  4. Replies: 1
    Last Post: 04-18-2017, 10:31 AM
  5. Replies: 1
    Last Post: 04-18-2017, 09:09 AM