1. tig5's Avatar
    Hey guys, hoping someone can help me with some problems on a refurbished S7 Edge I've just bought.

    I've done a factory reset, installed a new SIM and got the SIM running with the mobile operator.
    The main problem is that when I make and recieve calls the other person can't hear me, only very garbled staticy sounds. I've checked the microphone by making video recordings and using Facebook Video messaging and the mic doesn't seem to be the problem. I've tried removing the protective case etc, but no luck.
    Another weird issue is that the clock is running extremely slowly. I've tried setting it to manual time but after 12 hours have passed the clock on the phone has only progressed about 3 hours. Never seen anything like that before. There is a Vodafone app installed on the phone but I don't think there is a network lock as txt messages and internet seem to run ok on the new SIM (not Vodafone). The other issue is that Wifi seems to drop and reconnect a lot. I'm in New Zealand and the phone has installed OTA updates for 7.0.
    Phone is unrooted. I've done some rooting and installed custom recoveries and ROMs in the past but not on the S7. I'm not a complete noob but usually need to follow detailed instructions when customising.
    Any recommendations on the best approach to these probs? Happy to root and customise if it might help with the issues.
    Thanks in advance,

    08-04-2017 10:08 PM
  2. Alanhd's Avatar
    I've not got a specific answer but I seam to remember some people used to have a similar issue with wifi calling on.
    08-05-2017 12:36 PM
  3. B. Diddy's Avatar
    Welcome to Android Central! Remember that video recordings often use the secondary mic for audio (as do certain 3rd party communication apps). Can people hear you on a regular call if you're on speakerphone, or using a wired or Bluetooth headset?
    08-05-2017 08:43 PM
  4. tig5's Avatar
    Issue persists if I use the stock headphones (which i believe have a built in mic). Also noticed that the calls disconnect by themselves after about 10-15 seconds. I've tried using another SIM (same provider) but same results. Wifi continuing to drop in and out randomly. Improved after I disabled "BT scanning" and "Wifi Scanning" under location settings but still unreliable. My S7 Edge has no option for Wifi Calling and I've really looked everywhere for it including Phone Settings>More Settings etc. I read somewhere that it may only be available for branded (carrier) devices...
    Anyway, keen to try anything else if it might help.
    Thanks for the replies.
    08-06-2017 05:24 AM
  5. tig5's Avatar
    P.S the Wifi issue seems to be caused by the device switching wifi off. If you go to the wifi menu you can watch it in action. Also, sometimes when wifi appears disconnected the wifi button is greyed out and it says beside wifi "Turning on". Need to reboot when this happens to get Wifi to turn on again. Tried another Factory reset, no improvement.
    08-06-2017 05:28 AM
  6. B. Diddy's Avatar
    Does it happen in Safe Mode as well?
    08-06-2017 10:08 AM

Similar Threads

  1. Problem with WhatsApp
    By Dirtymike14 in forum Android Apps
    Replies: 4
    Last Post: 08-25-2017, 09:00 AM
  2. S7 Edge will not turn off without password help!!!
    By jackinthebox24 in forum Samsung Galaxy S7 edge
    Replies: 2
    Last Post: 08-06-2017, 11:54 AM
  3. Replies: 1
    Last Post: 08-04-2017, 09:57 PM
  4. Samsung galaxy s7 1440p resolution lag
    By deadpixel188 in forum Samsung Galaxy S7
    Replies: 0
    Last Post: 08-04-2017, 07:14 PM
  5. How do I fine old text messages on my galaxy S7 phone?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 08-04-2017, 10:58 AM