1. robotica34's Avatar
    I am tired of going through a million forum threads on all websites not being able to find my answer, and none answering mine. Is my problem so severe?

    I bought a used S7 Edge. It was KNOX tripped, and since I didn't know what that was at the time, I tried flashing to stock ROM through Smart Switch's download mode. It soft bricked my phone, and any other attempts at flashing stock firmware
    (not from any other model, I'm not that stupid) results in the same unbootable state. It only gets to recovery mode. How can I fix that?

    I was told by some phone repair guys that my phone IMEI has "disappeared" and that it's preventing the phone from booting, and they don't know how to fix it. I call bull on that one, because I've seen phones booting without IMEI. Please provide any help you can.

    Thank you.
    08-10-2017 01:27 PM
  2. Razier's Avatar
    Ok so what you would do (I assume you have a new phone by now) is to take your battery out and hold the power key for about 30 sec. Then charge it for whatever amount if time seems good for yoyr phone (btry % might pop up too so that will help) onece yoyr phone is charged sufficiently, boot into download mode, and do a full wipe of the system. Once that is complete, try flashing the firmware again. If that fails repeat the process but this time wait to flash... idk why this works but my phone did the same thing and i was able to fix it after leaving it for a while. If THAT fails, try doing everything above but instead, flashing the stock firmware that you had for your phone. Be sure you leave it in a place that the cord wont be disturbed for like 30 mins. After a while ODIN should say pass in a green box and everything should be good. Dont worry about booting it for the first time, it is always slow, this is because the newly installed firmware is setting everything up on your device. but, if all else fails, sometimes, you break a phone in such a way that it cannot return from what you did to it... i really hope i helped you figure this out.
    thecomicbookandme likes this.
    12-01-2017 05:58 AM
  3. robotica34's Avatar
    Hey, maybe I forgot to archive the post or whatever because I solved my problem by just taking it to a repair shop.
    12-02-2017 12:35 PM

Similar Threads

  1. It's alive again! (De-brick of my Note 10.1 N8013)
    By giffer in forum Samsung Galaxy Note 10.1
    Replies: 2
    Last Post: 08-09-2017, 09:13 AM
  2. Oh my...I need help, have I bricked my new phone?
    By Anomaly427 in forum Samsung Galaxy S7
    Replies: 4
    Last Post: 08-06-2017, 10:28 PM
  3. Hard brick app erased my internal memory
    By Olvers974 in forum Samsung Galaxy S8 & S8+
    Replies: 1
    Last Post: 08-06-2017, 06:30 PM
  4. On an S8/S8+ how can i permanently ignore a wifi connection point?
    By AC Question in forum Samsung Galaxy S8 & S8+
    Replies: 2
    Last Post: 08-02-2017, 08:37 AM