1. arows's Avatar
    Hi, I have a s7 edge, unlocked, purchased in Canada, and always worked fine all over the world. I recently moved to Hong Kong and I used a prepaid China Mobile sim card for a couple weeks, the internet speed was great. Now I signed a contract with CSL (other local carrier) and while I do connect to even LTE+, internet speed sucks (youtube defaults to 240p and still lags). What's odd is that I tried my sim card with a s7 edge in their store and it worked great, so i really cant understand what is going on since phone, sim card and network seem ok. There seem to be an issue specific to my phone with the CSL network, but I can't figure out what it may be. Any ideas?
    09-20-2017 08:25 PM
  2. B. Diddy's Avatar
    Welcome to Android Central! What's the exact model number of your phone? And just to be sure, you're seeing "LTE+" and not "HSPA+", right?
    09-21-2017 11:02 AM
  3. arows's Avatar
    Hi B. Diddy! It's a SM-G935W8 and I always see LTE or LTE+, never had HSPA+
    09-22-2017 08:58 AM
  4. B. Diddy's Avatar
    Ok, that phone supports China Mobile's bands. Have you already checked to make sure the APN settings are correct? https://www.apnsettings.org/china/ch...alaxy-beijing/

    You mentioned slow YouTube streaming -- is it only with streaming, or is it also slow with general browsing or other web activity?
    09-22-2017 10:38 AM

Similar Threads

  1. Unable to type French accented characters in Oreo
    By Laurent Duperval in forum Android 8.0 Oreo
    Replies: 5
    Last Post: 09-22-2017, 07:14 AM
  2. Replies: 3
    Last Post: 09-20-2017, 06:51 PM
  3. Replies: 1
    Last Post: 09-20-2017, 06:00 PM
  4. bluetooth connection noise
    By dsx968 in forum Samsung Galaxy S8 & S8+
    Replies: 0
    Last Post: 09-20-2017, 05:29 PM
  5. View 360 Photos from Gallery
    By Johnny Cakes1 in forum LG V10
    Replies: 2
    Last Post: 09-20-2017, 05:03 PM