1. ani_saha007's Avatar
    I am using s7 edge for over a year now. Suddenly for last week the battery drain was too fast. So i decided to fully drain the battery but on 1% the phone kept running for long. Now whenever i unplug the charger the phone instantly goes to 1% and then runs for a long time.
    Attached Thumbnails S7 edge battery drain problem-screenshot_20171114-113039.jpg  
    11-13-2017 11:59 PM
  2. Dngrsone's Avatar
    Try restarting your phones while it's plugged into a charger, see if that makes a difference.
    11-14-2017 12:11 AM
  3. ani_saha007's Avatar
    Try restarting your phones while it's plugged into a charger, see if that makes a difference.
    Thank you. It showed 92% but then directly went down to 72%. After that its normal now.
    11-14-2017 01:20 AM
  4. ani_saha007's Avatar
    Try restarting your phones while it's plugged into a charger, see if that makes a difference.
    11-14-2017 01:20 AM

Similar Threads

  1. These 'Pixel 2 problem!' stories need to stop
    By LeoRex in forum Google Pixel 2 & Pixel 2 XL
    Replies: 105
    Last Post: 11-26-2017, 08:07 AM
  2. Battery stops charging around 90%.
    By Alexthenewguy in forum Samsung Galaxy Note 8
    Replies: 13
    Last Post: 11-17-2017, 09:01 AM
  3. Extended battery - wrong % indicator
    By Tran Trung Le in forum LG V20
    Replies: 5
    Last Post: 11-15-2017, 06:03 PM
  4. Inaccurate battery percentage when charging
    By nav525 in forum Google Pixel 2 & Pixel 2 XL
    Replies: 5
    Last Post: 11-14-2017, 10:11 PM
  5. Problem with Digital Offers
    By JimmieCD in forum Ask a Question
    Replies: 0
    Last Post: 11-13-2017, 05:24 PM
LINK TO POST COPIED TO CLIPBOARD