1. ungairis's Avatar
    Hi everyone,

    I've recently got a S7 edge. I did factory reset. I flashed the newest firmware with odin so the device should be okay. I got the S7 from my brother and he had no wifi issue with it. The apps didn't work properly with wifi and disabled cellular data. I installed the Speedtest app by Ookla and I learnt what's the problem with my apps. I have simply no upload speed on wifi. I have an older Galaxy S5 which is just working fine. There is healthy upload speed with it. So this is not a router related problem. Any idea? Thanks in advance!
    03-23-2018 01:15 PM
  2. SpookDroid's Avatar
    Since you flashed software via ODIN you can't guarantee that the phone is 'OK'. I suggest to try factory resetting it (if still possible, haven't flashed in a while so not sure if doing so wipes the recovery partition) and testing WiFi out. If that still fails, check in different networks. Might be a 'problem' with your router (some routers needed a patch installed to play nice with some Samsung phones, or some units would have issues with WiFi in certain channels).
    03-23-2018 01:28 PM
  3. ungairis's Avatar
    Since you flashed software via ODIN you can't guarantee that the phone is 'OK'. I suggest to try factory resetting it (if still possible, haven't flashed in a while so not sure if doing so wipes the recovery partition) and testing WiFi out. If that still fails, check in different networks. Might be a 'problem' with your router (some routers needed a patch installed to play nice with some Samsung phones, or some units would have issues with WiFi in certain channels).
    If this was a wifi channel problem the download speed would be affected too, wouldn't it? I did the odin flash after a few factory reset, trying a different router and even a hard reset. Nothing helped.
    03-23-2018 01:40 PM
  4. SpookDroid's Avatar
    Not necessarily. Channels still have two 'bands' for upload and download. But if you've already tried a different router then the issue seems to be with your phone. I'd still suggest a factory reset and NOT flashing anything with ODIN (again, not sure that's possible). Run the phone with the factory software, untouched. If it fails then, most likely it's a chipset issue. I'd try running in Safe Mode just in case and rule out 3rd party apps causing an issue (and turn off BT...)
    03-23-2018 02:58 PM
  5. ungairis's Avatar
    Not necessarily. Channels still have two 'bands' for upload and download. But if you've already tried a different router then the issue seems to be with your phone. I'd still suggest a factory reset and NOT flashing anything with ODIN (again, not sure that's possible). Run the phone with the factory software, untouched. If it fails then, most likely it's a chipset issue. I'd try running in Safe Mode just in case and rule out 3rd party apps causing an issue (and turn off BT...)
    There is a new addition to the issue. I found a story with a similar issue on the net. I subscribed to a NordVPN trial. And...voila...I have upload speed on wifi. So I asked my internet provider to enabling the bridge mode (there is no such option in their current firmware) in their crappy technicolor 7200 modem. I will test out my old linksys wrt 54 gl and I if it worked without vpn, I would buy a decent router. Interesting that my mother's router can produce the same thing. I'm waiting for their answer. 48 hours...and they will be examine my complain.
    03-24-2018 07:18 AM

Similar Threads

  1. Galaxy S8 Gmail icon shows excess emails
    By Android Central Question in forum Ask a Question
    Replies: 1
    Last Post: 03-25-2018, 06:38 PM
  2. How to remove "sent by samsung mobile" on samsung galaxy s 7
    By Twigster in forum Samsung Galaxy S7
    Replies: 1
    Last Post: 03-23-2018, 11:50 AM
  3. Some Galaxy S9 owners have unresponsive touchscreens.
    By VW Maverick in forum Samsung Galaxy S9 & S9+
    Replies: 2
    Last Post: 03-23-2018, 11:07 AM
  4. Galaxy S8+ themes
    By JC8865 in forum The Android Central Lounge
    Replies: 0
    Last Post: 03-23-2018, 11:00 AM
  5. why did my galaxy note 4 fail to root?
    By Android Central Question in forum Samsung Galaxy Note 4
    Replies: 0
    Last Post: 03-23-2018, 10:50 AM
LINK TO POST COPIED TO CLIPBOARD