1. Android Central Question's Avatar
    Hi all, I'm after some help.....I have a galaxy s7 edge which was stuck in a loop. I managed to do a factory reset however, this did not solve the issue. Since then, I tried flashing using odin which showed complete but the phone has not switched back on. I've tried charging, soft reset and still nothing. Have I bricked this phone completely or can it still be saved?
    Many thanks
    10-03-2018 05:38 PM
  2. B. Diddy's Avatar
    Welcome to Android Central! Have you also tried pressing and holding Power for good 20 seconds or so?
    10-03-2018 07:09 PM

Similar Threads

  1. Why does my bluetooth audio disconnect when switching wifi networks?
    By Android Central Question in forum Samsung Galaxy S7
    Replies: 17
    Last Post: 10-21-2018, 01:42 PM
  2. i deleted my os
    By Android Central Question in forum Samsung Galaxy Tab S 10.5
    Replies: 2
    Last Post: 10-08-2018, 05:29 AM
  3. Replies: 39
    Last Post: 10-04-2018, 08:01 PM
  4. Replies: 10
    Last Post: 10-03-2018, 06:47 PM
  5. My google backup is deleted
    By Android Central Question in forum Ask a Question
    Replies: 1
    Last Post: 10-03-2018, 06:01 PM
LINK TO POST COPIED TO CLIPBOARD