08-25-2017 06:22 PM
49 12
  1. dmoss84's Avatar
    I am having this issue as well. Tried all fixes here except the above wifi transfer app.

    Would be great to get this issue some exposure.
    07-06-2016 02:26 AM
  2. DawnMSam's Avatar
    Thank you!!! I have been trying forever to figure this out and you are the first person that knew how to fix this.

    I sincerely will love you forever.
    07-06-2016 08:04 PM
  3. Airhead Bit's Avatar
    Out of three cables I only found one that would work for file transfer, another wouldn't even beebop when plugged in but worked with the Charger, the last one would beebop but show an empty (No Card or Phone) device.
    At any rate, every time the transfer cable (as it is now labeled) is plugged into my Galaxy Note Edge with Marshmallow I must switch from Charging to File Transfer in order to see Card and Phone space.
    Thanks Verizon, for yet another fine mess you've made, no wonder no one can reach support.
    07-17-2016 10:22 PM
  4. Rhedtodes's Avatar
    Downloading files (music, photos or Word) from your samsung S6 or 7 to a computer.
    I was having the same problem to transfer files from my Samsung, so I went to customer service and learned how. Here it is, hope it helps you.
    1. Connect phone to computer with a USB
    2. Swipe down from top left corner and click on ´connected as a video device´
    3. Choose either ´transfering files´or transfering images´ and your phone will return to home screen. You won´t touch the phone after this, just the computer.
    4. Now go to ´my computer´ and you will see your samsung on the side menu and on the active page.
    5. Double click Samsung and ´phone will appear on the active page´.
    6. Double click ´phone´ and your files will appear. Click one and your files on the phone will appear. DCIM for your photos,( Camera or screenshot will appear), your music and other files will also show. Open the files you wish to copy to your computer with the left click and drag or copy to the computer file you want to copy them to. If you want to move them to your computer while deleting them on the phone, use the right click, move them to the file and it will ask you if you want to copy or move, click move. And that’s it, I hope this has been helpful.
    07-19-2016 01:46 PM
  5. drdanj's Avatar
    Not one of these things works. Not one. Developer Options does not appear on my new S7, it was there on the old one. I can't find it hidden anywhere. It was there on my S6. No search will find it, not hidden anywhere. I install the SmartSwitch app on my computer and it puts me in a loop, tells me to uninstall the old version and that's all. I'm using the Samsung cable. On my old phone I had to go through the routine of telling it to switch to transfer mode, a hassle but okay, it would work. The Pull Down menu doesn't have USB charging. Try to install SmartSwitch Modbile on the phone, it says it is there, no it is not. Here, nothing. Zip.
    07-24-2016 10:55 AM
  6. lbsrfr31's Avatar
    Yep, that worked. Swapped out the usb cable I had been using for another one(likely the one that came with phone) and that did the trick.
    07-24-2016 05:10 PM
  7. Starla Burt's Avatar
    To the one that responded saying to use a higher quality USB cable... THAT WORKED!

    THANK YOU!!!!
    07-25-2016 09:47 AM
  8. OmahaBob's Avatar
    My scenario is even more weird than those described here so far. I have a brand new (3 days) Galaxy S7. It's a Verizon phone but I got it directly from a Samsung wholesaler because it was cheaper that way. I have a good cable and I have the latest drivers from Samsung. I'm able to access the "Use USB for" connection options by pulling down the menu from the Status Bar at the top of the screen, but MTP transfer isn't one of my options. My choices are Charging, File Transfer, Photo Transfer, Software installation and MIDI.

    For those of you who haven't been able to access the needed developer functions, you have to tap on "Build number" several times in a row in the "About phone" menu before your phone 'promotes' you to developer status. You'll see a little pop-up message informing you of that status, and everything you need in "Developer options" should be available to you. But despite having "USB debugging" turned on and "USB configuration" set to "MTP", I'm only given the "File transfer" option in the "Use USB for" options, and my phone never appears in Windows Explorer on my computer. I do get the new device connection sound in Windows, but the phone never appears. And here's where it starts to get really weird.

    If I use the "Photo Transfer" option I can transfer files. I can transfer any files I want, but the only files I'll be able to see in Windows are image files. For instance, I have several user manuals in pdf format that I like to carry on my phone. In Windows Explorer on my PC, I can drag and drop those pdf files into a "Manuals" folder on my phone and they will copy there. But if I then click on that folder in Windows, the folder will display as completely empty. But if I use my phone to navigate to that same folder all the files will be there. It won't show video files in Windows either. The phone will allow non-image files to be copied from Windows, or at least all I've tried so far, but it won't allow them to be viewed from Windows. I've been a computer systems engineer for a long time, but this ranks up there with some of the most weird problems I've seen. I'm still investigating, since I just discovered this issue today, so I'll report back if I discover more.
    07-27-2016 03:26 PM
  9. OmahaBob's Avatar
    Okay. Third re-install of the USB drivers on my computer finally fixed my problem. But you have to wait-wait-wait while it tries endlessly to search Windows Update for drivers. Not sure why it does that since I downloaded and installed the latest drivers today, but I won't argue with success. Also had an issue with the phone for a while where the USB configuration simply refused to set to MTP. I could open the menu and select MTP, but the configuration remained set to Charging. Have no idea why it did that, nor do I know why it suddenly stopped doing it and started working again. But again, I won't argue with success. Drivers for my phone were at Samsung Galaxy S7, 32GB, (Verizon), Gold Platinum. Check your model number, and if it isn't the SM-G930V, enter your model number in the search block at the top of the page to make sure you get the correct driver for your phone.
    07-27-2016 04:28 PM
  10. Daphne Danana's Avatar
    Tried some of the methods mentioned but still didn't work..... Even tried Samsung Smart Switch but it didn't even sense my device being connected
    I'm not sure if it is my cable's problem? Because the "USB for transfer" did appear but it keeps disappearing. When i tried to form the cable in a certain position so it appears again but it disappears again before I could even tap on it.
    Many websites said to use a good cable and I'm using the one that came with my S7, I don't get why it's still not working, any ideas what I should do?
    09-03-2016 10:43 PM
  11. Jay Sacks's Avatar
    Developer Options can be enabled on the Note 7 by opening settings, go to about phone, find build number and press a couple of times. A prompt will come up telling you 4 more presses and you will activate developer options.
    Press back and you will find a new category labeled Developer Options. You can turn on and off with the switch upper right hand side.
    Sorry, see someone has already posted instructions.
    09-03-2016 11:18 PM
  12. steinweiner's Avatar
    My Galaxy S7 does not show any of those promps, nor does my computer.. I have downloaded the smart switch app from the Samsung site, my pc still only sees the phone, but cannot access files (i.e.: no music files, photos, nothing..just the Galaxy phone. Beyond fustrating
    09-10-2016 02:00 PM
  13. Madaoji's Avatar
    It gave several options under "Use USB for: I switched it to Transferring images and it installed a new driver. This made it click through folders a little quicker, but It didn't help me git photos off my phone. It can see the drive and knows they are pictures, but can't open them. I didn't have this trouble at first. Only after installing updates to my phone. It keeps trying to load the thumbnails indefinitely.
    09-13-2016 11:47 PM
  14. kashakesh's Avatar
    so simple, yet so frustrating... thanks for this!
    09-19-2016 04:37 PM
  15. pulaki's Avatar
    THANKS RUSSEL!!! Totally the right answer and it makes sense. I am most appreciative. Cynthia-
    09-30-2016 12:13 PM
  16. angelcalled's Avatar
    I just fixed this tonight by going into the registry and removing any reference to Verizon. Before I connected my phone I rebooted and it worked perfectly. It detected my phone and I was able to choose the option to transfer files.
    11-06-2016 06:12 PM
  17. Mahaloboo's Avatar
    Its the cable. A Galaxy S7 can detect the type of cable and will only charge on lower quality cables, not allowing file transfers.

    Try a different (better) usb cable.
    Is there a way to make this the first post in the thread?

    Thanks Another Mike, as soon as a pulled out an old charger cable it worked fine after failing trying everything else
    11-25-2016 11:47 AM
  18. IdahoRoadapple's Avatar
    That fixed my S7 issue, too. Thanks!
    12-08-2016 02:25 PM
  19. JimRaginCajunScot's Avatar
    Literally the above post does not help. Can you please explain how to do that? I see no such option anywhere on my phone.
    Stuck Limo
    Someone tried to help me - they have an S5 and wouldnt work - not the same as an S7!!
    Couldn't find the USB Icon (looks kind of like Neptune's spear - w/unequal blades!
    Follow below link to cellguide.com till your USB Icon shows up as you get in to developer - real pain - or you come to 'factory reset' BS - DON'T.
    Trying to find the next step I took. As soon as I was able to set the USB in developer from standard to Media Transfer 'MTP something' it started tfrg pics. 1000s in a matter of minutes and only 1 error - which was nothing.
    Email me if it doesn't work - ragincajunscot@gmail.com
    Good Luck!

    USB connection not working on Samsung Galaxy S7
    12-09-2016 08:07 AM
  20. Sea Wolf's Avatar
    Same problem here. You can not select an option to use USB for file transfer if that option is not available. That is the issue here. Plug in the USB and all I get is the popup saying that it is charging. NO possibility of making another choice because it does not exist. Charging only. This was with the cable that came with the phone. GO AND BUY A BETTER CABLE!!! I went and bought a Belkin $29 cable that was a higher grade and for file transfers. Plugged it in and IMMEDIATELY a window popped up asking what I wanted to do with the USB connection. Problem fixed.
    12-09-2016 04:17 PM
  21. Johneeo's Avatar
    I have tried everything suggested and still cannot get this damn phone to access my laptop.

    This is unbelievable. You should just plug the damn phone into the computer like any USB device and it should work.
    01-03-2017 10:44 AM
  22. thenortonsetup's Avatar
    Have you tried the Samsung Kies software or Samsung PC Studio software? They should be compatible with your phone, and can be found on the Samsung support site.

    Samsung Kies Download
    01-12-2017 12:25 AM
  23. leper65's Avatar
    Its the cable. A Galaxy S7 can detect the type of cable and will only charge on lower quality cables, not allowing file transfers.

    Try a different (better) usb cable.
    This worked for me, different cable worked like magic! Thanks!
    04-21-2017 10:23 PM
  24. Amber Williams2's Avatar
    Its the cable. A Galaxy S7 can detect the type of cable and will only charge on lower quality cables, not allowing file transfers.

    Try a different (better) usb cable.
    After all of the suggestions on here, THIS simple one worked. THANK YOU!!!
    08-25-2017 06:22 PM
49 12

Similar Threads

  1. How to completely REMOVE any other user or guest access
    By LReno in forum Samsung Galaxy Tab S2
    Replies: 10
    Last Post: 06-01-2017, 03:20 PM
  2. Can I use a normal charger with s7 edge?
    By Andyvalver in forum Samsung Galaxy S7 edge
    Replies: 14
    Last Post: 04-20-2016, 04:46 AM
  3. Received my ATT S7 Edge with battery dead out of the box
    By rong21 in forum Samsung Galaxy S7 edge
    Replies: 7
    Last Post: 03-14-2016, 05:41 PM
  4. Why won't the s7 edge download any apps?
    By AC Question in forum Ask a Question
    Replies: 5
    Last Post: 03-13-2016, 09:25 AM
  5. Replies: 1
    Last Post: 03-12-2016, 12:49 PM