08-25-2017 06:22 PM
49 12
tools
  1. stuck limo's Avatar
    Just got the 200 gb Sandisk card, installed it, downloaded all Samsung drivers (plus ADB server) and the computer/phone will not recognize at all. I'm using the stock cable, after market cable, enabling USB debugging, etc. Nothing at all happens. I formatted the SD card too within the phone, and it appears to be mounted.

    The only thing that happens is the little BLEEP BLOOP sound and then the phone charges via USB.

    Any ideas?
    03-12-2016 12:53 PM
  2. JHStewart1023's Avatar
    You have to manually make it the whatever driver thing for the comouter. You have to slide the screen down and you can change what you want to use the computer for.. Otherwise it thinks you just want to charge your phone

    Posted via the Android Central App
    03-12-2016 12:56 PM
  3. stuck limo's Avatar
    Literally the above post does not help. Can you please explain how to do that? I see no such option anywhere on my phone.
    03-12-2016 01:08 PM
  4. JHStewart1023's Avatar
    It's hard to explain I noticed it when I tried to link my phone to my compter... Here this is sorta what I'm trying to explain

    Posted via the Android Central App
    Attached Thumbnails S7 (Verizon) Will Not Connect to PC-3802.jpg  
    03-12-2016 01:18 PM
  5. russel5150's Avatar
    By default when you plug the s7 in it seems to be a charger, scroll down notification and hit the battery charging, it gives the option of running the installer (which you could do the first time) or using as media device. When you select media or whatever its called give it a second and the pop up should appear on the pc screen that says open files to view folders.

    Seems like phones used to remember what you used last time, but the s7 and my note5 now make me change it to media device or whatever everytime i want to move pics or videos or music around.

    Hope this helps

    Sent with my white Note5 with nonremovable back and no SDcard!
    Travis Man and pulaki like this.
    03-12-2016 08:49 PM
  6. Travis Man's Avatar
    I just got an S7 a week ago, and it's been driving me crazy to attach it to my laptop as an outboard drive. I was about to go insane when all of a sudden the 'Use USB for' window popped up for me. That was good except I didn't know how I had gotten that to show up. Yes, you are right, that when you plug the S7 into the laptop USB port, this window is associated with the 'Charging' notification (it was still difficult for me to find because it was mostly hidden behind the 'Charging' notification, but the 'Use USB for' was definitely there). Interesting development w/ this S7 phone. Thx.
    IdahoRoadapple likes this.
    03-19-2016 09:49 AM
  7. 20blks's Avatar
    You need the drivers for the phone. Download smart switch from the Samsung website.

    Posted via the Android Central App
    03-19-2016 12:17 PM
  8. Jareck44's Avatar
    Thank you, it helped me!
    04-07-2016 09:51 PM
  9. MisterEd51's Avatar
    You need the drivers for the phone. Download smart switch from the Samsung website.
    Posted via the Android Central App
    With the S7 connected to my PC the USB drivers started downloading on my PC after I installed the Samsung SideSync program. You can use SideSync to transfer files but find that awkward. Instead I use the drive that pops up whenever the S7 is connected with the USB cable. The drive for me is called "SAMSUNG-SM-G930A". It contains a folder called Phone. There also is a folder called Card if you have a microSD card.
    04-07-2016 10:25 PM
  10. monicakm's Avatar
    I'm glad I saw/read this. I've only had my phone 8 days and haven't connected it to my computer yet. I've been using BT to transfer a few photos. It would have taken a few tries to have noticed that notification about what to do with the connection. Drivers are downloading right now
    04-07-2016 10:55 PM
  11. stuck limo's Avatar
    Still having MAJOR issues when I connect. Samsung Smart Switch didn't help --- it keeps telling me my USB connection is unsupported.

    Then, when I look at my phone or SD card when normally plugged into the PC, I get a literal blank screen "This Device is Empty" message or I get a bunch of hard drive icons that cannot be clicked/opened with no titles.
    04-11-2016 08:31 AM
  12. sushiguy732's Avatar
    I had the same issue and here's how I resolved it.

    Yes I read so I know you already have the drivers installed so I won't insult you by telling you to install the drivers. :-)

    Go to Settings and in the search box above type in "USB Configuration"
    It will pop up a menu and just choose MTP and that should solve the issue.
    04-11-2016 09:20 AM
  13. NewS7User's Avatar
    For really new people:

    Plug in your USB to the GS7 and the PC (expect to hear a bleep bloop and see the charging icon on the GS7)
    Attachment 224191
    On the GS7, click the line that says "Connected for Charging"
    It pops open this screen:
    S7 (Verizon) Will Not Connect to PC-shot1a.png
    Click the that says "Transferring Media Files" (or other choice)
    Note the following icon on the PC's Taskbar:
    S7 (Verizon) Will Not Connect to PC-shot2.png
    If you hover the mouse, it will show:
    S7 (Verizon) Will Not Connect to PC-shot4.png
    If you click the icon on the PC Taskbar, you will see the following notification (if first install)
    S7 (Verizon) Will Not Connect to PC-shot3.png
    When it completes installation, you should see this screen:
    S7 (Verizon) Will Not Connect to PC-shot5.png

    Then you can use it as normal external memory device.
    04-11-2016 11:09 AM
  14. Seth Slayton's Avatar
    I am having a similar issue. I have a Galaxy S7 (Sprint) running the Google Now launcher (not sure if that makes any difference). When I plug mine into my PC it charges fine. I also see the charging notification in the notification area. However, tapping on it doesn't do anything. I am not able to get the USB window to show at all and searching through the settings turns up nothing either. I am new to Android having switched over from a Windows Phone so I am unused to this OS. Any suggestions on what I may be missing?
    04-22-2016 12:43 PM
  15. GoodLookin's Avatar
    that works , thanks
    04-25-2016 10:13 AM
  16. 49er_PhD's Avatar
    I had the same issue and here's how I resolved it.

    Yes I read so I know you already have the drivers installed so I won't insult you by telling you to install the drivers. :-)

    Go to Settings and in the search box above type in "USB Configuration"
    It will pop up a menu and just choose MTP and that should solve the issue.
    Nope. Nothing found when I do this.
    05-07-2016 09:54 PM
  17. 49er_PhD's Avatar
    For really new people:

    Plug in your USB to the GS7 and the PC (expect to hear a bleep bloop and see the charging icon on the GS7)
    Attachment 224191
    On the GS7, click the line that says "Connected for Charging"
    It pops open this screen:
    Click image for larger version. 

Name:	Shot1a.png 
Views:	285 
Size:	94.4 KB 
ID:	224193
    Click the that says "Transferring Media Files" (or other choice)
    Note the following icon on the PC's Taskbar:
    Click image for larger version. 

Name:	shot2.png 
Views:	282 
Size:	28.0 KB 
ID:	224195
    If you hover the mouse, it will show:
    Click image for larger version. 

Name:	Shot4.png 
Views:	282 
Size:	8.3 KB 
ID:	224197
    If you click the icon on the PC Taskbar, you will see the following notification (if first install)
    Click image for larger version. 

Name:	Shot3.png 
Views:	283 
Size:	226.3 KB 
ID:	224199
    When it completes installation, you should see this screen:
    Click image for larger version. 

Name:	Shot5.png 
Views:	283 
Size:	380.4 KB 
ID:	224200

    Then you can use it as normal external memory device.
    None of this worked. I don't hear any sounds and I don't see any of the options you mentioned including the connected for charging.
    05-07-2016 10:00 PM
  18. 49er_PhD's Avatar
    Ok. Here's the fix that worked for me with Verizon: Go to settings, enter the search term 'Developer options,' after they show up, scroll down and turn ON 'USB debugging' then scroll down more and click on USB configuration, there you will FINALLY be able to see the MTP transfer option that you can't see anywhere else, thanks apparently to Verizon. Cheers.

    PS - Keep this handy because apparently it resets to 'charging only' when you power off or maybe it was safe mode, but the issue is that you may have to reset it this way more than once.
    05-07-2016 11:14 PM
  19. F105PLT's Avatar
    That fixed the problem for me. Thank you.
    05-21-2016 01:54 PM
  20. Juliann826's Avatar
    I've tried everything listed and nothing works. It says USB debugging is on and it's in MTP mode under developer options but still I plug it in to the computer and nothing. I tried plugging in a hard drive to test the computer too and it's working just fine. This is beyond frustrating!
    06-21-2016 11:44 AM
  21. Anthonysmith92's Avatar
    I had the same issue and here's how I resolved it.

    Yes I read so I know you already have the drivers installed so I won't insult you by telling you to install the drivers. :-)

    Go to Settings and in the search box above type in "USB Configuration"
    It will pop up a menu and just choose MTP and that should solve the issue.
    When I try to change my usb configuration to MTP, it still says charging. I can't get it to change. Plus my phone stopped fast charging. No matter what cable I use. Not sure if the problems are related. But getting pretty frustrated
    06-25-2016 05:02 PM
  22. tengtengvn's Avatar
    I've tried everything listed and nothing works. It says USB debugging is on and it's in MTP mode under developer options but still I plug it in to the computer and nothing. I tried plugging in a hard drive to test the computer too and it's working just fine. This is beyond frustrating!
    I have the same problem with Windows 10. Can't get adb to work at all.
    06-26-2016 02:11 AM
  23. BillPhillips's Avatar
    Hello folks,

    I won't offer a solution to a few of you who have this connection problem to the PC because there may be more than one solution, but I can offer you a story about this problem and the happy ending it had for me. I was just as frustrated as many of you when I plugged my new S7 Edge into my PC hoping to flawlessly transfer photos, music, documents, and more from the PC to my Edge 128 GB SD card. I hit the same "dead end" most of you mention. For several days, I tried to find solutions, even looking on this forum, but couldn't find this discussion. It didn't occur to me to include "Verizon" in the search.

    So, I went back to Best Buy where I got the phone. The first guy I talked to started doing all kinds of complicated "fix it" searches. I thought, "Hey, wait a minute, this is the highest rated phone on the market and one of the most expensive. This phone should read my mind, and anticipate any problem, and pop up a solution on the spot. I should not have to waste my time problem solving here." The Best Buy tech guy was sweating it out looking for a solution.

    Then "Matt" walked over from phone sales. He said "Oh, it's a Verizon phone, right?" In two clicks he solved it, and my laptop directory immediately displayed all the files on the S7 Edge both on the device and the SD card. Matt had used the same solution mentioned above by JHStewart, Russell, New S7 User, and 49er.
    1) Pull down the notifications from the top of the phone screen
    2) Select USB charging
    3) Switch to "file transfer"

    So, basically, it's a Verizon mess up. Why would they think you would plug your phone into a PC to charge it???? Wish I could send Verizon a bill at my hourly rate for the work time I missed fixing this.

    Best regards,
    Bill Phillips
    Durham, North Carolina
    11B1P likes this.
    06-27-2016 05:06 AM
  24. Another Mike's Avatar
    Its the cable. A Galaxy S7 can detect the type of cable and will only charge on lower quality cables, not allowing file transfers.

    Try a different (better) usb cable.
    07-05-2016 07:43 AM
  25. Scandal7876's Avatar
    Well, after trying for countless hours to connect with every suggestion on this thread, not to mention countless hours with Samsung Tech Support (whom appear to be useless) and being told that my phone wasn't compatible with computers. Sigh. I found a solution that worked like a charm. It's a free app (and trust me - I have NOTHING to do with promoting this app - just felt lucky to find it) it's called Software Data Cable. Once you open it on your phone, it shows your network, then says "connect now". It connects and shows a "scannable" area for a barcode. Then you go to Software Data Cable in your PC browser and you scan the code from the computer screen. Like magic.... you're connected. It took about 5 minutes for the initial setup and FINALLY I can move my pictures from my phone to my computer easily! Cable/shmable... this is easier!
    07-05-2016 10:42 AM
49 12

Similar Threads

  1. How to completely REMOVE any other user or guest access
    By LReno in forum Samsung Galaxy Tab S2
    Replies: 10
    Last Post: 06-01-2017, 03:20 PM
  2. Can I use a normal charger with s7 edge?
    By Andyvalver in forum Samsung Galaxy S7 edge
    Replies: 14
    Last Post: 04-20-2016, 04:46 AM
  3. Received my ATT S7 Edge with battery dead out of the box
    By rong21 in forum Samsung Galaxy S7 edge
    Replies: 7
    Last Post: 03-14-2016, 05:41 PM
  4. Why won't the s7 edge download any apps?
    By AC Question in forum Ask a Question
    Replies: 5
    Last Post: 03-13-2016, 09:25 AM
  5. Replies: 1
    Last Post: 03-12-2016, 12:49 PM
LINK TO POST COPIED TO CLIPBOARD