03-31-2018 04:08 PM
54 123
tools
  1. Almeuit's Avatar
    It's marshmellow.. Its a BIG BIG PROBLEM..
    I would have to disagree after having a few phones with MM on it and not seeing this issue.
    05-09-2016 11:08 AM
  2. IrishBaritone's Avatar
    Just bought a Samsung Galaxy S7 a few days ago. Worked fine with my Linksys EA3500. Now I'm having the same issue as others. WiFi on the phone keeps trying to connect to the network. Once it looks like it's going to connect, it turns off and on again. Cycle repeats forever. I've turned off all of the dozen or so settings everyone has described. Still jacked. Should I just take it back and try to get a new one?
    05-21-2016 08:33 PM
  3. Matt Zappasodi's Avatar
    I'm seeing the same issues on a new Verizon S7.

    I'm a sysadmin so my home network isn't what most people have. The router is a UBNT EdgeRouter, and wireless is via an AeroHive AP230 (.11ac)

    The issue isn't the infrastructure. Hopefully a update comes soon to fix it.
    Hey SRYAN i have a similar background, and UBNT setup, what did you do for the fix?
    05-31-2016 07:50 PM
  4. Matt Zappasodi's Avatar
    Any update on this sryan? I have a sinilar setup.
    06-03-2016 05:38 AM
  5. BobboloFaraglia's Avatar
    Same problem here. S7 on ATT with Linksys E4200 router. My old S4 and a Galaxy Tab S 10.5 are able to hold onto the 5GHz band with no issue. My S7 seems to lose it during standby (smart network switch is off and is set to keep wi-fi on during sleep). It will even drop connection sitting next to router. When I wake the phone, the 5GHz is not connected, but shows up in the available network list but with an error "Internet not available". I am able to select the 5GHz network manually and connect with no problems or password required. It will then hold the connection for the several minutes I am using the phone.

    Samsung tech support had me to full factory reset. I then set the device up as new and only attempted to log onto the network. Same problem.
    ATT escalated problem up to their engineering level.
    I have the same problem. Wifi works fine when the screen is on, but during standby it drops the connection and when I wake up the screen it says ''Internet not avaliable''. Then, if I turn off and on the wifi or force the connection, it will connect without problems. I have a 2.4ghz connection and the wifi channel is relatively free. I have the ''smart network switch'' disabled and the Bluetooth scanning disabled. I don't know what to do, it is a bit frustrating, considering that a couple of my friends have the galaxy S7 too but they don't have problems. My old Galaxy s4 mini and Meizu MX5 had no problems too with the same wifi.
    06-15-2016 06:18 PM
  6. L8nytr's Avatar
    At least on my Verizon unit I have wifi and bluetooth scanning off, and smart switch disabled. Still seeing the same issue. I disabled IPv6 (on the network side) for fun and that didn't help.


    Also at least on the VZW ROM Smart switch isn't enabled by default.
    You ever get your working?
    06-25-2016 02:44 AM
  7. Dacian Cristian Luta's Avatar
    You ever get your working?
    Hello, made the account , maybe will help some of you, had huge wifi problems and after i have tested everything for me the fix was to turn gps off, turning gps off gived a huge internet speed boost and amazing battery life. Wifi works like never before, hope will help. Cheers
    06-26-2016 04:21 AM
  8. Ian and Marguerite Taylor's Avatar
    My brand new wi-fi version Galaxy TAB S2 was also randomly logging on to Wi-Fi networks, then logging off, logging on to another, logging off again, etc. I had 6 wi-fi networks (a 2G and a 5G from each of the main router, an AP router and a Wi-Fi extender) here in the house with each network having a unique SSID name. I could watch the Wi-Fi Settings screen on the TAB and, every 10 seconds or so when the TAB would automatically check (as they all do) for the presence of wi-fi networks, the list would jumble about and the Tab Might drop one and sign on to another. Totally flaky communications.

    Things totally stabilized after I assigned the same SSID name to all the networks. I realize that I still have 6 networks running, each on its own radio channel, and that the TAB will jump from one to another depending on where the Tab is moved around the house. So it still will automatically change networks. But having assigned the same SSID name to them all has stopped the connection hiccups. It's all rock solid now.

    The problem was happening both before and before the Marshmallow upgrade.

    BTW, this problem was not occurring on any of my 3 Windows 10 laptops. They stayed with solid connections even when the S2 (I actually have two of them) were bouncing around, network to network.
    06-28-2016 08:40 PM
  9. Drew Garrod's Avatar
    I would tend to agree with you and I understand your point but my wife has a S7 and I have a S7 edge and both devices are the only ones having trouble on our home network. On a "top line" Linksys EA9200 this should not be occuring. Our phones work fine on other WiFi's so that supports you thought but I also have 4 apple devices, a smart tv, ps4, wii, and WiFi cameras on this home network that do not see these troubles. It is just very frustrating to go from a time of such simple setups of home wifi's and no problems to now you pay $300 for crap routers and headaches.
    07-20-2016 10:25 AM
  10. BobboloFaraglia's Avatar
    I would tend to agree with you and I understand your point but my wife has a S7 and I have a S7 edge and both devices are the only ones having trouble on our home network. On a "top line" Linksys EA9200 this should not be occuring. Our phones work fine on other WiFi's so that supports you thought but I also have 4 apple devices, a smart tv, ps4, wii, and WiFi cameras on this home network that do not see these troubles. It is just very frustrating to go from a time of such simple setups of home wifi's and no problems to now you pay $300 for crap routers and headaches.
    I had this problem on two different routers.

    With one of these routers I solved by setting the wifi channel from "automatic" to "manual".

    With the other router I solved disabling WowFi, that is a service offered from my italian internet provider. I don't know if other providers around the world offer this service and I don't know how it is called.

    Btw I have to say that with all of my previous phones I had no issue with wifi, I think that S7 has some problem handling wifi, and this is not acceptable considering its price.
    07-20-2016 12:38 PM
  11. kittenfuud's Avatar
    I can't access that link and c/p doesn't work for some reason. I even turned on my data! ??

    Galaxy Gal from 1-7!
    07-22-2016 07:40 PM
  12. daweeze02's Avatar
    Holy hell I have the same issue. I can't even download from the playstore with my rt-n66 and s7. The only fix I have found is to use my 5ghz network but the range obviously blows
    07-28-2016 06:17 PM
  13. Ereinion#AC's Avatar
    Here, my phone turn Wi-Fi and Bluetooth off, and put sound to vibration by itself, first was when disconnecting from car Bluetooth but today out of nowhere, middle of lunch time pebble buzz from disconnection.... any hints, Google does not help me much.
    07-28-2016 07:58 PM
  14. Simovic1973's Avatar
    Samsung S7 SM-G930F
    Router Linksys E1200, firmware 2.0.07

    Problem: WiFi connection drops, phone switches to 3g, usually in standby mode when the screen is turned off. There is a message next to WiFi name "Internet not available". I could manually connect to wireless, but often I don't notice and use expensive 3g instead.

    I tried several suggestions, but all of them failed:
    - Smart network switch on/off
    - Keep Wi-Fi on during sleep (all three options)
    - Location / Improve accuracy / Wi-Fi scanning / BT scanning on/off
    - phone SW update
    - router firmware update

    At the end I went to my router Wi-Fi settings / Channel width and switched from "Auto (20MHz or 40MHz)" to "20MHz only" and issue is so far solved. Not a single connection drop in last two days. I even noticed considerable improvement in standby battery drain. It went from 2% per hour to 1.3% per hour.
    08-31-2016 03:45 AM
  15. legendaky's Avatar
    Samsung S7 SM-G930F
    Router Linksys E1200, firmware 2.0.07

    Problem: WiFi connection drops, phone switches to 3g, usually in standby mode when the screen is turned off. There is a message next to WiFi name "Internet not available". I could manually connect to wireless, but often I don't notice and use expensive 3g instead.

    I tried several suggestions, but all of them failed:
    - Smart network switch on/off
    - Keep Wi-Fi on during sleep (all three options)
    - Location / Improve accuracy / Wi-Fi scanning / BT scanning on/off
    - phone SW update
    - router firmware update

    At the end I went to my router Wi-Fi settings / Channel width and switched from "Auto (20MHz or 40MHz)" to "20MHz only" and issue is so far solved. Not a single connection drop in last two days. I even noticed considerable improvement in standby battery drain. It went from 2% per hour to 1.3% per hour.
    None of the solutions here have worked, so I'd like to try yours, but I'm using Verizon? All it shows for channel width is "Auto Detect" then numbers from 1-11. Do you know what would be the equivalent?
    09-14-2016 09:49 PM
  16. AtraCulpa's Avatar
    I've been experiencing the same problem as many others here, where my S7s Wi-Fi connection would simply drop and revert to 4g after going on standby. It started happening rather suddenly where before everything worked just fine on the same network. I tried several of the solutions listed in this thread like disabling BT scanning for location accuracy, Network smart switch to no avail.

    I ended up going into my Wi-Fi settings on my router and forced it to use 802.11b mode only, as opposed to auto select.
    I checked over the specifications of the S7 again and sure enough it only supports WLAN versions 802.11 a/b/g/n/ac.

    So far no more drops or connection hitches and the home network doesn't feel any less stable.

    Hope this helps others out there!!
    09-15-2016 02:14 PM
  17. hsbdobergirl's Avatar
    My S7 just started disconnecting from WiFi. When I tryhttp://forums.androidcentral.com/editpost.php?p=5463169&do=editpost to turn WiFi on it toggles back and forth "Scanning and finds it" then "Turning Off". It vacillates back and forth about 3X then goes back to "To see available networks, turn on Wi-FI". It's not my environment. I have about multiple devices which all play together well. I've looked thru all the threads on this and checked this and that. the problem started I believe after the last software update which I recently performed. I have been out so I didn't notice it before, but I need it to work - I'm dependent on WIFI since that's what I use mostly and have a low-bandwidth data plan. Any other advice? I'm using Verizon but again, this has worked for several months until today. First thing I did was a restart. Thanks

    UPDATE 2 minutes later. For grins I turned off 'location' and it Connected. So as long as I don't broadcast my location it will connect to my WIFI, 5G or not.

    UPDATE 3: Well turning off location code temporarily fixed WIFI from not activating on the s7. Now WIFI drops all the time with no rhyme or reason. Any other ideas?
    10-04-2016 12:00 PM
  18. rob pelkie's Avatar
    Before you blame the S7, I would try the S7 with other WiFi access points. The issue may very well be with your WiFi access point (your wireless router) and not with the S7. Very often people making complaints such as yours, with their devices disconnecting, etc. are running very old, very iffy WiFi access points. Of course, there is also a chance that something in your environment is interfering (stepping on) with your WiFi and thus the intermittent disconnects. Again, do troubleshoot.... go to a different location, access a different WiFi access point and ascertain if it really is your S7.
    I have an issue with both places i use wifi in .in fact im mostly on wifi .my issues lay with the fact that i have had many andriod devices and tinkered with many services with in the os in other devices. This however strikes me as odd . So im set up on two wifi networks. on one side tech geeks run the house pc department so im good there. my device seems to have issues where i should automatically connect when im in range ... .but sometimes its like neope you wanted to use wifi ,my bad .um yeah im on but aum just power cycle the wifi on your phone and yeah your good.i dont get the odd detection system issues
    10-23-2016 02:28 AM
  19. Jakho11's Avatar
    I had the same problem. I believe this is a Bluetooth Problem. By default BT Scanning is enabled to improve location. Disabled it. This resolved the wifi disconnects for me.

    Settings > Location > Improve Accuracy > Bluetooth Scanning : Turn it off
    Do this and it will solve the problem. Thank you!
    pjniez likes this.
    11-14-2016 08:16 PM
  20. DomVoc's Avatar
    New update fixed the problem!!... so far.
    I was having the same problems as everyone else. The wifi on my S7 would turn itself on and off every few minutes. None of the posted fixes worked for me. I checked for a system update yesterday, but there wasn't one. So today, I was going to contact Samsung tech support, because they're usually pretty good at having simple fixes for problems. Just before I was going to contact them, I decided to check again to see if there was a system update, and sure enough, there was. So I updated about an hour ago. I've been successfully using wifi on my phone for 30 minutes, without any interruption. So far, it seems the update has fixed the problem. I hope this helps everyone else.
    New Version: G930VVRU4API3
    --DomVoc

    UPDATE: It's now been about 24 hours since my last post. The wifi issue still exists. However, it has only turned off/on about 6-8 times today. I'm still not happy, but it's better than every few minutes. Maybe there will be another update soon.
    --DomVoc
    11-18-2016 01:05 AM
  21. raresalm's Avatar
    I had the same problem. I believe this is a Bluetooth Problem. By default BT Scanning is enabled to improve location. Disabled it. This resolved the wifi disconnects for me.

    Settings > Location > Improve Accuracy > Bluetooth Scanning : Turn it off
    Thank you. This fixed my issue, too
    11-19-2016 11:35 AM
  22. GoLfWRC's Avatar
    I have had this kind of problem on S6 Edge before. WiFi router worked with other phones fine also S6 Edge worked on other routers fine. So I think it would be a firmware issue.
    11-19-2016 09:27 PM
  23. Velavi's Avatar
    I had the same problem. I believe this is a Bluetooth Problem. By default BT Scanning is enabled to improve location. Disabled it. This resolved the wifi disconnects for me.

    Settings > Location > Improve Accuracy > Bluetooth Scanning : Turn it off
    Thanks for this. It works for me too.

    I'm using S7 edge and for some reason the wifi kept turning itself off each time I turn it on. I disabled Bluetooth scanning and problem is solved.
    12-02-2016 01:51 PM
  24. Crusado7's Avatar
    I have the same problem right now and I don't think it's the s7's that's having a problem because the phone works on other wifi's.
    12-13-2016 07:32 PM
  25. DCJeepin101's Avatar
    OK, I got the Galaxy s7 a month ago. No issues at all. Two days ago I used the Hot Spot feature while i was out and about. Went fine. Got home, hot spot was off by then, and phone is now consistently disconnecting from the 5ghz wifi at the house when the unit goes to sleep and while sitting idle with out screen time out.
    I have tried everything mentioned in the forum and other sites and nothing has worked. I am going back to the store where i bought the phone today to see what can be done. BUT i did come up with a work around.
    I Setup a static ip for the phone on my home router. And i seem to stay connected. I still get the notice to configure wifi when i unlock the phone but it is already connected by the time i get to wifi settings. I confirmed this on the router side.
    Also another item that worked as a work around was to go to Settings > Wi-Fi > More > Advanced > Tap "Keep Wi-Fi on during sleep"
    in that menu i choose "While Charging."
    So when i unlocked the phone it did consistently re-connect to the 5ghz wifi.
    btw 2.4 ghz wifi is steady and always stays connected.
    So those are workarounds and not a fix. I will post anything significant after going to the store.
    01-14-2017 12:17 PM
54 123

Similar Threads

  1. Quick thoughts from long time iphone user
    By NuMotiv in forum Samsung Galaxy S7 edge
    Replies: 107
    Last Post: 03-18-2016, 12:30 PM
  2. Replies: 1
    Last Post: 03-12-2016, 04:27 PM
  3. Replies: 1
    Last Post: 03-12-2016, 04:25 PM
  4. Galaxy S4, can't press accept on Google Play
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 03-12-2016, 04:23 PM
  5. S7 edge sends text after reboot?
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 03-12-2016, 01:59 PM
LINK TO POST COPIED TO CLIPBOARD