03-31-2018 04:08 PM
54 123
tools
  1. tycobb280's Avatar
    I got my S7 a couple days ago. Set up and transfer of all my data went smooth with no issues. The only problem I am having is it keeps disconnecting a reconnecting to my wifi. It is constant connected disconnected connected disconnected. It's never connected long enough for me to get anything done. I have read about this issue, and fixes for previous galaxy generations, like turning off wifi power save mode. I have tried different settings, and and even tried the push button WPS connection or whatever it is with my wireless router. please help
    03-12-2016 02:25 PM
  2. BillArf's Avatar
    Before you blame the S7, I would try the S7 with other WiFi access points. The issue may very well be with your WiFi access point (your wireless router) and not with the S7. Very often people making complaints such as yours, with their devices disconnecting, etc. are running very old, very iffy WiFi access points. Of course, there is also a chance that something in your environment is interfering (stepping on) with your WiFi and thus the intermittent disconnects. Again, do troubleshoot.... go to a different location, access a different WiFi access point and ascertain if it really is your S7.
    03-12-2016 05:45 PM
  3. AndroidDale's Avatar
    Phone: Samsung Galaxy S7 Edge,Gold
    Router: ASUS Wireless Router RT-N66U

    My connection also repeatedly drops. I've messed with it a little. It's only when connected to the 5 ghz. It doesn't do it on the 2.4. I have 3 other android devices that connect just fine. I'm convinced it's the phone. There was a similar problem in many of the S5's.
    03-12-2016 11:33 PM
  4. erasat's Avatar
    Besides the point that since the S6 and S6 edge, some people reported issues with some routers using 5ghz instead of 2.4ghz, now it seems that there is s bug with Marshmallow and some WiFi IP protocols, try what I posted on this thread and see if it also works for you.

    http://forums.androidcentral.com/sam...ml#post5056269
    03-13-2016 08:25 AM
  5. sryan2k1's Avatar
    I'm seeing the same issues on a new Verizon S7.

    I'm a sysadmin so my home network isn't what most people have. The router is a UBNT EdgeRouter, and wireless is via an AeroHive AP230 (.11ac)

    The issue isn't the infrastructure. Hopefully a update comes soon to fix it.
    Craig Stevens likes this.
    03-13-2016 04:08 PM
  6. sfont84's Avatar
    Same problem here. S7 on ATT with Linksys E4200 router. My old S4 and a Galaxy Tab S 10.5 are able to hold onto the 5GHz band with no issue. My S7 seems to lose it during standby (smart network switch is off and is set to keep wi-fi on during sleep). It will even drop connection sitting next to router. When I wake the phone, the 5GHz is not connected, but shows up in the available network list but with an error "Internet not available". I am able to select the 5GHz network manually and connect with no problems or password required. It will then hold the connection for the several minutes I am using the phone.

    Samsung tech support had me to full factory reset. I then set the device up as new and only attempted to log onto the network. Same problem.
    ATT escalated problem up to their engineering level.
    03-13-2016 05:12 PM
  7. tjonesjr's Avatar
    I had the same problem. I believe this is a Bluetooth Problem. By default BT Scanning is enabled to improve location. Disabled it. This resolved the wifi disconnects for me.

    Settings > Location > Improve Accuracy > Bluetooth Scanning : Turn it off
    03-14-2016 07:52 AM
  8. mlmcgahee's Avatar
    I got my S7 a couple days ago. Set up and transfer of all my data went smooth with no issues. The only problem I am having is it keeps disconnecting a reconnecting to my wifi. It is constant connected disconnected connected disconnected. It's never connected long enough for me to get anything done. I have read about this issue, and fixes for previous galaxy generations, like turning off wifi power save mode. I have tried different settings, and and even tried the push button WPS connection or whatever it is with my wireless router. please help
    Go to WiFi settings, click more in the upper right and chose advanced. Try turning off "smart network switch". It seems to be on by default. This may resolve your issue.
    03-14-2016 11:43 AM
  9. dawaster's Avatar
    I change my setting from lte/3g/2g to 3g/2g and it seems to have sorted out the problem. It used to disconnect from wifi and stay on 4G but now it stays on wifi
    03-15-2016 04:49 PM
  10. sryan2k1's Avatar
    At least on my Verizon unit I have wifi and bluetooth scanning off, and smart switch disabled. Still seeing the same issue. I disabled IPv6 (on the network side) for fun and that didn't help.


    Also at least on the VZW ROM Smart switch isn't enabled by default.
    03-15-2016 08:50 PM
  11. vikingfuneral's Avatar
    I also have the RT-N66U. The latest router firmware might have wifi issues. I'm planning to try rolling back the firmware. I don't just have issues with my s7, but also a Sony TV.
    03-17-2016 06:32 PM
  12. Craig Stevens's Avatar
    This is definitely an S7 wifi problem! I have reset routers, wiped the cache of the S7, turned off blue-tooth, gone to recovery mode, even reset the software to factory version. It works fine for a little while, then the next thing you know, the play store doesn't work, Pandora doesn't work, etc. over wifi. Some apps work on wifi, but any app that takes streams of data, quit working on wifi. I can turn off wifi and go to 4GLte data and everything works fine. Then I turn wifi back on and everything stops. Each reset buys some time but nothing works more than a day or two at best. I'm ready to return the phone. My S5 never had these problems and works fine today. In fact, no phone I have ever had had these kind of wifi problems.
    03-18-2016 08:46 AM
  13. HNLE's Avatar
    This could be related to why listening to steaming music apps such as Soundcloud and Spotify, it keeps on pausing and stopping
    Diane Kennedy likes this.
    03-18-2016 10:32 AM
  14. Rlin5741's Avatar
    In general, I have had wifi issues on a fair number of devices when I purchased as an "early adopter" - i.e. shortly after release. The latest example is iPad Air 2, which wouldn't work with my fairly new Linksys 802.11n router. It would take a couple weeks or months before the manufacturers fixed the issues with a patch.

    From these experiences, I would say the following things have generally helped:
    • Set DIFFERENT SSIDs for 2.4 and 5GHz bands. I have found that most devices and routers do a terrible job dynamically switching between the networks if each as the same SSID - I think the chipset recognizes the SSID and constantly jumps from one band to the other depending on which had the strongest signal.
    • Disable the bluetooth and wifi SCANNING feature (not bluetooth itself as one of the prior posters cited). This setting is found in "locations" and allows your phone to scan for recognized wifi and bluetooth networks even when wifi or bluetooth is turned off to pinpoint its location. Given that bluetooth only has about a 50 ft range, its puzzling why the bluetooth scanning is even an option
    • Set the channel width in the router to 20 MHz or 40MHz. Some products can't recognize the 80MHz channel widths (my old S5 couldn't recognize my travel router if I had it set to 80MHz. Note that this may slow down your connection.
    • Disable Smart Network Switch (in Wifi Advanced settings) or other similar setting that dynamically switches between Wifi and mobile data depending on network access
    • Get 802.11ac-capable router. This may be less of an issue now, but for a couple years after the ac standard came out, a lot of ac clients would have issues with legacy non-ac routers. Obviously not ideal.
    03-18-2016 12:27 PM
  15. nightcynerg's Avatar
    The wifi on my Galaxy S7 Edge keeps disconnecting. I'm the only one on it and have extremely fast internet. I ran my s5 and s7 at the same time I completed my email, sent and opened facebook on my s5 while my s7 edge just sat there blank. I shut off my s5 and it still sat there doing nothing. it's pretty annoying that a phone that is 2yrs older is faster and better than my new one.
    03-21-2016 04:15 PM
  16. Ms Mini's Avatar
    It's a problem with some Samsung Galaxy S 7 and S7 Edge phones. I have the same problem. My cell carrier is ordering a new phone and sending this one back. My carrier said they've been getting several calls. I've had my phone 3 days.
    03-24-2016 11:01 PM
  17. vikingfuneral's Avatar
    Update:

    The ASUS rt-n66u had a recent firmware issue. I'm using stock asus firmware these days, not dd-wrt. I resolved that and still have (less frequent) issues with wifi and the s7.

    I've tweaked some settings and they seem to have helped somewhat. I turned off auto band selection and set channel width to 40MHz on the router.

    Posted via the Android Central App
    03-27-2016 04:44 PM
  18. twodaend's Avatar
    I have the S7 Edge and the Asus RT-N66U and I too have my wireless drop on the 5GHz channel. I have different SSIDs for the 2GHz (20MHz) and 5GHz (40MHz) channels and I have them both in my phone. Whenever I connect to the 5GHz, everything is fine while using the phone. However, if I put my phone down for a bit and come back to it, I get the WiFi connected noticed and it is now on my 2GHz channel. I have the latest firmware on my Asus with BT location scanning and Smart Network Switch off.

    I don't know what I could change in my router as other devices are just fine. to the 5GHz channel and stay connected (iPhone 6 Plus/5S/5, iPad, Laptop, etc.)
    03-30-2016 10:37 AM
  19. sillehrabbitz's Avatar
    DX I have a wifi connecting problem at work. It won't automatically connect to the saved network and tries to connect to the other one that doesn't work. Everywhere else it automatically connects to the saved network..except work..I have to manually click on the network for it to work. Q.Q
    03-30-2016 10:44 AM
  20. Froide's Avatar
    I had the same problem. I believe this is a Bluetooth Problem. By default BT Scanning is enabled to improve location. Disabled it. This resolved the wifi disconnects for me.

    Settings > Location > Improve Accuracy > Bluetooth Scanning : Turn it off
    This worked like a charm. Thank you!
    (FYI, Smart Switch was aleady off.)
    davebwi likes this.
    04-19-2016 09:36 PM
  21. JohnPatrick Yu's Avatar
    I got my S7 a couple days ago. Set up and transfer of all my data went smooth with no issues. The only problem I am having is it keeps disconnecting a reconnecting to my wifi. It is constant connected disconnected connected disconnected. It's never connected long enough for me to get anything done. I have read about this issue, and fixes for previous galaxy generations, like turning off wifi power save mode. I have tried different settings, and and even tried the push button WPS connection or whatever it is with my wireless router. please help
    Maybe what you mean is when your phone goes to sleep the wifi turns off?you go to wifi then more and on the keep wifi on during sleep
    05-06-2016 08:21 AM
  22. thereverend2u2's Avatar
    It's marshmellow.. Its a BIG BIG PROBLEM..
    05-06-2016 08:30 AM
  23. Tim1954's Avatar
    Make sure the"smart network switch " is not on...
    05-06-2016 10:44 PM
  24. xRuckus's Avatar
    Same thing happened to my Galaxy S7. 5G would keep disconnecting and would show "internet not available" 2.4G is perfect though. what i did was
    1. turn off smart network switch 2. turn off bluetooth scanning. 3. download wifi analyzer app from play store 4. switch router to the best channel (mine was 40)

    everythings awesome now hope this helped
    05-08-2016 10:29 PM
  25. Shivani Broghan's Avatar
    Smart Switch disabled seems to be working for now. Thanks for that suggestion.

    But it seems like a bug that even when the WiFi is back to a decent level, it will not switch back. So no more Smart Switch for me!
    05-09-2016 10:44 AM
54 123

Similar Threads

  1. Quick thoughts from long time iphone user
    By NuMotiv in forum Samsung Galaxy S7 edge
    Replies: 107
    Last Post: 03-18-2016, 12:30 PM
  2. Replies: 1
    Last Post: 03-12-2016, 04:27 PM
  3. Replies: 1
    Last Post: 03-12-2016, 04:25 PM
  4. Galaxy S4, can't press accept on Google Play
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 03-12-2016, 04:23 PM
  5. S7 edge sends text after reboot?
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 03-12-2016, 01:59 PM
LINK TO POST COPIED TO CLIPBOARD