1. kwlaznkid's Avatar
    Hi everyone,
    looking for some help here.

    I just got the s7 and my google calendar is syncing some meetings and not some and I can't figure out why

    all events are saved under the same google account email and not to the phone calendar and sync is turned on for both phones.

    as you can see one calendar has a lot more events than the other one.. this is scaring me since my life is based on my calendar and i can miss meetings and important events

    Google Calendar Sync help please!-screenshot_2016-03-14-08-00-58.jpg
    Google Calendar Sync help please!-screenshot_20160314-080103.jpg
    03-14-2016 10:46 AM
  2. B. Diddy's Avatar
    Welcome to Android Central! So you have one Google account, with multiple calendars in your Google Calendar, correct? Tap Menu>Settings, and select the calendar(s) that isn't syncing completely Make sure the Sync switch is on.
    03-14-2016 12:33 PM
  3. williams448's Avatar
    Tap your menu icon in the top left, & make sure next to your Gmail address that it doesn't say "enable sync". If it does say enable sync, then tap it & everything should sync up.

    Posted via the Android Central App using my badass Galaxy S7
    03-14-2016 04:00 PM
  4. williams448's Avatar
    Like this.

    Posted via the Android Central App using my badass Galaxy S7
    Attached Thumbnails Google Calendar Sync help please!-191.jpg  
    03-14-2016 04:04 PM
  5. syahng's Avatar
    Great graphic, but my phone doesn't show 'enable sync" Galaxy s7 2 weeks old. Google calendar app. Events entered from Chromebook and Samsung tablet show up, but events entered from phone do not sync to others.
    07-04-2016 08:06 PM
  6. mrbulin's Avatar
    I have the same problem!!!!
    09-01-2016 09:39 AM
  7. boocats's Avatar
    I'm having the same trouble. I'm using the Google Calendar app to make appointments but they are not syncing with my computer Google Calendar. Is there a conflict with the calendar that comes on the phone and Google Calendar? I am also not seeing any icon that says to enable sync...
    09-21-2016 10:05 AM
  8. 19sparky82's Avatar
    Make sure that the Samsung Calendar app has all of your alternate calendars active and syncing like you have in the Google Calendar app. In my case It seems both must match and be active to sync with the web version of Google Calendar.
    09-21-2016 03:06 PM
  9. monicakm's Avatar
    Had a similar problem with my husband's Google calendar. The information was syncing on my phone and computer but not his phone. In his case it had to do with not being signed in to Gmail. Once he signed in, his calendar updated.
    09-22-2016 03:01 AM
  10. FatGrino's Avatar
    I was having exactly the same problem on my s7 edge after the most recent Firmware update.

    I downloaded a third party calendar, sync'd that, and somehow now everything works.

    I offer no reason or explanation, only a solution... that worked once...
    07-26-2017 07:38 PM
  11. cmarsha's Avatar
    Well it's the "Village *****" here. I was having a problem with my Samsung S8 suddenly not syncing events created on the S8 to my Google Calendar. Anything posted on my Android tablet or my iMac desktop posted back to the phone. I went through all of the steps on the phone noted above -- cleaning both cache and data in "Google Calendar" and the system "Calendar storage" -- then restarting the phone. All settings looked fine. BUT....I finally found it. My guess is that my good friends at Samsung decided, as part of an update of the S8, to flip my default calendar to the "Samsung Calendar." Therefore, everything I was creating on the S8 went no further than the S8. So....if you're having this odd problem of not getting any sync of events created on your phone (or Samsung tablet), try creating a "test" event and when you do, look and see if it says "Samsung Calendar" right below where you enter the description of the event. If so, change it to "Events // [your gmail address]", save the test event, and the problem -- if this is the cause -- is resolved. Your event will now sync to the Google calendar. You'll note that the event is now a different color on your calendar from any events that you mistakenly entered on your Samsung Calendar. The only way to fix this (that I'm aware of) is to find each one of the Samsung calendar events, delete it, and reenter it on your Google Calendar. That is penance for being dumb like me.
    10-30-2017 09:55 AM
  12. nkennedymsrd's Avatar
    Well it's the "Village *****" here. I was having a problem with my Samsung S8 suddenly not syncing events created on the S8 to my Google Calendar. Anything posted on my Android tablet or my iMac desktop posted back to the phone. I went through all of the steps on the phone noted above -- cleaning both cache and data in "Google Calendar" and the system "Calendar storage" -- then restarting the phone. All settings looked fine. BUT....I finally found it. My guess is that my good friends at Samsung decided, as part of an update of the S8, to flip my default calendar to the "Samsung Calendar." Therefore, everything I was creating on the S8 went no further than the S8. So....if you're having this odd problem of not getting any sync of events created on your phone (or Samsung tablet), try creating a "test" event and when you do, look and see if it says "Samsung Calendar" right below where you enter the description of the event. If so, change it to "Events // [your gmail address]", save the test event, and the problem -- if this is the cause -- is resolved. Your event will now sync to the Google calendar. You'll note that the event is now a different color on your calendar from any events that you mistakenly entered on your Samsung Calendar. The only way to fix this (that I'm aware of) is to find each one of the Samsung calendar events, delete it, and reenter it on your Google Calendar. That is penance for being dumb like me.
    I was having the same problem with my s8 not syncing to my computer google calendar. After reading this response i checked my google calendar on my phone and sure enough there was a new Samsung calendar listed in the drop down list with all my other calendars. I simply unchecked that calendar and VOILA everything is syncing now. Changes I made by unknowingly using the calendar as Samsung had to be redone. Luckily I found out now. SHAME ON SAMSUNG. QUIT TRYING TO CONTROL MY LIFE.
    11-11-2017 10:49 AM

Similar Threads

  1. Stock email app "sync disabled"
    By kaienish in forum Samsung Galaxy S7 edge
    Replies: 7
    Last Post: 03-16-2016, 05:59 PM
  2. Replies: 1
    Last Post: 03-14-2016, 01:06 PM
  3. Samsung Note 8.0 n5100 desperate help, anyone?
    By Neo Alison in forum General Help and How To
    Replies: 0
    Last Post: 03-14-2016, 10:39 AM
  4. Replies: 1
    Last Post: 03-14-2016, 09:08 AM
  5. I don't know where to start video,can you help me ?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 03-14-2016, 08:03 AM
LINK TO POST COPIED TO CLIPBOARD