1. WadeOhh's Avatar
    I have the new Samsung S7 (non-edge version) and on wi-fi, anything that needs to talk to Google such as Play Store updates for Google apps (Gmail updates, Chrome updates, etc), Play Store downloads are even a bit hit and miss, and even apps that need to sync with Google such as Google Keep and Gmail just will not load. I get no error messages, just endless 'loading' or 'downloading' messages across the various apps. I've tried removing and re-adding my Google account to the phone, still no resolution. Its like my Google account is being block somewhere in the line on wi-fi. As soon as I turn wi-fi off, everything starts working and downloading, this all only happens on wi-fi. Samsung app updates on wi-fi seem to be a bit hit and miss too. It seems to be anything that is a 'system' type app just will not download or update. Regular web browsing in Chrome, browsing Facebook, Twitter, etc all work completely fine on wi-fi.

    I've created an account on this forum specifically because of this issue. I've been trying to fix it for 2 days, done endless searching across the web, tried everything known to man such as factory reset router, factory reset phone, nothing has resolved it and I'm at the end of my sanity.

    Please help! As mentioned, I really want to try and get this resolved.
    03-18-2016 12:36 AM
  2. zocster's Avatar
    Is it on all WiFi or just at home?
    03-18-2016 12:50 AM
  3. WadeOhh's Avatar
    Unfortunately, I haven't been able to test on another wi-fi. That was going to be my next test to see if its the phone or the router. But my wifes phone is working totally fine (android phone).
    03-18-2016 01:05 AM
  4. zocster's Avatar
    Carrier and isp info please?
    03-18-2016 01:12 AM
  5. WadeOhh's Avatar
    I'm in Australia. Phone is through Telstra and home internet is through TPG.
    03-18-2016 01:27 AM
  6. zocster's Avatar
    I'm in New Zealand. I get issues from time to time on Telstra Clear / Vodafone DNS.

    Primary DNS: 203.12.160.35
    Secondary DNS: 203.12.160.36

    Try manually entering their DNS?
    03-18-2016 01:49 AM
  7. WadeOhh's Avatar
    Sorry, I'm a bit of an ***** when it comes to this area. Can you explain a little further how to do the above?
    03-18-2016 01:59 AM
  8. sushiguy732's Avatar
    In the USA we have a similar issue and have narrowed it down to a specific app. As silly as it is, it seems that the Dunkin Donuts app causes an issue and once it is removed the phone works 100% again. Something to do with it trying to access Bluetooth but that's all I can tell you.

    Posted via the Android Central App
    ironass likes this.
    03-18-2016 05:56 AM
  9. WadeOhh's Avatar
    Yeah, I ran into that solution last night. However, I don't have that app. The phone actually won't connect to the play store right from first boot (IE: Straight after a factory reset) when all that exists on the phone are the stock apps.

    I think I've narrowed it down to something to do with IPv6 (which my ISP does not support). But I still don't know how to solve the problem.
    sushiguy732 likes this.
    03-18-2016 06:40 AM
  10. SUMIMASN's Avatar
    I'm Canada I have this problem consistently at home. I can't download anything on my home WiFi nor can I even connect to my office WiFi. The same happened to the Edge I bought and returned and the S7 I have now.
    03-18-2016 07:31 AM
  11. WadeOhh's Avatar
    I've stumbled across a bit of a fix. When I connect my phone through the VPN I use (I use Private Internet Access) that everything works as it should.

    Unfortunately, with my limited knowledge in this area of servers, IP addresses and whatnot, that I have absolutely no idea how, or why, this works, but it does. Happy days
    03-18-2016 08:34 AM
  12. Brent Winter's Avatar
    I live in the US and have been pulling my hair out trying to figure out why all of a sudden my wireless stopped loading at home. Just deleted my DunkinDonuts app. It's lightening fast again. Thanks for the information!
    Done in by the donuts!
    03-23-2016 08:17 AM
  13. Jayden Calhoun's Avatar
    FIX - go to settings< mobile network < mobile data and uncheck Enhanced LTE, wait for it to disable and begin using google apps
    03-25-2016 12:18 PM
  14. Hortish's Avatar
    I have the exact same problem...... Living in Australia, with telstra phone provider and internet with tpg, did you figure out what was going wrong?
    04-27-2016 03:50 AM
  15. Mohrfeld's Avatar
    FIX - go to settings< mobile network < mobile data and uncheck Enhanced LTE, wait for it to disable and begin using google apps
    06-19-2016 07:23 PM
  16. Durrel Brown's Avatar
    This fixed the issue for me as well. Anyone know why this is causing the problem and is there a more permanent fix?
    07-21-2016 11:29 AM

Similar Threads

  1. Edge apps visible even on lock screen
    By AndySG in forum Samsung Galaxy S7 edge
    Replies: 5
    Last Post: 03-19-2016, 12:26 AM
  2. Which app does this notification belong to
    By alexisneyers91 in forum Android Apps
    Replies: 1
    Last Post: 03-18-2016, 04:10 PM
  3. Good camera app with manual controls?
    By Soundtallica in forum Nexus 6P
    Replies: 1
    Last Post: 03-18-2016, 09:06 AM
  4. Music not showing up on computer or app but is playable
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 03-18-2016, 12:05 AM
  5. Replies: 2
    Last Post: 03-17-2016, 11:02 PM
LINK TO POST COPIED TO CLIPBOARD