07-29-2018 02:50 PM
28 12
tools
  1. AC Question's Avatar
    First time really using the forms here and I tried searching but didn't notice anything about my issue. I'm having trouble with mobile data just stopping randomly. It says mobile data is on but the data just isn't functioning. I've tried toggling airplane mode off and on but that doesn't work and neither does toggling mobile data off and back on. The only solution seems to be rebooting the phone. I bought the phone used so I can't just send it back. I'm just wondering if anybody else is having this same issue? It happened twice today and three times yesterday. It also happened over the last couple weeks randomly. I've read about people having the issue with Wi-Fi but not the mobile data. The phone is Sim unlocked now but has not been rooted and is running the stock software. Any suggestions on how to clear this issue up? Any help would be greatly appreciated.
    04-06-2016 11:03 PM
  2. H3aTeRzz's Avatar
    Hello!

    We'd love to help you out, but need more information about your phone. Can you register with us? Its Free & Easy! Some possible tips, in case your phone possesses these abilities.

    1. Remove SIM Card while phone is on>Turn Phone Off>Re-insert Sim Card>Restart phone.
    2. Enter Recover (Google, "how to enter recovery on, (Your Phone)) And then Wipe Cache Partition - No Data Will Be Loss.
    3. Get new Sim Card, if possible, "Most" carriers will do this cheap, if not free. AT&T charges 1 penny.
    4. Do a FULL FACTORY RESET. Be sure to research how to properly backup your phone, to minimize personal data loss.

    Hope this Helps!

    Chris
    04-06-2016 11:54 PM
  3. Jester23's Avatar
    Thanks, this was actually my question but I was using the Android Central Android app and it's just broken and not allowing me to post properly even though I was signed in.. I ended up posting this in the Galaxy S7 forum once I was able to get to it on the mobile site.. I've tried your suggestions and will see if that helps! Thanks!
    H3aTeRzz likes this.
    04-07-2016 02:04 AM
  4. H3aTeRzz's Avatar
    You are quite welcome, and if I've helped you, be sure to hit the like button! Have a great day.
    04-07-2016 10:26 AM
  5. Rumblee1's Avatar
    Im having this issue with my S7 edge. Verizon sending me a new sim, free. It'll be here tomorrow. If that doesn't work, I'll take a new phone.

    Posted via Android Central App
    04-17-2016 07:44 PM
  6. Rumblee1's Avatar
    I. Have the same issues and tried everything mentioned and more without luck. Getting rid of this phone.
    04-23-2016 07:38 AM
  7. Ddrake13's Avatar
    I've been having the same issue with my galaxy s7 edge..can't find much on the subject either. It happens randomly and the main reason I know its happening is my battery life drops dramatically, and the top battery drainer on my battery usage list is Call Standby. While this is happening i can't sent or receive texts or calls. Sent texts will remain in pending status while calls just drop before the first ring. Only fix I've found is only temporary, like stated from the host of this thread restarting the phone seems to be the only way to correct it...I think its been to long to just simply turn in my phone, has anyone come up with/know of a solution to this? Are our phones just lemons? Or will this likely be addressed in a upcoming patch...because come to think about it, I never had the issue until I updated the phone last.

    Edit:
    It wasn't showing the other comments last night when I posted...I've tried the first few steps short of getting a new Sims card. I'll see if it ends up fixing the issue.
    05-21-2016 10:17 PM
  8. bazgrant's Avatar
    I'll see if it ends up fixing the issue.
    Did either the new SIM card or a factory reset fix the problem?
    07-20-2016 01:49 PM
  9. Jester23's Avatar
    Did either the new SIM card or a factory reset fix the problem?
    Since I got the newest software update from my phone's carrier, the problem seems to have stopped... Including the issue I was having every once in a while where it was telling me I had no sim in even though there was. It's the July Security patched software from Bell mobility Canada that seems to have fixed the issue.
    08-21-2016 08:39 PM
  10. bazgrant's Avatar
    OK, I got a replacement SIM on Saturday, going to see if that will fix it 😃
    08-22-2016 01:43 AM
  11. Bertan's Avatar
    I have the same problem with my S7 edge. I think it has something to do with mobile data's incompatibility with wi-fi. I was on holiday couple of weeks ago and and had no wi-fi signal for most of the week. So my wi-fi was off and mobile data was on, and the mobile data just kept on working. For an entire week, no problems. But when I came back to home and turned on the wi-fi, the drops have started again.


    I got fed up yesterday and did a factory reset, but the problem came back right away today. However, while searching different forums, I saw a temporary solution that worked for me:

    Go to settings / mobile networks / network mode, switch to 2g only or 3g only, and then switch back to "lte/3g/2g (auto connect)". It starts working again and it is much much faster than restarting the phone.

    It's still pretty friggin annoying, but might be preferable than taking the phone back to Samsung and waiting days for them to return it. The thing is, sometimes it works flawless for days, and sometimes it goes bust 5 minutes after restarting the phone. Maybe they'll think they fixed the problem, and actually they have stumbled on one of those good runs. You'll take it back thinking it's all fixed, and nothing has changed...
    10-02-2016 08:53 AM
  12. motimou's Avatar
    i HAVE THE SAME PROBLEM, but I can do nothing as even if I change to what you said it does not work as there is just No NETWORK.
    Have done factory reset twice, reloaded firmware, put in a new sim NO HELP.
    All the problems have started after the last update
    But not all Samsung S7 phones have this problem as my friends S7 is perfect.
    I bought mine the first day it came out.
    10-03-2016 02:14 AM
  13. scotiez's Avatar
    What network are you people on? Do you have good signal strength? Only problems i have is when i am in an area with very low signal. Other wise i have great network reception. I am on Verizon.
    10-03-2016 06:52 AM
  14. EDM01's Avatar
    I just picked up the phone two weeks ago. It's done this issue too many times. Only fix is restarting the phone that I have found. Not ideal. I am with Fido (rogers).

    If anyone has any permanent solutions please share.
    10-08-2016 05:00 PM
  15. motimou's Avatar
    This is not a network issue its a hardware issue IF it happens too often. The only solution is to send it back to Samsung for a fix.
    10-09-2016 12:51 AM
  16. JibJab007's Avatar
    This is not a network issue its a hardware issue IF it happens too often. The only solution is to send it back to Samsung for a fix.
    Hey Motimou I have the same issue as I never had an issue with my data dropping till this latest update. I don't know if the mobile carrier makes a difference here but I have sprint. How do you know its a network issue?
    10-20-2016 05:31 PM
  17. motimou's Avatar
    Update: Got it back from the service they changed the circuit board and back cover. Its under warranty so no charge.
    11-28-2016 05:01 AM
  18. SaundersInMexico's Avatar
    Don't get hung up on it being a Samsung problem. I have the same problem with my Nexus 5x, with Android nougat. I've had the same problem for years and several previous phones. A lot of research and no answers. Only remedy is a reboot.
    12-07-2016 10:38 AM
  19. bazgrant's Avatar
    A new SIM card did actually solve it for me
    12-07-2016 11:07 AM
  20. Dan BC's Avatar
    My phone is having the same problem.
    So the only fixes are (maybe) replacing the SIM or getting a replacement phone?
    12-08-2016 01:56 PM
  21. bazgrant's Avatar
    Your carrier should send a new SIM for very low cost (or free if you ask nicely) so it is a good place to start. It definitely cured it for me
    12-08-2016 02:54 PM
  22. becool773's Avatar
    I am facing the same issue in 2017. Any fix for this?
    03-02-2017 02:13 AM
  23. bazgrant's Avatar
    I haven't had the issue at all since replacing the SIM card, I really do suggest you start there
    03-02-2017 02:45 AM
  24. Jester23's Avatar
    I had sent my phone in for service because of it. Issue is now gone after they recalibrated the LTE something or other... I don't remember exactly what it was they did but it fixed it. Same sim card as before.
    03-02-2017 08:00 PM
  25. Jooke86's Avatar
    I'm sharing my story to, for what it's worht

    I live in Sweden and I also have this problem with my brand new (as of june 2017) Galaxy s7.

    It started after I had my phone on service through my carrier (is that what it's called? My net provider?/where I also bought the phone) for a broken display, when it came back, I noticed two connected kinds of problems:

    1. I had problems with making calls and sending texts, aswell as recieving calls.
    2. I had problems connecting to the mobile data net, lacking 3g and 4g connection too often, resulting in slow internet, and not being able to access the internet at all sometimes. This seems worse when I commuting, btw.

    My Carrier sent me a new sim, had me do a factory reset, and I still had the problem. So I sent it back to my carrier to repair it again. They changed the entire circuit/mother board, sort of everything except the battery and shell, they said. BUT, the problem presists! The report said they found no problem with the phone but they did not mention any testing before the changing of the circuit/mother board. They only subjected it to standard tests after having replaced the circuit/motherboard.

    While having my phone on repair, I was given a replacement phone, a galaxy a4 or a5. It worked like a charm, no problems, even when commuting.

    Now I do not know what to do, I would have them send my another phone, I'll even take a cheaper one, as long as it works! We will see what they come up when I ask to have it checked again. I figure I'll will use it/test it for one week before reporting the issue again, though.

    My suspicion at this point is that this is a software issue since they replaced the circuit/motherboard on my phone and the issue presists.
    09-20-2017 02:03 AM
28 12

Similar Threads

  1. Re: Galaxy S7 voice to text feature missing from keyboard ?
    By AC Question in forum Samsung Galaxy S7
    Replies: 67
    Last Post: 07-14-2018, 08:22 PM
  2. Replies: 10
    Last Post: 10-26-2016, 12:33 AM
  3. Will the Samsung Galaxy S7 Edge get a privacy screen?
    By AC Question in forum Samsung Galaxy S7 edge Cases & Accessories
    Replies: 3
    Last Post: 06-24-2016, 09:09 PM
  4. Why does my light randomly flash on my Galaxy S3?
    By charlesxy in forum Samsung Galaxy S3
    Replies: 3
    Last Post: 04-27-2016, 08:49 AM
  5. Replies: 3
    Last Post: 04-06-2016, 10:26 PM
LINK TO POST COPIED TO CLIPBOARD