05-28-2018 01:33 PM
32 12
tools
  1. arktex54's Avatar
    I have read through this thread and nothing I tried worked
    I turned the items on and off to no avail. The only thing that worked for me was using Reset settings under Virtual Keyboard -> Samsung Keyboard.
    09-01-2017 03:36 PM
  2. 1raygin's Avatar
    Thanks to the suggestions offered in this thread I now have auto-correct back.
    09-23-2017 09:49 PM
  3. Starflare5's Avatar
    I have read through this thread and nothing I tried worked, finally it dawned on me that even though the English data base was selected that maybe when the device updated to Nougat perhaps it was lost. This would explain why autocorrect does nothing because there is NO database to lookup the words in. So, if youve tried everything else previously mentioned try this:

    In the Samsung Keyboard, Language and types, Manage Input languages select English(US) and the download (down arrow icon). You should see the download progress, verify "downloaded languages" English(US) is on and you should be good.

    I imagine some of the processes previously mention perhaps does a download on some devices but not on a Galaxy Tab A. So, if your pulling out your hair trying to figure this out try the above message.

    It would have been nice if someone had mentioned this as a possible problem in the release notes for Nougat but I guess that's pie in the sky!
    Regards all
    Dan

    This worked for me, and, just a note, this issue isn't just with the S7, it's across all Samsung phones running Nougat 7.0.1 and 7.1.1. I have a J700T and this saved me so much pain... Thank you again!
    11-04-2017 06:11 PM
  4. Christien Nel's Avatar
    Ok I figured it out. language and input, samsung keyboard, and then go to reset settings at the bottom, and reset keyboard settings. Hope that helps!
    I have tried all the steps.....Got my English to work again but not the Afrikaans!!!!

    What to do?????
    11-22-2017 01:18 AM
  5. Mozzalili's Avatar
    Not being able to sort this is driving me mad. The basic misspelling of words happens frequently and my s7 just won't auto correct! When I go into settings the options just aren't there! When i use my old Windows phone texting is much easier! When I go to settings all i get is: language and input, default keyboard is Samsung keyboard and there are no other options. No predictive text options, no cogs etc. Driving me mad - would love someone to find a solution for me please
    12-30-2017 02:22 AM
  6. Lmrphy08's Avatar
    My auto correct works for most area's on my S7 but when I use Google it no longer brings up autocorrect or predictive words. Very annoying! Any ideas to fix 1 issue when it works in all other areas?
    01-09-2018 07:29 AM
  7. Regi22's Avatar
    I found out how to fix mine I had to go to Language And Input > Virtual Keyboard > Samsung Keyboard > Predictive Text Turn this on if it’s off and also make sure you have an Auto Replace language selected. Mine was on but there was no language selected. Hope this helps!
    You saved me! I have been working on this until my brain almost exploded. Checking that the language was selected did it. This was the only time I've seen this suggestion in the hundreds of searches I've done.
    05-28-2018 01:33 PM
32 12

Similar Threads

  1. Week and a half old S7 Edge screen spontaneously cracked along the volume button?
    By HerRoyalSquirrelness in forum Samsung Galaxy S7 edge
    Replies: 28
    Last Post: 06-03-2018, 12:37 AM
  2. Wifi login issues S7 exynos
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 04-15-2016, 07:29 AM
  3. Auto reject list clear log
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 04-15-2016, 07:27 AM
  4. FPR LOCK S7 Please Help!
    By Shujinko in forum Ask a Question
    Replies: 1
    Last Post: 04-13-2016, 01:18 AM
  5. Replies: 1
    Last Post: 04-11-2016, 09:38 PM
LINK TO POST COPIED TO CLIPBOARD