1. mtngant's Avatar
    How do I get auto-correct to come back? It used to work, but is now gone.

    Something that can be so irritating ... can really be missed when it is gone...

    Thanks.
    04-11-2016 08:52 PM
  2. areyes163's Avatar
    Mine shut off to once. Just go to settings and turn it back on.
    04-11-2016 09:21 PM
  3. mtngant's Avatar
    Okay. I found it.

    Settings... Language and input... Samsung Keyboard... Predictive text and/or Auto check spelling.

    Previously I had tried going through "Default keyboard" but I couldn't get there by that route. You have to go through "Samsung Keyboard".

    Thanks.
    04-11-2016 09:36 PM
  4. Angelique Hogentogler's Avatar
    Thank you for posting! Mine somehow turned off and was driving me insane

    Okay. I found it.

    Settings... Language and input... Samsung Keyboard... Predictive text and/or Auto check spelling.

    Previously I had tried going through "Default keyboard" but I couldn't get there by that route. You have to go through "Samsung Keyboard".

    Thanks.
    01-05-2017 09:01 PM
  5. weaponsguru's Avatar
    My auto correct / predictive text just doesn't work - full stop!

    It is really irritating!

    I have it switched on in the correct settings i.e. In the "General Management, Language and input, Virtual keyboard, Samsung Keyboard" - I have Predictive and Auto check switched on.

    But ....

    I get some options when I am typing, but I cannot just start typing and then allow the "prediction" to be inserted (as I did with my S6 edge on Marshmallow that I just traded in).
    Even when I have typed a word - or misspelled a word, it doesn't correct it for me - it shows me some options, but the best that i (occasionally) get is my typed word - whether it is correctly spelt or not, is one of the options I can select on the top.

    There is no auto correct, no auto complete on any of the apps that I use the keyboard for.

    The phone was bought with Marshmallow in Dubai, but when I got home, I got a download message with a Nougat update which I downloaded.

    Am I the only person with this problem or are we many?
    03-08-2017 07:16 AM
  6. criscuit_love's Avatar
    My s7 did the same thing after the newest update, and I can't figure out what's up.
    03-12-2017 01:14 PM
  7. criscuit_love's Avatar
    Ok I figured it out. language and input, samsung keyboard, and then go to reset settings at the bottom, and reset keyboard settings. Hope that helps!
    03-12-2017 01:23 PM
  8. mesocyclone30's Avatar
    I notice lately when typing the words out they don't have spaces in between automatically. didn't it put the spaces in automatically by default before with Marshmallow? I'm assuming it did since I'm typing out of habit and not putting spaces in.
    03-13-2017 02:55 AM
  9. LineKill's Avatar
    I notice lately when typing the words out they don't have spaces in between automatically. didn't it put the spaces in automatically by default before with Marshmallow? I'm assuming it did since I'm typing out of habit and not putting spaces in.
    If you go to into your keyboard settings you can turn auto spacing on.
    03-13-2017 07:46 AM
  10. mesocyclone30's Avatar
    If you go to into your keyboard settings you can turn auto spacing on.
    It's already selected. Now what?
    03-13-2017 08:06 AM
  11. LineKill's Avatar
    It's already selected. Now what?
    Try turning it off and turning it back on. If that doesn't work, on the bottom of the same settings page tap reset settings and then reset keyboard settings.
    03-13-2017 08:10 AM
  12. mesocyclone30's Avatar
    Try turning it off and turning it back on. If that doesn't work, on the bottom of the same settings page tap reset settings and then reset keyboard settings.
    I reset the keyboard but it didn't help. But I know it worked for facebook this morning. But not a text message. Or on here. If I Swype it puts in the spaces.
    LineKill likes this.
    03-13-2017 01:05 PM
  13. Orion798's Avatar
    Hey all. Here's the issue essentially. When your Android or Samsung suddenly stops spell correlating, first go to settings, language input, keyboard etc. and ensure the settings for autocorrect are enabled. If they aren't, choose them and go back out to test their efficacy.

    If you find they still don't work, go back in and 'reset keyboard settings'. Then once again ensure that you've selected autocorrect etc because it might get deselected.

    If that doesn't work. Do it all over again and also restart the phone. Then check

    If that doesn't work, make sure you have the latest updates and restart.

    If that doesn't work, take phone to repair man.
    03-14-2017 06:25 AM
  14. Steerpike58's Avatar
    I reset the keyboard but it didn't help. But I know it worked for facebook this morning. But not a text message. Or on here. If I Swype it puts in the spaces.
    I have same problem with my new S7. I turned on 'auto-check spelling' and that caused words to be underlined in red, but not 'corrected' automatically. I saw no 'auto-correct' option anywhere. But I did find, under 'Predictive text', the option to 'auto-replace' words.

    This seems to be the closest to auto-correct, but is not the same ... predictive text and auto-replace seems more than just correcting mis-spelled words.

    In summary - there's
    Language and input -> Virtual Keyboard -> Samsung Keyboard -> Auto Check Spelling On/Language
    Language and input -> Virtual Keyboard -> Samsung Keyboard -> Predictive text -> On/Auto-Replace.

    So has there ever been just a simple 'auto-correct' for mis-spelled words only?
    03-14-2017 12:38 PM
  15. mesocyclone30's Avatar
    Come to find out I guess mine is messed up too. I had to retype every sentence today in messages. It gives me incorrect spellings as a suggestion when I spell a word right. Or uses all the wrong words that is irrelevant to the topic and sentence. I'm pissed. I can't take it anymore. Is this a android issue or a Samsung issue?
    03-19-2017 06:38 PM
  16. mesocyclone30's Avatar
    Come to find out I guess mine is messed up too. I had to retype every sentence today in messages. It gives me incorrect spellings as a suggestion when I spell a word right. Or uses all the wrong words that is irrelevant to the topic and sentence. I'm pissed. I can't take it anymore. Is this a android issue or a Samsung issue?
    Just found out someone else i know had the same problem. Hers is a SPRINT GS7.
    03-21-2017 02:44 PM
  17. Captainsweatpant's Avatar
    I found out how to fix mine I had to go to Language And Input > Virtual Keyboard > Samsung Keyboard > Predictive Text Turn this on if it’s off and also make sure you have an Auto Replace language selected. Mine was on but there was no language selected. Hope this helps!
    03-28-2017 03:19 PM
  18. JustineBrownlow's Avatar
    Ok I figured it out. language and input, samsung keyboard, and then go to reset settings at the bottom, and reset keyboard settings. Hope that helps!
    Thanks...this worked.
    04-05-2017 12:45 AM
  19. mesocyclone30's Avatar
    I never got it fixed. G6 is on the way so it won't be my problem anymore. Everything I typed today was frigged up.
    04-05-2017 01:26 AM
  20. Ogmagic's Avatar
    Okay I figured it out.
    Make sure your keyboard language is the same as your predictve text language.
    Mine was not working because my keyboard language was English(US) and my predictive text was English(UK)
    Make sure they are both the same .
    Same thing goes with using Auto check spelling.

    Hope I helped you guys fix the issue.
    05-17-2017 03:27 PM
  21. Rusty4508's Avatar
    I too have problem with autocorrect spelling. Previously before the last 2 updates, it worked perfectlyvand allowed me to add my own words and if i typed a part of a word, it would complete the word. Since then it is buggy and additionally will type over my own words to enter what it thinks is appropriate. It keeps doing it even after backspacing and retrying multiple times. So frustrating. What once worked gteat is now garbage. This is on a note 5
    06-21-2017 05:10 AM
  22. Strssd's Avatar
    I found this forum and read all what everyone suggested here and nothing was working for me. Super frustrated. Well..........

    I think I FINALLY found a resolution. At least it worked for me.......

    Settings
    General Management
    Language and Input
    Virtual keyboard
    Samsung keyboard
    Predictive text
    Text shortcuts
    Add

    I added my first name and my email address and my "blue" words were back! Now I don't know if the actual selection of "add" was the trigger, or if actually adding something in did it but either way I'm not going to mess with it 'cuz it's working!
    07-18-2017 10:15 AM
  23. skyeden's Avatar
    Somehow you got your auto correct settings changed. Follow the steps to get it back on
    • Go to a screen that shows the keyboard
    • Near the left “Space Bar” select and hold the “Dictation Key”
    • Then select on the “Settings” gear option
    • Below the section that says “Smart Typing”, select on “Predictive Text” and enable it
    • you'll also find there different settings like auto-capitalization and punctuation marks
    07-20-2017 06:48 AM
  24. Parson Pete's Avatar
    I've finally figured it out. I guess Samsung want to use the space to accept the auto correct word and the check mark if you want the word you spelled. It's okay so long as the auto correct is the word you want!
    07-30-2017 10:21 PM

Similar Threads

  1. Week and a half old S7 Edge screen spontaneously cracked along the volume button?
    By HerRoyalSquirrelness in forum Samsung Galaxy S7 edge
    Replies: 27
    Last Post: 03-27-2017, 09:48 AM
  2. Wifi login issues S7 exynos
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 04-15-2016, 07:29 AM
  3. Auto reject list clear log
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 04-15-2016, 07:27 AM
  4. FPR LOCK S7 Please Help!
    By Shujinko in forum Ask a Question
    Replies: 1
    Last Post: 04-13-2016, 01:18 AM
  5. Replies: 1
    Last Post: 04-11-2016, 09:38 PM
LINK TO POST COPIED TO CLIPBOARD