1. AC Question's Avatar
    Last night my phone had a software update come through but I didn't want to download it there and then because I wasn't on WiFi. It might be a coincident but ever since then my phone has been unresponsive and when I touch the screen a horizontal blue line appears and moves up and down my screen. I have tried restarting my phone several times and using the home key but nothing. Has anyone else had this problem or can help? Thanks.
    05-02-2016 12:13 AM
  2. belodion's Avatar
    I have heard of that happening. It sounds like a hardware failure, but I'll request that the thread be moved to the S7 forum for more suggestions.
    05-02-2016 04:11 AM
  3. amyb324's Avatar
    I have a similar problem with my Galaxy s7, after my system update yesterday my screen is either unresponsive or blank, only showing my wallpaper. I have to hit the recent apps button to get it going. The phone is only a few month old. I am not happy at all!
    Any suggestions on how to fix i?
    05-09-2016 10:35 AM
  4. FutureMarine26's Avatar
    Press home button 3 times, worked for me
    05-24-2016 10:24 PM

Similar Threads

  1. Replies: 6
    Last Post: 10-15-2016, 02:44 PM
  2. Replies: 2
    Last Post: 05-02-2016, 09:27 PM
  3. Replies: 1
    Last Post: 05-02-2016, 04:20 AM
  4. can't get finger print to unlock my phone s7
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 05-02-2016, 12:15 AM
  5. Replies: 0
    Last Post: 05-01-2016, 08:50 PM
LINK TO POST COPIED TO CLIPBOARD