1. werds's Avatar
    OK, So I have my unlocked T-mobile variant S7 which I moved to ATT wireless, now suddenly the Mobile Hotspot function doesn't work no matter which way I try to get to it...

    Am I doomed to needing to purchase an AT&T variant of the phone in order to get the hotspot to work??? The best I have been able to get to occur so far is for the phone to turn on the hotspot and the indicator to show up for abotu half a second before it dissapears off the screen and the dial sets to off position...
    05-15-2016 08:15 PM
  2. B. Diddy's Avatar
    My guess is that since it's a carrier-specific phone, the firmware requires the phone to be on T-Mobile for the tether to work (since tethering requires specific plans through T-Mobile, and is not free). Since you're on a different carrier now, that firmware likely prevents the phone from using the tether on AT&T.
    werds likes this.
    05-16-2016 12:50 AM
  3. dadathepanda's Avatar
    I think att requires you ro purchase a tethering plan...

    Posted via the Android Central App
    05-16-2016 01:50 PM
  4. williams448's Avatar
    AT&T does not require a tethering plan. Like mentioned above, since it's a T-Mobile phone, tethering probably requires a T-Mibile sim.

    Posted via the Android Central App with my Badass Galaxy S7
    werds likes this.
    05-16-2016 05:16 PM
  5. werds's Avatar
    Darn I think you guys may be right about the firmware - looking at some extra help text in the tethering section of the phone alludes to needing smart tethering plan, guess it's time to buy an ATT variant!

    Thanks, just needed to make sure I wasn't crazy or there wasn't a simple fix!
    B. Diddy likes this.
    05-16-2016 09:30 PM
  6. werds's Avatar
    OK, I know it has been a few months since I posted this thread but wanted to update... I briefly purchased an ATT branded version but had to send it back because of some issues with the seller (AKA they had an unpaid balance on the phone).

    So decided to just stick it out with my T-Mobile branded GS7 for a bit, one day out of boredom I flipped on the Hotspot and it worked! Since then it has functioned properly. I am GUESSING that the reason it didn't work previously may have had something to do with my switching over to ATT and it having been recent.

    The OTHER slightly interesting if possibly odd part that is YMMV, I also noticed that if I have Wifi turned on whenever I attempt to turn on hotspot, the hotspot will refuse to turn on or stay on. I have to manually shut off wifi to make sure the hotspot consistently and correctly turns on.

    I am now extremely hapy with my T-Mobile variant GS7 on AT&T! Also just recently purchased a Gear S2 T-Mobile variant smartwatch and I am LOVIGN the pairing!
    08-11-2016 10:12 AM

Similar Threads

  1. Mobile hotspot won't enable!!!
    By sarahyin in forum Samsung Galaxy S5
    Replies: 4
    Last Post: 05-16-2016, 06:12 PM
  2. Why am I getting old emails no stop
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 05-15-2016, 07:31 PM
  3. ATT phone using with Cricket, hotspot won't enable.
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 05-15-2016, 07:24 PM
  4. Replies: 0
    Last Post: 05-15-2016, 07:10 PM
  5. Replies: 0
    Last Post: 05-15-2016, 07:04 PM
LINK TO POST COPIED TO CLIPBOARD