1. ryan 27's Avatar
    My WiFi connection works perfectly when I am using chrome/other apps on my phone. However, I am not receiving push notifications from apps like groupme, snapchat, etc. and when I turn off WiFi I get flooded with the backed up notifications. Any ideas why?
    05-24-2016 09:49 PM
  2. B. Diddy's Avatar
    Welcome to Android Central! Is this only when the phone has been asleep, or does it happen when you're actively using the phone?

    Go to Settings>Wi-fi, tap More>Advanced, and look for a Smart Network Switch option, or any other kind of "optimization" setting, and turn that off. Also, do you have any preinstalled apps (especially from the carrier) that claim to optimize connections?
    05-25-2016 02:14 PM
  3. goodgnus's Avatar
    Tmobile user here, S7. Last few (2-3) days I've had the same issue. Only at home. At first I thought it was just a Cox cable issue, but it has persisted after having rebooted modem and done speed tests. Have not made any changes to phone settings. I called in to tmo and talked to a tech, they mentioned some things to do (use 5ghz instead of 2.4ghz on router, which my router does not support, make sure bluetooth is off, remove recently installed apps, etc). They also mentioned there's a known issue that Samsung is working on? My phone is up to date. I've rebooted, wiped the cache partition, turned off nearby device detect (which uses ultra low power bluetooth even if bluetooth is turned off), etc. No resolution. I have no issues at work (connected via a 7 year old apple airport) but at home the last few days almost nothing is pushing in. I can turn off wifi and get barraged with push notifications. Very odd.

    My modem/router at home is a cox provided all in one unit, Netgear N450. I've rebooted that several times as well.

    I'll probably be calling tmobile again tomorrow (I have a multi-line business plan with them) and asking for some free high speed data as I'll have to be on the cell network at home until there's some sort of resolution for this.

    I feel like I did an OS update in the last couple weeks? And I just did an update check after talking with Tmobile and the OS updated again.
    05-26-2016 01:34 AM
  4. B. Diddy's Avatar
    Welcome to Android Central! Try also disabling IPv6 in your router's settings page, if possible.
    05-26-2016 01:07 PM
  5. ryan 27's Avatar
    My smart network switch is already off and wifi is set to always stay on (even when the phone is asleep). I believe this still happens both if I am using the phone or it is asleep. Looking through my apps I do not see any optimization apps that may be affecting this. (I'm also on Verizon). I will try playing with the router settings to see if this will change anything. I just have the standard router provided by comcast xfinity.

    This is rather frustrating considering even if it is a compatibility issue with my router that if I am using WiFi in a public place I have no way of knowing whether my S7 will be compatible with the network and cause me to not see notifications.
    05-26-2016 06:33 PM
  6. B. Diddy's Avatar
    I forgot to ask that before--are you saying that this happens regardless of the wi-fi network, or is it only at home?
    05-27-2016 12:34 PM

Similar Threads

  1. S7 - events won't save to calendar
    By steensmom in forum Ask a Question
    Replies: 2
    Last Post: 07-05-2016, 04:01 PM
  2. Replies: 1
    Last Post: 06-02-2016, 10:16 AM
  3. Samsung Galaxy Note II - Water Damage
    By AC Question in forum Ask a Question
    Replies: 3
    Last Post: 05-25-2016, 10:48 PM
  4. How can I get ringback tone on galaxy s7 edge
    By AC Question in forum Ask a Question
    Replies: 2
    Last Post: 05-24-2016, 10:48 PM
  5. Replies: 1
    Last Post: 05-24-2016, 09:45 PM
LINK TO POST COPIED TO CLIPBOARD